Message ID | 20201019115044.1571-1-yanfei.xu@windriver.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | [v3] mm/compaction: Rename 'start_pfn' to 'iteration_start_pfn' in compact_zone() | expand |
On 19.10.20 13:50, yanfei.xu@windriver.com wrote: > From: Yanfei Xu <yanfei.xu@windriver.com> > > There are two 'start_pfn' declared in compact_zone() which have > different meaning. Rename the second one to 'iteration_start_pfn' > to prevent confusion. > > BTW, remove an useless semicolon. > > Signed-off-by: Yanfei Xu <yanfei.xu@windriver.com> > Acked-by: David Hildenbrand <david@redhat.com> ^ huh, where does that come from? (you should only add acks in case they were explicitly spelled out) Anyhow, now you can keep it :) Acked-by: David Hildenbrand <david@redhat.com>
diff --git a/mm/compaction.c b/mm/compaction.c index 6e0ee5641788..ee1f8439369e 100644 --- a/mm/compaction.c +++ b/mm/compaction.c @@ -2271,7 +2271,7 @@ compact_zone(struct compact_control *cc, struct capture_control *capc) while ((ret = compact_finished(cc)) == COMPACT_CONTINUE) { int err; - unsigned long start_pfn = cc->migrate_pfn; + unsigned long iteration_start_pfn = cc->migrate_pfn; /* * Avoid multiple rescans which can happen if a page cannot be @@ -2283,7 +2283,7 @@ compact_zone(struct compact_control *cc, struct capture_control *capc) */ cc->rescan = false; if (pageblock_start_pfn(last_migrated_pfn) == - pageblock_start_pfn(start_pfn)) { + pageblock_start_pfn(iteration_start_pfn)) { cc->rescan = true; } @@ -2307,8 +2307,7 @@ compact_zone(struct compact_control *cc, struct capture_control *capc) goto check_drain; case ISOLATE_SUCCESS: update_cached = false; - last_migrated_pfn = start_pfn; - ; + last_migrated_pfn = iteration_start_pfn; } err = migrate_pages(&cc->migratepages, compaction_alloc,