Message ID | 20220104021729.111006-1-mike.kravetz@oracle.com (mailing list archive) |
---|---|
State | New |
Headers | show |
Series | userfaultfd/selftests: clean up hugetlb allocation code | expand |
On Mon, Jan 3, 2022 at 6:17 PM Mike Kravetz <mike.kravetz@oracle.com> wrote: > > The message for commit f5c73297181c ("userfaultfd/selftests: fix hugetlb > area allocations") says there is no need to create a hugetlb file in the > non-shared testing case. However, the commit did not actually change > the code to prevent creation of the file. > > While it is technically true that there is no need to create and use a > hugetlb file in the case of non-shared-testing, it is useful. This is > because 'hole punching' of a hugetlb file has the potentially incorrect > side effect of also removing pages from private mappings. The > userfaultfd test relies on this side effect for removing pages from the > destination buffer during rounds of stress testing. > > Remove the incomplete code that was added to deal with no hugetlb file. > Just keep the code that prevents reserves from being created for the > destination area. > > Signed-off-by: Mike Kravetz <mike.kravetz@oracle.com> > --- > tools/testing/selftests/vm/userfaultfd.c | 15 ++++++--------- > 1 file changed, 6 insertions(+), 9 deletions(-) > > diff --git a/tools/testing/selftests/vm/userfaultfd.c b/tools/testing/selftests/vm/userfaultfd.c > index 9354a5e0321c..0b543a9a42b2 100644 > --- a/tools/testing/selftests/vm/userfaultfd.c > +++ b/tools/testing/selftests/vm/userfaultfd.c > @@ -87,7 +87,7 @@ static bool test_uffdio_minor = false; > > static bool map_shared; > static int shm_fd; > -static int huge_fd = -1; /* only used for hugetlb_shared test */ > +static int huge_fd; > static char *huge_fd_off0; > static unsigned long long *count_verify; > static int uffd = -1; > @@ -223,9 +223,6 @@ static void noop_alias_mapping(__u64 *start, size_t len, unsigned long offset) > > static void hugetlb_release_pages(char *rel_area) > { > - if (huge_fd == -1) > - return; > - > if (fallocate(huge_fd, FALLOC_FL_PUNCH_HOLE | FALLOC_FL_KEEP_SIZE, > rel_area == huge_fd_off0 ? 0 : nr_pages * page_size, > nr_pages * page_size)) > @@ -238,17 +235,17 @@ static void hugetlb_allocate_area(void **alloc_area) > char **alloc_area_alias; > > *alloc_area = mmap(NULL, nr_pages * page_size, PROT_READ | PROT_WRITE, > - map_shared ? MAP_SHARED : > - MAP_PRIVATE | MAP_HUGETLB | > + (map_shared ? MAP_SHARED : MAP_PRIVATE) | > + MAP_HUGETLB | > (*alloc_area == area_src ? 0 : MAP_NORESERVE), > - huge_fd, > - *alloc_area == area_src ? 0 : nr_pages * page_size); > + huge_fd, *alloc_area == area_src ? 0 : > + nr_pages * page_size); Sorry to nitpick, but I think it was slightly more readable when the ternary was all on one line. > if (*alloc_area == MAP_FAILED) > err("mmap of hugetlbfs file failed"); > > if (map_shared) { > area_alias = mmap(NULL, nr_pages * page_size, PROT_READ | PROT_WRITE, > - MAP_SHARED, > + MAP_SHARED | MAP_HUGETLB, > huge_fd, *alloc_area == area_src ? 0 : > nr_pages * page_size); > if (area_alias == MAP_FAILED) > -- > 2.33.1 > Looks functionally correct to me besides the one style gripe, Reviewed-by: Axel Rasmussen <axelrasmussen@google.com>
On 1/4/22 14:35, Axel Rasmussen wrote: > On Mon, Jan 3, 2022 at 6:17 PM Mike Kravetz <mike.kravetz@oracle.com> wrote: > > Looks functionally correct to me besides the one style gripe, > > Reviewed-by: Axel Rasmussen <axelrasmussen@google.com> Thanks Axel! The userfaultfd test is not so easy to follow. While looking at this, I noticed that we skip the mremap() testing for hugetlb. However, Mina recently added hugetlb mremap support. Unfortunately, mremap hugetlb testing fails if enabled. I am still trying to determine the root cause, but would like to eliminate this special case if possible.
On Tue, 4 Jan 2022 14:35:34 -0800 Axel Rasmussen <axelrasmussen@google.com> wrote: > On Mon, Jan 3, 2022 at 6:17 PM Mike Kravetz <mike.kravetz@oracle.com> wrote: > > > > The message for commit f5c73297181c ("userfaultfd/selftests: fix hugetlb > > area allocations") says there is no need to create a hugetlb file in the > > non-shared testing case. However, the commit did not actually change > > the code to prevent creation of the file. > > > > While it is technically true that there is no need to create and use a > > hugetlb file in the case of non-shared-testing, it is useful. This is > > because 'hole punching' of a hugetlb file has the potentially incorrect > > side effect of also removing pages from private mappings. The > > userfaultfd test relies on this side effect for removing pages from the > > destination buffer during rounds of stress testing. > > > > Remove the incomplete code that was added to deal with no hugetlb file. > > Just keep the code that prevents reserves from being created for the > > destination area. > > > > *alloc_area = mmap(NULL, nr_pages * page_size, PROT_READ | PROT_WRITE, > > - map_shared ? MAP_SHARED : > > - MAP_PRIVATE | MAP_HUGETLB | > > + (map_shared ? MAP_SHARED : MAP_PRIVATE) | > > + MAP_HUGETLB | > > (*alloc_area == area_src ? 0 : MAP_NORESERVE), > > - huge_fd, > > - *alloc_area == area_src ? 0 : nr_pages * page_size); > > + huge_fd, *alloc_area == area_src ? 0 : > > + nr_pages * page_size); > > Sorry to nitpick, but I think it was slightly more readable when the > ternary was all on one line. When you have that many arguments I think it's clearer to put one per line, viz. *alloc_area = mmap(NULL, nr_pages * page_size, PROT_READ | PROT_WRITE, (map_shared ? MAP_SHARED : MAP_PRIVATE) | MAP_HUGETLB | (*alloc_area == area_src ? 0 : MAP_NORESERVE), huge_fd, *alloc_area == area_src ? 0 : nr_pages * page_size); But whatever...
On 1/5/22 15:56, Andrew Morton wrote: > On Tue, 4 Jan 2022 14:35:34 -0800 Axel Rasmussen <axelrasmussen@google.com> wrote: > >> On Mon, Jan 3, 2022 at 6:17 PM Mike Kravetz <mike.kravetz@oracle.com> wrote: >>> >>> The message for commit f5c73297181c ("userfaultfd/selftests: fix hugetlb >>> area allocations") says there is no need to create a hugetlb file in the >>> non-shared testing case. However, the commit did not actually change >>> the code to prevent creation of the file. >>> >>> While it is technically true that there is no need to create and use a >>> hugetlb file in the case of non-shared-testing, it is useful. This is >>> because 'hole punching' of a hugetlb file has the potentially incorrect >>> side effect of also removing pages from private mappings. The >>> userfaultfd test relies on this side effect for removing pages from the >>> destination buffer during rounds of stress testing. >>> >>> Remove the incomplete code that was added to deal with no hugetlb file. >>> Just keep the code that prevents reserves from being created for the >>> destination area. >>> >>> *alloc_area = mmap(NULL, nr_pages * page_size, PROT_READ | PROT_WRITE, >>> - map_shared ? MAP_SHARED : >>> - MAP_PRIVATE | MAP_HUGETLB | >>> + (map_shared ? MAP_SHARED : MAP_PRIVATE) | >>> + MAP_HUGETLB | >>> (*alloc_area == area_src ? 0 : MAP_NORESERVE), >>> - huge_fd, >>> - *alloc_area == area_src ? 0 : nr_pages * page_size); >>> + huge_fd, *alloc_area == area_src ? 0 : >>> + nr_pages * page_size); >> >> Sorry to nitpick, but I think it was slightly more readable when the >> ternary was all on one line. > > When you have that many arguments I think it's clearer to put one per > line, viz. > > *alloc_area = mmap(NULL, > nr_pages * page_size, > PROT_READ | PROT_WRITE, > (map_shared ? MAP_SHARED : MAP_PRIVATE) | > MAP_HUGETLB | > (*alloc_area == area_src ? 0 : MAP_NORESERVE), > huge_fd, > *alloc_area == area_src ? 0 : nr_pages * page_size); > > > But whatever... I agree, and also agree with Axel's comment about keeping the ternary all on one line. However, there are examples of breaking both these conventions throughout the file. My intention here was just to clean up the mess I created with the previous patch. As such, I would prefer to leave this patch as is. If someone really wants this modified, I will. However, IMO if we make this one call easier to read, we should use the same convention throughout the file. I can do that as well, but would prefer to first try to enable using mremap with hugetlb within the test.
On Thu, Jan 6, 2022 at 9:43 AM Mike Kravetz <mike.kravetz@oracle.com> wrote: > > On 1/5/22 15:56, Andrew Morton wrote: > > On Tue, 4 Jan 2022 14:35:34 -0800 Axel Rasmussen <axelrasmussen@google.com> wrote: > > > >> On Mon, Jan 3, 2022 at 6:17 PM Mike Kravetz <mike.kravetz@oracle.com> wrote: > >>> > >>> The message for commit f5c73297181c ("userfaultfd/selftests: fix hugetlb > >>> area allocations") says there is no need to create a hugetlb file in the > >>> non-shared testing case. However, the commit did not actually change > >>> the code to prevent creation of the file. > >>> > >>> While it is technically true that there is no need to create and use a > >>> hugetlb file in the case of non-shared-testing, it is useful. This is > >>> because 'hole punching' of a hugetlb file has the potentially incorrect > >>> side effect of also removing pages from private mappings. The > >>> userfaultfd test relies on this side effect for removing pages from the > >>> destination buffer during rounds of stress testing. > >>> > >>> Remove the incomplete code that was added to deal with no hugetlb file. > >>> Just keep the code that prevents reserves from being created for the > >>> destination area. > >>> > >>> *alloc_area = mmap(NULL, nr_pages * page_size, PROT_READ | PROT_WRITE, > >>> - map_shared ? MAP_SHARED : > >>> - MAP_PRIVATE | MAP_HUGETLB | > >>> + (map_shared ? MAP_SHARED : MAP_PRIVATE) | > >>> + MAP_HUGETLB | > >>> (*alloc_area == area_src ? 0 : MAP_NORESERVE), > >>> - huge_fd, > >>> - *alloc_area == area_src ? 0 : nr_pages * page_size); > >>> + huge_fd, *alloc_area == area_src ? 0 : > >>> + nr_pages * page_size); > >> > >> Sorry to nitpick, but I think it was slightly more readable when the > >> ternary was all on one line. > > > > When you have that many arguments I think it's clearer to put one per > > line, viz. > > > > *alloc_area = mmap(NULL, > > nr_pages * page_size, > > PROT_READ | PROT_WRITE, > > (map_shared ? MAP_SHARED : MAP_PRIVATE) | > > MAP_HUGETLB | > > (*alloc_area == area_src ? 0 : MAP_NORESERVE), > > huge_fd, > > *alloc_area == area_src ? 0 : nr_pages * page_size); > > > > > > But whatever... > I agree, and also agree with Axel's comment about keeping the ternary all on > one line. However, there are examples of breaking both these conventions throughout the file. For what it's worth, I don't at all mind Andrew's way either, where the two "outcomes" of the ternary are indented a bit. Not a big deal though, whatever you'd prefer is fine. :) > > My intention here was just to clean up the mess I created with the previous > patch. As such, I would prefer to leave this patch as is. If someone really > wants this modified, I will. However, IMO if we make this one call easier > to read, we should use the same convention throughout the file. I can do that > as well, but would prefer to first try to enable using mremap with hugetlb > within the test. +1, sounds like a good plan. > -- > Mike Kravetz
diff --git a/tools/testing/selftests/vm/userfaultfd.c b/tools/testing/selftests/vm/userfaultfd.c index 9354a5e0321c..0b543a9a42b2 100644 --- a/tools/testing/selftests/vm/userfaultfd.c +++ b/tools/testing/selftests/vm/userfaultfd.c @@ -87,7 +87,7 @@ static bool test_uffdio_minor = false; static bool map_shared; static int shm_fd; -static int huge_fd = -1; /* only used for hugetlb_shared test */ +static int huge_fd; static char *huge_fd_off0; static unsigned long long *count_verify; static int uffd = -1; @@ -223,9 +223,6 @@ static void noop_alias_mapping(__u64 *start, size_t len, unsigned long offset) static void hugetlb_release_pages(char *rel_area) { - if (huge_fd == -1) - return; - if (fallocate(huge_fd, FALLOC_FL_PUNCH_HOLE | FALLOC_FL_KEEP_SIZE, rel_area == huge_fd_off0 ? 0 : nr_pages * page_size, nr_pages * page_size)) @@ -238,17 +235,17 @@ static void hugetlb_allocate_area(void **alloc_area) char **alloc_area_alias; *alloc_area = mmap(NULL, nr_pages * page_size, PROT_READ | PROT_WRITE, - map_shared ? MAP_SHARED : - MAP_PRIVATE | MAP_HUGETLB | + (map_shared ? MAP_SHARED : MAP_PRIVATE) | + MAP_HUGETLB | (*alloc_area == area_src ? 0 : MAP_NORESERVE), - huge_fd, - *alloc_area == area_src ? 0 : nr_pages * page_size); + huge_fd, *alloc_area == area_src ? 0 : + nr_pages * page_size); if (*alloc_area == MAP_FAILED) err("mmap of hugetlbfs file failed"); if (map_shared) { area_alias = mmap(NULL, nr_pages * page_size, PROT_READ | PROT_WRITE, - MAP_SHARED, + MAP_SHARED | MAP_HUGETLB, huge_fd, *alloc_area == area_src ? 0 : nr_pages * page_size); if (area_alias == MAP_FAILED)
The message for commit f5c73297181c ("userfaultfd/selftests: fix hugetlb area allocations") says there is no need to create a hugetlb file in the non-shared testing case. However, the commit did not actually change the code to prevent creation of the file. While it is technically true that there is no need to create and use a hugetlb file in the case of non-shared-testing, it is useful. This is because 'hole punching' of a hugetlb file has the potentially incorrect side effect of also removing pages from private mappings. The userfaultfd test relies on this side effect for removing pages from the destination buffer during rounds of stress testing. Remove the incomplete code that was added to deal with no hugetlb file. Just keep the code that prevents reserves from being created for the destination area. Signed-off-by: Mike Kravetz <mike.kravetz@oracle.com> --- tools/testing/selftests/vm/userfaultfd.c | 15 ++++++--------- 1 file changed, 6 insertions(+), 9 deletions(-)