Message ID | 20221228113413.10329-3-wangkefeng.wang@huawei.com (mailing list archive) |
---|---|
State | New |
Headers | show |
Series | mm: convert page_idle/damon to use folios | expand |
On Wed, Dec 28, 2022 at 07:34:08PM +0800, Kefeng Wang wrote: > +static inline struct page *damon_get_page(unsigned long pfn) > +{ > + struct folio *folio = damon_get_folio(pfn); > + > + /* when folio is NULL, return &(0->page) mean return NULL */ > + return &folio->page; I really don't think this comment is needed. This is the standard idiom for converting from a folio to its head page.
Hi Matthew, On Wed, 28 Dec 2022 22:36:20 +0000 Matthew Wilcox <willy@infradead.org> wrote: > On Wed, Dec 28, 2022 at 07:34:08PM +0800, Kefeng Wang wrote: > > +static inline struct page *damon_get_page(unsigned long pfn) > > +{ > > + struct folio *folio = damon_get_folio(pfn); > > + > > + /* when folio is NULL, return &(0->page) mean return NULL */ > > + return &folio->page; > > I really don't think this comment is needed. This is the standard idiom > for converting from a folio to its head page. Well, I think some of DAMON code readers (at least me) might not yet that familiar with Folio, as it has not been a while since DAMON started using Folio. Also, maybe I overlooked some comments or documents, but I was unable to sure if the offset of 'page' in 'folio' is intended to be never changed with any future changes, or not. So I thought adding one more line of explanation here could be helpful for someone. I also show some code using 'folio_page(folio, 0)', so I might not be the only one who at least sometimes forget the idiom. For helping people remember this idiom easier, what do you think about having a new macro or static inline function, say, 'folio_head_page()' and comment why passing NULL is ok on the function? IMHO, that would be easier to read. Thanks, SJ
diff --git a/mm/damon/ops-common.c b/mm/damon/ops-common.c index 75409601f934..1294a256a87c 100644 --- a/mm/damon/ops-common.c +++ b/mm/damon/ops-common.c @@ -16,21 +16,25 @@ * Get an online page for a pfn if it's in the LRU list. Otherwise, returns * NULL. * - * The body of this function is stolen from the 'page_idle_get_page()'. We + * The body of this function is stolen from the 'page_idle_get_folio()'. We * steal rather than reuse it because the code is quite simple. */ -struct page *damon_get_page(unsigned long pfn) +struct folio *damon_get_folio(unsigned long pfn) { struct page *page = pfn_to_online_page(pfn); + struct folio *folio; - if (!page || !PageLRU(page) || !get_page_unless_zero(page)) + if (!page || PageTail(page)) return NULL; - if (unlikely(!PageLRU(page))) { - put_page(page); - page = NULL; + folio = page_folio(page); + if (!folio_test_lru(folio) || !folio_try_get(folio)) + return NULL; + if (unlikely(page_folio(page) != folio || !folio_test_lru(folio))) { + folio_put(folio); + folio = NULL; } - return page; + return folio; } void damon_ptep_mkold(pte_t *pte, struct mm_struct *mm, unsigned long addr) diff --git a/mm/damon/ops-common.h b/mm/damon/ops-common.h index 8d82d3722204..65f290f0a9d6 100644 --- a/mm/damon/ops-common.h +++ b/mm/damon/ops-common.h @@ -7,7 +7,14 @@ #include <linux/damon.h> -struct page *damon_get_page(unsigned long pfn); +struct folio *damon_get_folio(unsigned long pfn); +static inline struct page *damon_get_page(unsigned long pfn) +{ + struct folio *folio = damon_get_folio(pfn); + + /* when folio is NULL, return &(0->page) mean return NULL */ + return &folio->page; +} void damon_ptep_mkold(pte_t *pte, struct mm_struct *mm, unsigned long addr); void damon_pmdp_mkold(pmd_t *pmd, struct mm_struct *mm, unsigned long addr);
Introduce damon_get_folio(), and the temporary wrapper function damon_get_page(), which help us to convert damon related functions to use folios, and it will be dropped once the conversion is completed. Signed-off-by: Kefeng Wang <wangkefeng.wang@huawei.com> --- mm/damon/ops-common.c | 18 +++++++++++------- mm/damon/ops-common.h | 9 ++++++++- 2 files changed, 19 insertions(+), 8 deletions(-)