Message ID | 20230609075528.9390-10-bhe@redhat.com (mailing list archive) |
---|---|
State | New |
Headers | show |
Series | mm: ioremap: Convert architectures to take GENERIC_IOREMAP way | expand |
Looks good:
Reviewed-by: Christoph Hellwig <hch@lst.de>
On Fri, Jun 09, 2023 at 03:55:18PM +0800, Baoquan He wrote: > By taking GENERIC_IOREMAP method, the generic generic_ioremap_prot(), > generic_iounmap(), and their generic wrapper ioremap_prot(), ioremap() > and iounmap() are all visible and available to arch. Arch needs to > provide wrapper functions to override the generic versions if there's > arch specific handling in its ioremap_prot(), ioremap() or iounmap(). > This change will simplify implementation by removing duplicated codes > with generic_ioremap_prot() and generic_iounmap(), and has the equivalent > functioality as before. > > For openrisc, the current ioremap() and iounmap() are the same as > generic version. After taking GENERIC_IOREMAP way, the old ioremap() > and iounmap() can be completely removed. > > Signed-off-by: Baoquan He <bhe@redhat.com> > Cc: Stafford Horne <shorne@gmail.com> > Cc: Jonas Bonn <jonas@southpole.se> > Cc: Stefan Kristiansson <stefan.kristiansson@saunalahti.fi> > Cc: openrisc@lists.librecores.org Reviewed-by: Mike Rapoport (IBM) <rppt@kernel.org> > --- > v5->v6: > Remove iounmap() because it's the same as the generic version since we > have removed the code handling ealry mapping from fixmap pool in > patch 3 - Mike > > arch/openrisc/Kconfig | 1 + > arch/openrisc/include/asm/io.h | 11 ++++---- > arch/openrisc/mm/ioremap.c | 49 ---------------------------------- > 3 files changed, 7 insertions(+), 54 deletions(-) > > diff --git a/arch/openrisc/Kconfig b/arch/openrisc/Kconfig > index c7f282f60f64..fd9bb76a610b 100644 > --- a/arch/openrisc/Kconfig > +++ b/arch/openrisc/Kconfig > @@ -21,6 +21,7 @@ config OPENRISC > select GENERIC_IRQ_PROBE > select GENERIC_IRQ_SHOW > select GENERIC_PCI_IOMAP > + select GENERIC_IOREMAP > select GENERIC_CPU_DEVICES > select HAVE_PCI > select HAVE_UID16 > diff --git a/arch/openrisc/include/asm/io.h b/arch/openrisc/include/asm/io.h > index ee6043a03173..5a6f0f16a5ce 100644 > --- a/arch/openrisc/include/asm/io.h > +++ b/arch/openrisc/include/asm/io.h > @@ -15,6 +15,8 @@ > #define __ASM_OPENRISC_IO_H > > #include <linux/types.h> > +#include <asm/pgalloc.h> > +#include <asm/pgtable.h> > > /* > * PCI: We do not use IO ports in OpenRISC > @@ -27,11 +29,10 @@ > #define PIO_OFFSET 0 > #define PIO_MASK 0 > > -#define ioremap ioremap > -void __iomem *ioremap(phys_addr_t offset, unsigned long size); > - > -#define iounmap iounmap > -extern void iounmap(volatile void __iomem *addr); > +/* > + * I/O memory mapping functions. > + */ > +#define _PAGE_IOREMAP (pgprot_val(PAGE_KERNEL) | _PAGE_CI) > > #include <asm-generic/io.h> > > diff --git a/arch/openrisc/mm/ioremap.c b/arch/openrisc/mm/ioremap.c > index cdbcc7e73684..91c8259d4b7e 100644 > --- a/arch/openrisc/mm/ioremap.c > +++ b/arch/openrisc/mm/ioremap.c > @@ -22,55 +22,6 @@ > > extern int mem_init_done; > > -/* > - * Remap an arbitrary physical address space into the kernel virtual > - * address space. Needed when the kernel wants to access high addresses > - * directly. > - * > - * NOTE! We need to allow non-page-aligned mappings too: we will obviously > - * have to convert them into an offset in a page-aligned mapping, but the > - * caller shouldn't need to know that small detail. > - */ > -void __iomem *__ref ioremap(phys_addr_t addr, unsigned long size) > -{ > - phys_addr_t p; > - unsigned long v; > - unsigned long offset, last_addr; > - struct vm_struct *area = NULL; > - > - /* Don't allow wraparound or zero size */ > - last_addr = addr + size - 1; > - if (!size || last_addr < addr) > - return NULL; > - > - /* > - * Mappings have to be page-aligned > - */ > - offset = addr & ~PAGE_MASK; > - p = addr & PAGE_MASK; > - size = PAGE_ALIGN(last_addr + 1) - p; > - > - area = get_vm_area(size, VM_IOREMAP); > - if (!area) > - return NULL; > - v = (unsigned long)area->addr; > - > - if (ioremap_page_range(v, v + size, p, > - __pgprot(pgprot_val(PAGE_KERNEL) | _PAGE_CI))) { > - vfree(area->addr); > - return NULL; > - } > - > - return (void __iomem *)(offset + (char *)v); > -} > -EXPORT_SYMBOL(ioremap); > - > -void iounmap(volatile void __iomem *addr) > -{ > - return vfree((void *)(PAGE_MASK & (unsigned long)addr)); > -} > -EXPORT_SYMBOL(iounmap); > - > /** > * OK, this one's a bit tricky... ioremap can get called before memory is > * initialized (early serial console does this) and will want to alloc a page > -- > 2.34.1 >
diff --git a/arch/openrisc/Kconfig b/arch/openrisc/Kconfig index c7f282f60f64..fd9bb76a610b 100644 --- a/arch/openrisc/Kconfig +++ b/arch/openrisc/Kconfig @@ -21,6 +21,7 @@ config OPENRISC select GENERIC_IRQ_PROBE select GENERIC_IRQ_SHOW select GENERIC_PCI_IOMAP + select GENERIC_IOREMAP select GENERIC_CPU_DEVICES select HAVE_PCI select HAVE_UID16 diff --git a/arch/openrisc/include/asm/io.h b/arch/openrisc/include/asm/io.h index ee6043a03173..5a6f0f16a5ce 100644 --- a/arch/openrisc/include/asm/io.h +++ b/arch/openrisc/include/asm/io.h @@ -15,6 +15,8 @@ #define __ASM_OPENRISC_IO_H #include <linux/types.h> +#include <asm/pgalloc.h> +#include <asm/pgtable.h> /* * PCI: We do not use IO ports in OpenRISC @@ -27,11 +29,10 @@ #define PIO_OFFSET 0 #define PIO_MASK 0 -#define ioremap ioremap -void __iomem *ioremap(phys_addr_t offset, unsigned long size); - -#define iounmap iounmap -extern void iounmap(volatile void __iomem *addr); +/* + * I/O memory mapping functions. + */ +#define _PAGE_IOREMAP (pgprot_val(PAGE_KERNEL) | _PAGE_CI) #include <asm-generic/io.h> diff --git a/arch/openrisc/mm/ioremap.c b/arch/openrisc/mm/ioremap.c index cdbcc7e73684..91c8259d4b7e 100644 --- a/arch/openrisc/mm/ioremap.c +++ b/arch/openrisc/mm/ioremap.c @@ -22,55 +22,6 @@ extern int mem_init_done; -/* - * Remap an arbitrary physical address space into the kernel virtual - * address space. Needed when the kernel wants to access high addresses - * directly. - * - * NOTE! We need to allow non-page-aligned mappings too: we will obviously - * have to convert them into an offset in a page-aligned mapping, but the - * caller shouldn't need to know that small detail. - */ -void __iomem *__ref ioremap(phys_addr_t addr, unsigned long size) -{ - phys_addr_t p; - unsigned long v; - unsigned long offset, last_addr; - struct vm_struct *area = NULL; - - /* Don't allow wraparound or zero size */ - last_addr = addr + size - 1; - if (!size || last_addr < addr) - return NULL; - - /* - * Mappings have to be page-aligned - */ - offset = addr & ~PAGE_MASK; - p = addr & PAGE_MASK; - size = PAGE_ALIGN(last_addr + 1) - p; - - area = get_vm_area(size, VM_IOREMAP); - if (!area) - return NULL; - v = (unsigned long)area->addr; - - if (ioremap_page_range(v, v + size, p, - __pgprot(pgprot_val(PAGE_KERNEL) | _PAGE_CI))) { - vfree(area->addr); - return NULL; - } - - return (void __iomem *)(offset + (char *)v); -} -EXPORT_SYMBOL(ioremap); - -void iounmap(volatile void __iomem *addr) -{ - return vfree((void *)(PAGE_MASK & (unsigned long)addr)); -} -EXPORT_SYMBOL(iounmap); - /** * OK, this one's a bit tricky... ioremap can get called before memory is * initialized (early serial console does this) and will want to alloc a page
By taking GENERIC_IOREMAP method, the generic generic_ioremap_prot(), generic_iounmap(), and their generic wrapper ioremap_prot(), ioremap() and iounmap() are all visible and available to arch. Arch needs to provide wrapper functions to override the generic versions if there's arch specific handling in its ioremap_prot(), ioremap() or iounmap(). This change will simplify implementation by removing duplicated codes with generic_ioremap_prot() and generic_iounmap(), and has the equivalent functioality as before. For openrisc, the current ioremap() and iounmap() are the same as generic version. After taking GENERIC_IOREMAP way, the old ioremap() and iounmap() can be completely removed. Signed-off-by: Baoquan He <bhe@redhat.com> Cc: Stafford Horne <shorne@gmail.com> Cc: Jonas Bonn <jonas@southpole.se> Cc: Stefan Kristiansson <stefan.kristiansson@saunalahti.fi> Cc: openrisc@lists.librecores.org --- v5->v6: Remove iounmap() because it's the same as the generic version since we have removed the code handling ealry mapping from fixmap pool in patch 3 - Mike arch/openrisc/Kconfig | 1 + arch/openrisc/include/asm/io.h | 11 ++++---- arch/openrisc/mm/ioremap.c | 49 ---------------------------------- 3 files changed, 7 insertions(+), 54 deletions(-)