Message ID | 20230715033708.2568201-1-linmiaohe@huawei.com (mailing list archive) |
---|---|
State | New |
Headers | show |
Series | memory tier: Use helper macro __ATTR_RW() | expand |
On 2023/7/15 11:37, Miaohe Lin wrote: > Use helper macro __ATTR_RW to define numa demotion attributes. Minor > readability improvement. > Sorry, I shouldn't change the interface name. Please ignore this patch. Will send a new one. Thanks.
diff --git a/mm/memory-tiers.c b/mm/memory-tiers.c index c49ab03f49b1..2898701b5209 100644 --- a/mm/memory-tiers.c +++ b/mm/memory-tiers.c @@ -693,8 +693,7 @@ static ssize_t numa_demotion_enabled_store(struct kobject *kobj, } static struct kobj_attribute numa_demotion_enabled_attr = - __ATTR(demotion_enabled, 0644, numa_demotion_enabled_show, - numa_demotion_enabled_store); + __ATTR_RW(numa_demotion_enabled); static struct attribute *numa_attrs[] = { &numa_demotion_enabled_attr.attr,
Use helper macro __ATTR_RW to define numa demotion attributes. Minor readability improvement. Signed-off-by: Miaohe Lin <linmiaohe@huawei.com> --- mm/memory-tiers.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-)