Message ID | 20250326011752.917564-1-ye.liu@linux.dev (mailing list archive) |
---|---|
State | New |
Headers | show |
Series | [v3] mm/page_alloc: Consolidate unlikely handling in page_expected_state | expand |
> Consolidates the handling of … > This change simplifies … > --- > V3: Delete 'This patch'. How good does such information fit to the wording requirement “imperative mood”? https://web.git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/Documentation/process/submitting-patches.rst?h=v6.14#n94 … > --- > --- > mm/page_alloc.c | 24 ++++++++---------------- How do you think about to omit redundant marker lines? Regards, Markus
在 2025/3/26 16:48, Markus Elfring 写道: >> Consolidates the handling of > … >> This change simplifies > … >> --- >> V3: Delete 'This patch'. > How good does such information fit to the wording requirement “imperative mood”? > https://web.git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/Documentation/process/submitting-patches.rst?h=v6.14#n94 How about this? Consolidate the handling of unlikely conditions in the page_expected_state function to reduce code duplication and improve readability. Move the logic for handling __PG_HWPOISON flags from the check_new_page_bad function to the page_expected_state function, and remove check_new_page_bad. Call bad_page directly from the check_new_page function if the page has unexpected flags. Simplify the code by reducing the number of functions and centralizing the handling of unlikely conditions. > … >> --- >> --- >> mm/page_alloc.c | 24 ++++++++---------------- > How do you think about to omit redundant marker lines? --- delete this one? --- mm/page_alloc.c | 24 ++++++++---------------- like this ? V2: return true instead of false in the PageHWPoison branch. --- mm/page_alloc.c | 24 ++++++++---------------- Thanks for pointing out the formatting issue. I would like to get your approval on the above changes before I send patch v4. > Regards, > Markus
>> https://web.git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/Documentation/process/submitting-patches.rst?h=v6.14#n94 > > How about this? I hope that such review can trigger improvements in change descriptions for further patch versions. > Consolidate the handling of unlikely conditions in the page_expected_state > function to reduce code duplication and improve readability. … Would you like to append parentheses to any function names? Regards, Markus
在 2025/3/27 23:05, Markus Elfring 写道: >>> https://web.git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/Documentation/process/submitting-patches.rst?h=v6.14#n94 >> How about this? > I hope that such review can trigger improvements in change descriptions > for further patch versions. > Thanks for the review and suggestion! I appreciate the feedback and will improve the change descriptions in future patch versions. >> Consolidate the handling of unlikely conditions in the page_expected_state >> function to reduce code duplication and improve readability. > … > > Would you like to append parentheses to any function names? I'll adjust accordingly. Best regards, Ye > Regards, > Markus
diff --git a/mm/page_alloc.c b/mm/page_alloc.c index 2842da893eea..e8b95c6a96c2 100644 --- a/mm/page_alloc.c +++ b/mm/page_alloc.c @@ -903,6 +903,12 @@ static inline bool page_expected_state(struct page *page, (page->flags & check_flags))) return false; + if (unlikely(PageHWPoison(page))) { + /* Don't complain about hwpoisoned pages */ + if (PageBuddy(page)) + __ClearPageBuddy(page); + } + return true; } @@ -1586,29 +1592,15 @@ static __always_inline void page_del_and_expand(struct zone *zone, account_freepages(zone, -nr_pages, migratetype); } -static void check_new_page_bad(struct page *page) -{ - if (unlikely(PageHWPoison(page))) { - /* Don't complain about hwpoisoned pages */ - if (PageBuddy(page)) - __ClearPageBuddy(page); - return; - } - - bad_page(page, - page_bad_reason(page, PAGE_FLAGS_CHECK_AT_PREP)); -} - /* * This page is about to be returned from the page allocator */ static bool check_new_page(struct page *page) { - if (likely(page_expected_state(page, - PAGE_FLAGS_CHECK_AT_PREP|__PG_HWPOISON))) + if (likely(page_expected_state(page, PAGE_FLAGS_CHECK_AT_PREP))) return false; - check_new_page_bad(page); + bad_page(page, page_bad_reason(page, PAGE_FLAGS_CHECK_AT_PREP)); return true; }