diff mbox series

[RFC,04/11] mmc: rename mmc_can_poweroff_notify() to mmc_card_can_poweroff_notify()

Message ID 20250401095847.29271-5-wsa+renesas@sang-engineering.com (mailing list archive)
State New
Headers show
Series mmc: rename mmc_can_* functions | expand

Commit Message

Wolfram Sang April 1, 2025, 9:58 a.m. UTC
mmc_can_* functions sometimes relate to the card and sometimes to the host.
Make it obvious by renaming this function to include 'card'.

Signed-off-by: Wolfram Sang <wsa+renesas@sang-engineering.com>
---
 drivers/mmc/core/mmc.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/drivers/mmc/core/mmc.c b/drivers/mmc/core/mmc.c
index 2b63eb608489..8911b2206c45 100644
--- a/drivers/mmc/core/mmc.c
+++ b/drivers/mmc/core/mmc.c
@@ -2013,7 +2013,7 @@  static int mmc_sleep(struct mmc_host *host)
 	return err;
 }
 
-static bool mmc_can_poweroff_notify(const struct mmc_card *card)
+static bool mmc_card_can_poweroff_notify(const struct mmc_card *card)
 {
 	return card &&
 		mmc_card_mmc(card) &&
@@ -2137,7 +2137,7 @@  static int _mmc_suspend(struct mmc_host *host, enum mmc_poweroff_type pm_type)
 		goto out;
 
 pr_info("%s: reason %d, may_notify %d\n", mmc_hostname(host), pm_type, mmc_may_poweroff_notify(host, pm_type));
-	if (mmc_can_poweroff_notify(host->card) &&
+	if (mmc_card_can_poweroff_notify(host->card) &&
 	    mmc_may_poweroff_notify(host, pm_type))
 		err = mmc_poweroff_notify(host->card, notify_type);
 	else if (mmc_can_sleep(host->card))
@@ -2217,7 +2217,7 @@  static int mmc_shutdown(struct mmc_host *host)
 	 * In a specific case for poweroff notify, we need to resume the card
 	 * before we can shutdown it properly.
 	 */
-	if (mmc_can_poweroff_notify(host->card) &&
+	if (mmc_card_can_poweroff_notify(host->card) &&
 	    !mmc_may_poweroff_notify(host, MMC_POWEROFF_SUSPEND))
 		err = _mmc_resume(host);