mbox series

[v4,0/4] Miscellaneous cleanups

Message ID cover.1645605431.git.christophe.leroy@csgroup.eu (mailing list archive)
Headers show
Series Miscellaneous cleanups | expand

Message

Christophe Leroy Feb. 23, 2022, 9 a.m. UTC
This series applies on top of Aaron's series "module: core code clean up" v8.

It does some cleanup around the settling of modules's layout page flags:
- Make module_enable_x() independent of CONFIG_ARCH_HAS_STRICT_MODULE_RWX
- Reunify everything into strict_rwx.c
- Change big hammer BUG_ON()s into WARN_ON()s
- Change misleading debug_align() to strict_align()

Changes in v4:
- Rebased on top of Aaron's series "module: core code clean up" v8.

Changes in v2/v3:
- Rebased on top of my series "Allocate module text and data separately" v5
- Moved the Kconfig patch out of this series, it is an independent change

Christophe Leroy (4):
  module: Make module_enable_x() independent of
    CONFIG_ARCH_HAS_STRICT_MODULE_RWX
  module: Move module_enable_x() and frob_text() in strict_rwx.c
  module: Rework layout alignment to avoid BUG_ON()s
  module: Rename debug_align() as strict_align()

 kernel/module/Makefile     |  3 +-
 kernel/module/internal.h   | 26 +++----------
 kernel/module/kallsyms.c   |  4 +-
 kernel/module/main.c       | 58 ++++++-----------------------
 kernel/module/strict_rwx.c | 75 +++++++++++++++++++++++++++++++++-----
 5 files changed, 87 insertions(+), 79 deletions(-)

Comments

Luis Chamberlain March 22, 2022, 5:23 p.m. UTC | #1
On Wed, Feb 23, 2022 at 10:00:57AM +0100, Christophe Leroy wrote:
> This series applies on top of Aaron's series "module: core code clean up" v8.

Queued onto modules-testing, thanks!

  Luis