@@ -6,6 +6,6 @@ AC_DEFUN([AC_KEYUTILS], [
AC_CHECK_LIB([keyutils], [keyctl_instantiate], [LIBKEYUTILS=-lkeyutils], ,)
AC_SUBST(LIBKEYUTILS)
- AC_CHECK_HEADERS([keyutils.h], ,
- [AC_MSG_ERROR([keyutils.h header not found.])])
+ AC_CHECK_HEADERS([keyutils.h])
+
])dnl
@@ -15,7 +15,6 @@ AC_DEFUN([AC_LIBNFSIDMAP], [
[Define to 1 if you have the `nfs4_set_debug' function.])])
dnl only enable nfsidmap when libnfsidmap supports it
- AC_CHECK_LIB([nfsidmap], [nfs4_owner_to_uid], [enable_nfsidmap=yes],
- [enable_nfsidmap=no])
+ AC_CHECK_LIB([nfsidmap], [nfs4_owner_to_uid])
])dnl
@@ -266,7 +266,7 @@ if test "$enable_nfsv4" = yes; then
fi
fi
dnl enable nfsidmap when its support by libnfsidmap
-AM_CONDITIONAL(CONFIG_NFSIDMAP, [test "$enable_nfsidmap" = "yes"])
+AM_CONDITIONAL(CONFIG_NFSIDMAP, [test "$ac_cv_header_keyutils_h$ac_cv_lib_nfsidmap_nfs4_owner_to_uid" = "yesyes"])
if test "$knfsd_cv_glibc2" = no; then
Since we already auto-disable based on libnfsidmap capabilities, don't make keyutils a hard failure. Signed-off-by: Mike Frysinger <vapier@gentoo.org> --- aclocal/keyutils.m4 | 4 ++-- aclocal/libnfsidmap.m4 | 3 +-- configure.ac | 2 +- 3 files changed, 4 insertions(+), 5 deletions(-)