diff mbox

[[nfs-utils] ] check for libio.h availability

Message ID 1364161322-25601-1-git-send-email-vapier@gentoo.org (mailing list archive)
State New, archived
Headers show

Commit Message

Mike Frysinger March 24, 2013, 9:42 p.m. UTC
On some systems (like uClibc), there isn't a libio.h header.  But it
isn't also needed on them.  So check for the header first.

Signed-off-by: Mike Frysinger <vapier@gentoo.org>
---
 configure.ac               | 2 +-
 support/include/sockaddr.h | 6 ++++++
 2 files changed, 7 insertions(+), 1 deletion(-)

Comments

Steve Dickson March 25, 2013, 2:19 p.m. UTC | #1
On 24/03/13 17:42, Mike Frysinger wrote:
> On some systems (like uClibc), there isn't a libio.h header.  But it
> isn't also needed on them.  So check for the header first.
> 
> Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Committed...

steved.
> ---
>  configure.ac               | 2 +-
>  support/include/sockaddr.h | 6 ++++++
>  2 files changed, 7 insertions(+), 1 deletion(-)
> 
> diff --git a/configure.ac b/configure.ac
> index f461219..cc7f3b4 100644
> --- a/configure.ac
> +++ b/configure.ac
> @@ -358,7 +358,7 @@ AC_CHECK_HEADERS([arpa/inet.h fcntl.h libintl.h limits.h \
>                   stdlib.h string.h sys/file.h sys/ioctl.h sys/mount.h \
>                   sys/param.h sys/socket.h sys/time.h sys/vfs.h \
>                   syslog.h unistd.h com_err.h et/com_err.h \
> -                 ifaddrs.h nfs-plugin.h])
> +                 ifaddrs.h nfs-plugin.h libio.h])
>  
>  dnl *************************************************************
>  dnl Checks for typedefs, structures, and compiler characteristics
> diff --git a/support/include/sockaddr.h b/support/include/sockaddr.h
> index 72766db..a1c30f9 100644
> --- a/support/include/sockaddr.h
> +++ b/support/include/sockaddr.h
> @@ -20,7 +20,13 @@
>  #ifndef NFS_UTILS_SOCKADDR_H
>  #define NFS_UTILS_SOCKADDR_H
>  
> +#ifdef HAVE_CONFIG_H
> +#include <config.h>
> +#endif
> +
> +#ifdef HAVE_LIBIO_H
>  #include <libio.h>
> +#endif
>  #include <stdbool.h>
>  #include <sys/socket.h>
>  #include <netinet/in.h>
> 
--
To unsubscribe from this list: send the line "unsubscribe linux-nfs" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/configure.ac b/configure.ac
index f461219..cc7f3b4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -358,7 +358,7 @@  AC_CHECK_HEADERS([arpa/inet.h fcntl.h libintl.h limits.h \
                  stdlib.h string.h sys/file.h sys/ioctl.h sys/mount.h \
                  sys/param.h sys/socket.h sys/time.h sys/vfs.h \
                  syslog.h unistd.h com_err.h et/com_err.h \
-                 ifaddrs.h nfs-plugin.h])
+                 ifaddrs.h nfs-plugin.h libio.h])
 
 dnl *************************************************************
 dnl Checks for typedefs, structures, and compiler characteristics
diff --git a/support/include/sockaddr.h b/support/include/sockaddr.h
index 72766db..a1c30f9 100644
--- a/support/include/sockaddr.h
+++ b/support/include/sockaddr.h
@@ -20,7 +20,13 @@ 
 #ifndef NFS_UTILS_SOCKADDR_H
 #define NFS_UTILS_SOCKADDR_H
 
+#ifdef HAVE_CONFIG_H
+#include <config.h>
+#endif
+
+#ifdef HAVE_LIBIO_H
 #include <libio.h>
+#endif
 #include <stdbool.h>
 #include <sys/socket.h>
 #include <netinet/in.h>