diff mbox

[[nfs-utils] ] rpcdebug: do not use build toolchain

Message ID 1364162728-3032-1-git-send-email-vapier@gentoo.org (mailing list archive)
State New, archived
Headers show

Commit Message

Mike Frysinger March 24, 2013, 10:05 p.m. UTC
The rpcdebug program gets installed, so we don't want to use the build
toolchain to compile it.  I can't find any scripts in the build system
that try to execute it, so this shouldn't be a problem.

Signed-off-by: Mike Frysinger <vapier@gentoo.org>
---
 tools/rpcdebug/Makefile.am | 6 ------
 1 file changed, 6 deletions(-)

Comments

Steve Dickson March 25, 2013, 2:19 p.m. UTC | #1
On 24/03/13 18:05, Mike Frysinger wrote:
> The rpcdebug program gets installed, so we don't want to use the build
> toolchain to compile it.  I can't find any scripts in the build system
> that try to execute it, so this shouldn't be a problem.
> 
> Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Committed...

steved
> ---
>  tools/rpcdebug/Makefile.am | 6 ------
>  1 file changed, 6 deletions(-)
> 
> diff --git a/tools/rpcdebug/Makefile.am b/tools/rpcdebug/Makefile.am
> index 39b70c9..b0a3e1f 100644
> --- a/tools/rpcdebug/Makefile.am
> +++ b/tools/rpcdebug/Makefile.am
> @@ -1,15 +1,9 @@
>  ## Process this file with automake to produce Makefile.in
>  
> -CC=$(CC_FOR_BUILD)
> -LIBTOOL = @LIBTOOL@ --tag=CC
> -
>  man8_MANS = rpcdebug.man
>  EXTRA_DIST = $(man8_MANS)
>  
>  sbin_PROGRAMS = rpcdebug
>  rpcdebug_SOURCES = rpcdebug.c
> -rpcdebug_CFLAGS=$(CFLAGS_FOR_BUILD)
> -rpcdebug_CPPFLAGS=$(CPPFLAGS_FOR_BUILD) -I$(top_srcdir)/support/include
> -rpcdebug_LDFLAGS=$(LDFLAGS_FOR_BUILD)
>  
>  MAINTAINERCLEANFILES = Makefile.in
> 
--
To unsubscribe from this list: send the line "unsubscribe linux-nfs" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/tools/rpcdebug/Makefile.am b/tools/rpcdebug/Makefile.am
index 39b70c9..b0a3e1f 100644
--- a/tools/rpcdebug/Makefile.am
+++ b/tools/rpcdebug/Makefile.am
@@ -1,15 +1,9 @@ 
 ## Process this file with automake to produce Makefile.in
 
-CC=$(CC_FOR_BUILD)
-LIBTOOL = @LIBTOOL@ --tag=CC
-
 man8_MANS = rpcdebug.man
 EXTRA_DIST = $(man8_MANS)
 
 sbin_PROGRAMS = rpcdebug
 rpcdebug_SOURCES = rpcdebug.c
-rpcdebug_CFLAGS=$(CFLAGS_FOR_BUILD)
-rpcdebug_CPPFLAGS=$(CPPFLAGS_FOR_BUILD) -I$(top_srcdir)/support/include
-rpcdebug_LDFLAGS=$(LDFLAGS_FOR_BUILD)
 
 MAINTAINERCLEANFILES = Makefile.in