diff mbox

[[nfs-utils] ] do not fail sqlite check when cross-compiling

Message ID 1365883476-5288-1-git-send-email-vapier@gentoo.org (mailing list archive)
State New, archived
Headers show

Commit Message

Mike Frysinger April 13, 2013, 8:04 p.m. UTC
If we're cross-compiling, we can't do a runtime test of sqlite,
so just assume that the user has a good enough version rather
than falling over.

Signed-off-by: Mike Frysinger <vapier@gentoo.org>
---
 configure.ac | 11 ++++++++---
 1 file changed, 8 insertions(+), 3 deletions(-)

Comments

Steve Dickson April 22, 2013, 5:19 p.m. UTC | #1
On 13/04/13 16:04, Mike Frysinger wrote:
> If we're cross-compiling, we can't do a runtime test of sqlite,
> so just assume that the user has a good enough version rather
> than falling over.
> 
> Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Committed...

steved.

> ---
>  configure.ac | 11 ++++++++---
>  1 file changed, 8 insertions(+), 3 deletions(-)
> 
> diff --git a/configure.ac b/configure.ac
> index 3d7ab0a..a594a7b 100644
> --- a/configure.ac
> +++ b/configure.ac
> @@ -274,9 +274,14 @@ if test "$enable_nfsv4" = yes; then
>  	AC_CHECK_HEADERS([libgen.h sys/inotify.h], ,
>  		AC_MSG_ERROR([Cannot find header needed for nfsdcltrack]))
>  
> -  	if test "$libsqlite3_cv_is_recent" != "yes" ; then
> -		AC_MSG_ERROR([nfsdcltrack requires sqlite-devel])
> -	fi
> +    case $libsqlite3_cv_is_recent in
> +    yes) ;;
> +    unknown)
> +      dnl do not fail when cross-compiling
> +      AC_MSG_WARN([assuming sqlite is at least v3.3]) ;;
> +    *)
> +      AC_MSG_ERROR([nfsdcltrack requires sqlite-devel]) ;;
> +    esac
>    fi
>  
>  else
> 
--
To unsubscribe from this list: send the line "unsubscribe linux-nfs" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/configure.ac b/configure.ac
index 3d7ab0a..a594a7b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -274,9 +274,14 @@  if test "$enable_nfsv4" = yes; then
 	AC_CHECK_HEADERS([libgen.h sys/inotify.h], ,
 		AC_MSG_ERROR([Cannot find header needed for nfsdcltrack]))
 
-  	if test "$libsqlite3_cv_is_recent" != "yes" ; then
-		AC_MSG_ERROR([nfsdcltrack requires sqlite-devel])
-	fi
+    case $libsqlite3_cv_is_recent in
+    yes) ;;
+    unknown)
+      dnl do not fail when cross-compiling
+      AC_MSG_WARN([assuming sqlite is at least v3.3]) ;;
+    *)
+      AC_MSG_ERROR([nfsdcltrack requires sqlite-devel]) ;;
+    esac
   fi
 
 else