@@ -71,18 +71,6 @@ AC_ARG_WITH(systemd,
AM_CONDITIONAL(INSTALL_SYSTEMD, [test "$use_systemd" = 1])
AC_SUBST(unitdir)
-modprobedir=/usr/lib/modprobe.d
-AC_ARG_WITH(modprobedir,
- [AS_HELP_STRING([--with-modprobedir@<:@=modprobe-dir-path@:>@],[install modprobe config files @<:@Default: /usr/lib/modprobe.d@:>@])],
- if test "$withval" != "no" ; then
- modprobedir=$withval
- else
- modprobedir=
- fi
- )
- AM_CONDITIONAL(INSTALL_MODPROBEDIR, [test -n "$modprobedir"])
- AC_SUBST(modprobedir)
-
AC_ARG_ENABLE(nfsv4,
[AS_HELP_STRING([--disable-nfsv4],[disable support for NFSv4 @<:@default=no@:>@])],
enable_nfsv4=$enableval,
@@ -82,7 +82,5 @@ install-data-hook: $(unit_files) $(modprobe_files)
else
install-data-hook: $(modprobe_files)
endif
-if INSTALL_MODPROBEDIR
- mkdir -p $(DESTDIR)$(modprobedir)
- cp $(modprobe_files) $(DESTDIR)$(modprobedir)
-endif
+ mkdir -p $(DESTDIR)/usr/lib/modprobe.d
+ cp $(modprobe_files) $(DESTDIR)/usr/lib/modprobe.d/
This reverts commit 7d76dd2e6f09a141eb6303b7343baa5c4f9c85ad. As part of the full revert of adding support via modprobe.d configuration to set sysctl settings of NFS-related modules when loading the modules. The approach caused problems with sysctl from busybox and with kmod as reported in Debian (https://bugs.debian.org/1024082) Signed-off-by: Salvatore Bonaccorso <carnil@debian.org> --- configure.ac | 12 ------------ systemd/Makefile.am | 6 ++---- 2 files changed, 2 insertions(+), 16 deletions(-)