Message ID | 20240102-j7200-pcie-s2r-v2-13-8e4f7d228ec2@bootlin.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | Add suspend to ram support for PCIe on J7200 | expand |
In subject, capitalize "Add ..." to follow historical convention. Also the other driver/pci/ patches. On Fri, Jan 26, 2024 at 03:36:55PM +0100, Thomas Richard wrote: > From: Théo Lebrun <theo.lebrun@bootlin.com> > > That function mixes probe structure init and hardware config. > The whole hardware config part must be done at resume after a suspend to > ram. > We therefore pass it a boolean flag determining if we are at probe or at > resume. s/That function/cdns_pcie_host_setup()/ so the commit log stands alone even without the subject line. s/ram/RAM/ Add blank line between paragraphs (or rewrap into a single paragraph). This is pretty similar but slightly different from the DWC pattern: imx6_pcie_probe ... do structure init ... if (RC) dw_pcie_host_init pp->ops->init imx6_pcie_host_init imx6_pcie_resume_noirq imx6_pcie_host_init j721e_pcie_probe j721e_pcie_ctrl_init if (RC) cdns_pcie_host_setup(true) j721e_pcie_resume_noirq j721e_pcie_ctrl_init if (RC) cdns_pcie_host_setup(false) It'd be super nice to have them the same. Passing in a "probe" flag works but seems a little harder to read in cdns_pcie_host_setup() and you have to keep track of what it means in the callers. > Signed-off-by: Théo Lebrun <theo.lebrun@bootlin.com> > Signed-off-by: Thomas Richard <thomas.richard@bootlin.com> > --- > drivers/pci/controller/cadence/pci-j721e.c | 2 +- > drivers/pci/controller/cadence/pcie-cadence-host.c | 49 ++++++++++++---------- > drivers/pci/controller/cadence/pcie-cadence-plat.c | 2 +- > drivers/pci/controller/cadence/pcie-cadence.h | 4 +- > 4 files changed, 30 insertions(+), 27 deletions(-) > > diff --git a/drivers/pci/controller/cadence/pci-j721e.c b/drivers/pci/controller/cadence/pci-j721e.c > index 2c87e7728a65..9b343a46da11 100644 > --- a/drivers/pci/controller/cadence/pci-j721e.c > +++ b/drivers/pci/controller/cadence/pci-j721e.c > @@ -509,7 +509,7 @@ static int j721e_pcie_probe(struct platform_device *pdev) > gpiod_set_value_cansleep(gpiod, 1); > } > > - ret = cdns_pcie_host_setup(rc); > + ret = cdns_pcie_host_setup(rc, true); > if (ret < 0) { > clk_disable_unprepare(pcie->refclk); > goto err_pcie_setup; > diff --git a/drivers/pci/controller/cadence/pcie-cadence-host.c b/drivers/pci/controller/cadence/pcie-cadence-host.c > index 5b14f7ee3c79..dd4d876a9138 100644 > --- a/drivers/pci/controller/cadence/pcie-cadence-host.c > +++ b/drivers/pci/controller/cadence/pcie-cadence-host.c > @@ -497,14 +497,14 @@ static int cdns_pcie_host_init(struct device *dev, > return cdns_pcie_host_init_address_translation(rc); > } > > -int cdns_pcie_host_setup(struct cdns_pcie_rc *rc) > +int cdns_pcie_host_setup(struct cdns_pcie_rc *rc, bool probe) > { > struct device *dev = rc->pcie.dev; > struct platform_device *pdev = to_platform_device(dev); > struct device_node *np = dev->of_node; > struct pci_host_bridge *bridge; > enum cdns_pcie_rp_bar bar; > - struct cdns_pcie *pcie; > + struct cdns_pcie *pcie = &rc->pcie; > struct resource *res; > int ret; > > @@ -512,26 +512,27 @@ int cdns_pcie_host_setup(struct cdns_pcie_rc *rc) > if (!bridge) > return -ENOMEM; > > - pcie = &rc->pcie; > - pcie->is_rc = true; > + if (probe) { > + pcie->is_rc = true; > > - rc->vendor_id = 0xffff; > - of_property_read_u32(np, "vendor-id", &rc->vendor_id); > + rc->vendor_id = 0xffff; > + of_property_read_u32(np, "vendor-id", &rc->vendor_id); > > - rc->device_id = 0xffff; > - of_property_read_u32(np, "device-id", &rc->device_id); > + rc->device_id = 0xffff; > + of_property_read_u32(np, "device-id", &rc->device_id); > > - pcie->reg_base = devm_platform_ioremap_resource_byname(pdev, "reg"); > - if (IS_ERR(pcie->reg_base)) { > - dev_err(dev, "missing \"reg\"\n"); > - return PTR_ERR(pcie->reg_base); > - } > + pcie->reg_base = devm_platform_ioremap_resource_byname(pdev, "reg"); > + if (IS_ERR(pcie->reg_base)) { > + dev_err(dev, "missing \"reg\"\n"); > + return PTR_ERR(pcie->reg_base); > + } > > - res = platform_get_resource_byname(pdev, IORESOURCE_MEM, "cfg"); > - rc->cfg_base = devm_pci_remap_cfg_resource(dev, res); > - if (IS_ERR(rc->cfg_base)) > - return PTR_ERR(rc->cfg_base); > - rc->cfg_res = res; > + res = platform_get_resource_byname(pdev, IORESOURCE_MEM, "cfg"); > + rc->cfg_base = devm_pci_remap_cfg_resource(dev, res); > + if (IS_ERR(rc->cfg_base)) > + return PTR_ERR(rc->cfg_base); > + rc->cfg_res = res; > + } > > if (rc->quirk_detect_quiet_flag) > cdns_pcie_detect_quiet_min_delay_set(&rc->pcie); > @@ -555,12 +556,14 @@ int cdns_pcie_host_setup(struct cdns_pcie_rc *rc) > if (ret) > return ret; > > - if (!bridge->ops) > - bridge->ops = &cdns_pcie_host_ops; > + if (probe) { > + if (!bridge->ops) > + bridge->ops = &cdns_pcie_host_ops; > > - ret = pci_host_probe(bridge); > - if (ret < 0) > - goto err_init; > + ret = pci_host_probe(bridge); > + if (ret < 0) > + goto err_init; > + } > > return 0; > > diff --git a/drivers/pci/controller/cadence/pcie-cadence-plat.c b/drivers/pci/controller/cadence/pcie-cadence-plat.c > index 0456845dabb9..071423091668 100644 > --- a/drivers/pci/controller/cadence/pcie-cadence-plat.c > +++ b/drivers/pci/controller/cadence/pcie-cadence-plat.c > @@ -86,7 +86,7 @@ static int cdns_plat_pcie_probe(struct platform_device *pdev) > goto err_get_sync; > } > > - ret = cdns_pcie_host_setup(rc); > + ret = cdns_pcie_host_setup(rc, true); > if (ret) > goto err_init; > } else { > diff --git a/drivers/pci/controller/cadence/pcie-cadence.h b/drivers/pci/controller/cadence/pcie-cadence.h > index 373cb50fcd15..3b0da889ed64 100644 > --- a/drivers/pci/controller/cadence/pcie-cadence.h > +++ b/drivers/pci/controller/cadence/pcie-cadence.h > @@ -515,11 +515,11 @@ static inline bool cdns_pcie_link_up(struct cdns_pcie *pcie) > } > > #ifdef CONFIG_PCIE_CADENCE_HOST > -int cdns_pcie_host_setup(struct cdns_pcie_rc *rc); > +int cdns_pcie_host_setup(struct cdns_pcie_rc *rc, bool probe); > void __iomem *cdns_pci_map_bus(struct pci_bus *bus, unsigned int devfn, > int where); > #else > -static inline int cdns_pcie_host_setup(struct cdns_pcie_rc *rc) > +static inline int cdns_pcie_host_setup(struct cdns_pcie_rc *rc, bool probe) > { > return 0; > } > > -- > 2.39.2 >
On Fri, Jan 26, 2024 at 11:43 PM Bjorn Helgaas <helgaas@kernel.org> wrote: > On Fri, Jan 26, 2024 at 03:36:55PM +0100, Thomas Richard wrote: ... > It'd be super nice to have them the same. Passing in a "probe" flag > works but seems a little harder to read in cdns_pcie_host_setup() and > you have to keep track of what it means in the callers. FWIW, in another patch with a similar approach I found it (the approach) a bit ugly and unmaintainable. I would suggest properly refactoring to create 2+ functions and use as needed.
On Fri, Jan 26, 2024 at 03:43:39PM -0600, Bjorn Helgaas wrote: > In subject, capitalize "Add ..." to follow historical convention. > Also the other driver/pci/ patches. > > On Fri, Jan 26, 2024 at 03:36:55PM +0100, Thomas Richard wrote: > > From: Théo Lebrun <theo.lebrun@bootlin.com> > > > > That function mixes probe structure init and hardware config. > > The whole hardware config part must be done at resume after a suspend to > > ram. > > We therefore pass it a boolean flag determining if we are at probe or at > > resume. > ... > This is pretty similar but slightly different from the DWC pattern: > > imx6_pcie_probe > ... do structure init ... > if (RC) > dw_pcie_host_init > pp->ops->init > imx6_pcie_host_init > > imx6_pcie_resume_noirq > imx6_pcie_host_init > > j721e_pcie_probe > j721e_pcie_ctrl_init > if (RC) > cdns_pcie_host_setup(true) > > j721e_pcie_resume_noirq > j721e_pcie_ctrl_init > if (RC) > cdns_pcie_host_setup(false) > > It'd be super nice to have them the same. Passing in a "probe" flag > works but seems a little harder to read in cdns_pcie_host_setup() and > you have to keep track of what it means in the callers. Maybe a better way to say this is that this patch uses the "probe" flag to select the behavior of cdns_pcie_host_setup(), and I think it would be nicer to split those two behaviors into separate functions. Bjorn
On Mon, Jan 29, 2024 at 04:16:49PM -0600, Bjorn Helgaas wrote: > On Fri, Jan 26, 2024 at 03:43:39PM -0600, Bjorn Helgaas wrote: > > On Fri, Jan 26, 2024 at 03:36:55PM +0100, Thomas Richard wrote: > > > From: Théo Lebrun <theo.lebrun@bootlin.com> > > > > > > That function mixes probe structure init and hardware config. > > > The whole hardware config part must be done at resume after a suspend to > > > ram. > > > We therefore pass it a boolean flag determining if we are at probe or at > > > resume. > > ... > > It'd be super nice to have them the same. Passing in a "probe" flag > > works but seems a little harder to read in cdns_pcie_host_setup() and > > you have to keep track of what it means in the callers. > > Maybe a better way to say this is that this patch uses the "probe" > flag to select the behavior of cdns_pcie_host_setup(), and I think it > would be nicer to split those two behaviors into separate functions. Oops, sorry, Andy, I wrote this before I saw your similar response from last Friday. Didn't mean to repeat what you already said! Bjorn
diff --git a/drivers/pci/controller/cadence/pci-j721e.c b/drivers/pci/controller/cadence/pci-j721e.c index 2c87e7728a65..9b343a46da11 100644 --- a/drivers/pci/controller/cadence/pci-j721e.c +++ b/drivers/pci/controller/cadence/pci-j721e.c @@ -509,7 +509,7 @@ static int j721e_pcie_probe(struct platform_device *pdev) gpiod_set_value_cansleep(gpiod, 1); } - ret = cdns_pcie_host_setup(rc); + ret = cdns_pcie_host_setup(rc, true); if (ret < 0) { clk_disable_unprepare(pcie->refclk); goto err_pcie_setup; diff --git a/drivers/pci/controller/cadence/pcie-cadence-host.c b/drivers/pci/controller/cadence/pcie-cadence-host.c index 5b14f7ee3c79..dd4d876a9138 100644 --- a/drivers/pci/controller/cadence/pcie-cadence-host.c +++ b/drivers/pci/controller/cadence/pcie-cadence-host.c @@ -497,14 +497,14 @@ static int cdns_pcie_host_init(struct device *dev, return cdns_pcie_host_init_address_translation(rc); } -int cdns_pcie_host_setup(struct cdns_pcie_rc *rc) +int cdns_pcie_host_setup(struct cdns_pcie_rc *rc, bool probe) { struct device *dev = rc->pcie.dev; struct platform_device *pdev = to_platform_device(dev); struct device_node *np = dev->of_node; struct pci_host_bridge *bridge; enum cdns_pcie_rp_bar bar; - struct cdns_pcie *pcie; + struct cdns_pcie *pcie = &rc->pcie; struct resource *res; int ret; @@ -512,26 +512,27 @@ int cdns_pcie_host_setup(struct cdns_pcie_rc *rc) if (!bridge) return -ENOMEM; - pcie = &rc->pcie; - pcie->is_rc = true; + if (probe) { + pcie->is_rc = true; - rc->vendor_id = 0xffff; - of_property_read_u32(np, "vendor-id", &rc->vendor_id); + rc->vendor_id = 0xffff; + of_property_read_u32(np, "vendor-id", &rc->vendor_id); - rc->device_id = 0xffff; - of_property_read_u32(np, "device-id", &rc->device_id); + rc->device_id = 0xffff; + of_property_read_u32(np, "device-id", &rc->device_id); - pcie->reg_base = devm_platform_ioremap_resource_byname(pdev, "reg"); - if (IS_ERR(pcie->reg_base)) { - dev_err(dev, "missing \"reg\"\n"); - return PTR_ERR(pcie->reg_base); - } + pcie->reg_base = devm_platform_ioremap_resource_byname(pdev, "reg"); + if (IS_ERR(pcie->reg_base)) { + dev_err(dev, "missing \"reg\"\n"); + return PTR_ERR(pcie->reg_base); + } - res = platform_get_resource_byname(pdev, IORESOURCE_MEM, "cfg"); - rc->cfg_base = devm_pci_remap_cfg_resource(dev, res); - if (IS_ERR(rc->cfg_base)) - return PTR_ERR(rc->cfg_base); - rc->cfg_res = res; + res = platform_get_resource_byname(pdev, IORESOURCE_MEM, "cfg"); + rc->cfg_base = devm_pci_remap_cfg_resource(dev, res); + if (IS_ERR(rc->cfg_base)) + return PTR_ERR(rc->cfg_base); + rc->cfg_res = res; + } if (rc->quirk_detect_quiet_flag) cdns_pcie_detect_quiet_min_delay_set(&rc->pcie); @@ -555,12 +556,14 @@ int cdns_pcie_host_setup(struct cdns_pcie_rc *rc) if (ret) return ret; - if (!bridge->ops) - bridge->ops = &cdns_pcie_host_ops; + if (probe) { + if (!bridge->ops) + bridge->ops = &cdns_pcie_host_ops; - ret = pci_host_probe(bridge); - if (ret < 0) - goto err_init; + ret = pci_host_probe(bridge); + if (ret < 0) + goto err_init; + } return 0; diff --git a/drivers/pci/controller/cadence/pcie-cadence-plat.c b/drivers/pci/controller/cadence/pcie-cadence-plat.c index 0456845dabb9..071423091668 100644 --- a/drivers/pci/controller/cadence/pcie-cadence-plat.c +++ b/drivers/pci/controller/cadence/pcie-cadence-plat.c @@ -86,7 +86,7 @@ static int cdns_plat_pcie_probe(struct platform_device *pdev) goto err_get_sync; } - ret = cdns_pcie_host_setup(rc); + ret = cdns_pcie_host_setup(rc, true); if (ret) goto err_init; } else { diff --git a/drivers/pci/controller/cadence/pcie-cadence.h b/drivers/pci/controller/cadence/pcie-cadence.h index 373cb50fcd15..3b0da889ed64 100644 --- a/drivers/pci/controller/cadence/pcie-cadence.h +++ b/drivers/pci/controller/cadence/pcie-cadence.h @@ -515,11 +515,11 @@ static inline bool cdns_pcie_link_up(struct cdns_pcie *pcie) } #ifdef CONFIG_PCIE_CADENCE_HOST -int cdns_pcie_host_setup(struct cdns_pcie_rc *rc); +int cdns_pcie_host_setup(struct cdns_pcie_rc *rc, bool probe); void __iomem *cdns_pci_map_bus(struct pci_bus *bus, unsigned int devfn, int where); #else -static inline int cdns_pcie_host_setup(struct cdns_pcie_rc *rc) +static inline int cdns_pcie_host_setup(struct cdns_pcie_rc *rc, bool probe) { return 0; }