diff mbox

OMAP PM: SRF: Drop unnecessary powerdomain activity hooks

Message ID alpine.DEB.2.00.0910271424420.10228@utopia.booyaka.com (mailing list archive)
State Accepted
Delegated to: Kevin Hilman
Headers show

Commit Message

Paul Walmsley Oct. 27, 2009, 8:25 p.m. UTC
None
diff mbox

Patch

diff --git a/arch/arm/plat-omap/omap-pm-srf.c b/arch/arm/plat-omap/omap-pm-srf.c
index d769b90..ef1d235 100644
--- a/arch/arm/plat-omap/omap-pm-srf.c
+++ b/arch/arm/plat-omap/omap-pm-srf.c
@@ -297,43 +297,7 @@  int omap_pm_get_dev_context_loss_count(struct device *dev)
 }
 
 /*
- * Powerdomain usecounting hooks
- */
-
-void omap_pm_pwrdm_active(struct powerdomain *pwrdm)
-{
-	if (!pwrdm) {
-		WARN_ON(1);
-		return;
-	};
-
-	pr_debug("OMAP PM: powerdomain %s is becoming active\n", pwrdm->name);
-
-	/*
-	 * CDP code apparently will need these for the enable_power_domain()
-	 * and disable_power_domain() functions.
-	 */
-}
-
-void omap_pm_pwrdm_inactive(struct powerdomain *pwrdm)
-{
-	if (!pwrdm) {
-		WARN_ON(1);
-		return;
-	};
-
-	pr_debug("OMAP PM: powerdomain %s is becoming inactive\n",
-		 pwrdm->name);
-
-	/*
-	 * CDP code apparently will need these for the enable_power_domain()
-	 * and disable_power_domain() functions.
-	 */
-}
-
-/*
- * Should be called before clk framework since clk fw will call
- * omap_pm_pwrdm_{in,}active()
+ * Must be called before clk framework init
  */
 int __init omap_pm_if_early_init(struct omap_opp *mpu_opp_table,
 				 struct omap_opp *dsp_opp_table,