diff mbox

parisc: fix NATIVE set up in build

Message ID 1367686258-28525-1-git-send-email-vapier@gentoo.org (mailing list archive)
State Superseded
Delegated to: Helge Deller
Headers show

Commit Message

Mike Frysinger May 4, 2013, 4:50 p.m. UTC
The ifeq operator does not accept globs, so this little bit of code will
never match (unless uname literally prints out "parsic*").  Rewrite to
use a pattern matching operator so that NATIVE is set to 1 on parisc.

Signed-off-by: Mike Frysinger <vapier@gentoo.org>
---
 arch/parisc/Makefile | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

Comments

Rolf Eike Beer May 4, 2013, 5:33 p.m. UTC | #1
Am 04.05.2013 18:50, schrieb Mike Frysinger:
> The ifeq operator does not accept globs, so this little bit of code 
> will
> never match (unless uname literally prints out "parsic*").  Rewrite to
                                                   ^^^^^^

That would never match ;)

Eike
--
To unsubscribe from this list: send the line "unsubscribe linux-parisc" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
John David Anglin May 7, 2013, 11:24 p.m. UTC | #2
This patch breaks builds on current Debian systems that want compiler  
prefixes
like hppa64-linux-gnu-", "hppa-linux-gnu-" or no prefix for native 32- 
bit.  The NATIVE
match previous failed and we got the correct FSF prefix.

Dave

On 4-May-13, at 12:50 PM, Mike Frysinger wrote:

> The ifeq operator does not accept globs, so this little bit of code  
> will
> never match (unless uname literally prints out "parsic*").  Rewrite to
> use a pattern matching operator so that NATIVE is set to 1 on parisc.
>
> Signed-off-by: Mike Frysinger <vapier@gentoo.org>
> ---
> arch/parisc/Makefile | 4 +---
> 1 file changed, 1 insertion(+), 3 deletions(-)
>
> diff --git a/arch/parisc/Makefile b/arch/parisc/Makefile
> index 113e282..2f967cc 100644
> --- a/arch/parisc/Makefile
> +++ b/arch/parisc/Makefile
> @@ -24,9 +24,7 @@ CHECKFLAGS	+= -D__hppa__=1
> LIBGCC		= $(shell $(CC) $(KBUILD_CFLAGS) -print-libgcc-file-name)
>
> MACHINE		:= $(shell uname -m)
> -ifeq ($(MACHINE),parisc*)
> -NATIVE		:= 1
> -endif
> +NATIVE		:= $(if $(filter parisc%,$(MACHINE)),1,0)
>
> ifdef CONFIG_64BIT
> UTS_MACHINE	:= parisc64
> -- 
> 1.8.2.1
>
> --
> To unsubscribe from this list: send the line "unsubscribe linux- 
> parisc" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
>

--
John David Anglin	dave.anglin@bell.net



--
To unsubscribe from this list: send the line "unsubscribe linux-parisc" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Mike Frysinger May 9, 2013, 5:04 a.m. UTC | #3
On Tuesday 07 May 2013 19:24:04 John David Anglin wrote:
> This patch breaks builds on current Debian systems that want compiler
> prefixes
> like hppa64-linux-gnu-", "hppa-linux-gnu-" or no prefix for native 32-
> bit.  The NATIVE
> match previous failed and we got the correct FSF prefix.

that was the intention of the code
-mike
diff mbox

Patch

diff --git a/arch/parisc/Makefile b/arch/parisc/Makefile
index 113e282..2f967cc 100644
--- a/arch/parisc/Makefile
+++ b/arch/parisc/Makefile
@@ -24,9 +24,7 @@  CHECKFLAGS	+= -D__hppa__=1
 LIBGCC		= $(shell $(CC) $(KBUILD_CFLAGS) -print-libgcc-file-name)
 
 MACHINE		:= $(shell uname -m)
-ifeq ($(MACHINE),parisc*)
-NATIVE		:= 1
-endif
+NATIVE		:= $(if $(filter parisc%,$(MACHINE)),1,0)
 
 ifdef CONFIG_64BIT
 UTS_MACHINE	:= parisc64