Message ID | 20211001195856.10081-1-kabel@kernel.org (mailing list archive) |
---|---|
Headers | show |
Series | PCI: aardvark controller fixes | expand |
On Fri, Oct 01, 2021 at 09:58:43PM +0200, Marek Behún wrote: > Hi Lorenzo, > > this series fixes some issues with the Aardvark PCIe controller driver. > > Most of them are small changes. Patch 11 has a rather long commit message > since it explains how the bugs were introduced from multiple misleading > names and comments of some registers. > > We have another 56 fixes for aardvark, but last time nobody wanted to > review such a large series, so we are now trying in smaller batches. > > It would be great if you could find time to review, since we would like > this to land in 5.16. Preferably we would like to send another batch for > 5.16, but we will see how fast this one goes > > Marek & Pali OK, so what's the overlap between this series and: https://patchwork.kernel.org/user/todo/linux-pci/?series=506773 https://patchwork.kernel.org/user/todo/linux-pci/?series=507035 I need to keep track of reviews in the series above and make sure they are reflected into *this* series if some of the patches overlap or they are a rework. Please let me know, thank you. Lorenzo > Marek Behún (2): > PCI: aardvark: Don't spam about PIO Response Status > PCI: aardvark: Deduplicate code in advk_pcie_rd_conf() > > Pali Rohár (11): > PCI: Add PCI_EXP_DEVCTL_PAYLOAD_* macros > PCI: aardvark: Fix PCIe Max Payload Size setting > PCI: aardvark: Fix preserving PCI_EXP_RTCTL_CRSSVE flag on emulated > bridge > PCI: aardvark: Fix configuring Reference clock > PCI: aardvark: Do not clear status bits of masked interrupts > PCI: aardvark: Do not unmask unused interrupts > PCI: aardvark: Implement re-issuing config requests on CRS response > PCI: aardvark: Simplify initialization of rootcap on virtual bridge > PCI: aardvark: Fix link training > PCI: aardvark: Fix checking for link up via LTSSM state > PCI: aardvark: Fix reporting Data Link Layer Link Active > > drivers/pci/controller/pci-aardvark.c | 364 +++++++++++++++----------- > include/uapi/linux/pci_regs.h | 6 + > 2 files changed, 212 insertions(+), 158 deletions(-) > > -- > 2.32.0 >
> OK, so what's the overlap between this series and: > > https://patchwork.kernel.org/user/todo/linux-pci/?series=506773 > > https://patchwork.kernel.org/user/todo/linux-pci/?series=507035 Lorenzo, both those patch series are superseded by this one and the following I plan to send once this one is applied (since I wanted to avoid sending 60+ patches in one go). (From the first series you applied one patch: PCI: aardvark: Implement workaround for the readback value of VEND_ID Another patch PCI: Add PCI_EXP_DEVCTL_PAYLOAD_* macros got an Ack from Bjorn, but was not applied, so we sent it again (the 1st patch in this series). Now we have also Bjorn's Reviewed-by for that patch.) Regarding links to patchwork, I am unable to see patches not delegated to me (I can't remove delegate=kabel filter), so I can't set their status to Superseded myself. > I need to keep track of reviews in the series above and make > sure they are reflected into *this* series if some of the > patches overlap or they are a rework. > > Please let me know, thank you.