diff mbox series

PCI: cadence: Remove duplicate message code definitions

Message ID 20250401145023.22948-1-18255117159@163.com (mailing list archive)
State New
Headers show
Series PCI: cadence: Remove duplicate message code definitions | expand

Commit Message

Hans Zhang April 1, 2025, 2:50 p.m. UTC
The Cadence PCIe controller driver defines message codes in enum
cdns_pcie_msg_code that duplicate existing PCIE_MSG_CODE_* macros
from drivers/pci/pci.h. The driver only uses ASSERT_INTA and
DEASSERT_INTA codes from this enum.

Remove the redundant enum definition and use the standard PCIe message
code macros from pci.h to:
  1. Avoid code duplication.
  2. Maintain consistency with PCI specifications.
  3. Simplify future maintenance.
  4. Prevent potential divergence between duplicate definitions.

Signed-off-by: Hans Zhang <18255117159@163.com>
---
 drivers/pci/controller/cadence/pcie-cadence-ep.c |  5 +++--
 drivers/pci/controller/cadence/pcie-cadence.h    | 11 -----------
 2 files changed, 3 insertions(+), 13 deletions(-)


base-commit: acb4f33713b9f6cadb6143f211714c343465411c
diff mbox series

Patch

diff --git a/drivers/pci/controller/cadence/pcie-cadence-ep.c b/drivers/pci/controller/cadence/pcie-cadence-ep.c
index e0cc4560dfde..9ce36113e9f2 100644
--- a/drivers/pci/controller/cadence/pcie-cadence-ep.c
+++ b/drivers/pci/controller/cadence/pcie-cadence-ep.c
@@ -12,6 +12,7 @@ 
 #include <linux/sizes.h>
 
 #include "pcie-cadence.h"
+#include "../../pci.h"
 
 #define CDNS_PCIE_EP_MIN_APERTURE		128	/* 128 bytes */
 #define CDNS_PCIE_EP_IRQ_PCI_ADDR_NONE		0x1
@@ -337,10 +338,10 @@  static void cdns_pcie_ep_assert_intx(struct cdns_pcie_ep *ep, u8 fn, u8 intx,
 
 	if (is_asserted) {
 		ep->irq_pending |= BIT(intx);
-		msg_code = MSG_CODE_ASSERT_INTA + intx;
+		msg_code = PCIE_MSG_CODE_ASSERT_INTA + intx;
 	} else {
 		ep->irq_pending &= ~BIT(intx);
-		msg_code = MSG_CODE_DEASSERT_INTA + intx;
+		msg_code = PCIE_MSG_CODE_DEASSERT_INTA + intx;
 	}
 
 	spin_lock_irqsave(&ep->lock, flags);
diff --git a/drivers/pci/controller/cadence/pcie-cadence.h b/drivers/pci/controller/cadence/pcie-cadence.h
index f5eeff834ec1..9a05940ff949 100644
--- a/drivers/pci/controller/cadence/pcie-cadence.h
+++ b/drivers/pci/controller/cadence/pcie-cadence.h
@@ -250,17 +250,6 @@  struct cdns_pcie_rp_ib_bar {
 
 struct cdns_pcie;
 
-enum cdns_pcie_msg_code {
-	MSG_CODE_ASSERT_INTA	= 0x20,
-	MSG_CODE_ASSERT_INTB	= 0x21,
-	MSG_CODE_ASSERT_INTC	= 0x22,
-	MSG_CODE_ASSERT_INTD	= 0x23,
-	MSG_CODE_DEASSERT_INTA	= 0x24,
-	MSG_CODE_DEASSERT_INTB	= 0x25,
-	MSG_CODE_DEASSERT_INTC	= 0x26,
-	MSG_CODE_DEASSERT_INTD	= 0x27,
-};
-
 enum cdns_pcie_msg_routing {
 	/* Route to Root Complex */
 	MSG_ROUTING_TO_RC,