Message ID | 50EE1594.4070905@infradead.org (mailing list archive) |
---|---|
State | New, archived |
Delegated to: | Bjorn Helgaas |
Headers | show |
On 01/09/2013 08:12 PM, Randy Dunlap wrote: > From: Randy Dunlap<rdunlap@infradead.org> > > Fix kernel-doc warning in iov.c: > > Warning(drivers/pci/iov.c:752): No description found for parameter 'numvfs' > > Signed-off-by: Randy Dunlap<rdunlap@infradead.org> > --- > drivers/pci/iov.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > --- lnx-38-rc2.orig/drivers/pci/iov.c > +++ lnx-38-rc2/drivers/pci/iov.c > @@ -739,7 +739,7 @@ EXPORT_SYMBOL_GPL(pci_num_vf); > /** > * pci_sriov_set_totalvfs -- reduce the TotalVFs available > * @dev: the PCI PF device > - * numvfs: number that should be used for TotalVFs supported > + * @numvfs: number that should be used for TotalVFs supported > * > * Should be called from PF driver's probe routine with > * device's mutex held. > -- > To unsubscribe from this list: send the line "unsubscribe linux-pci" in > the body of a message to majordomo@vger.kernel.org > More majordomo info at http://vger.kernel.org/majordomo-info.html Thanks for cleanup; /my bad. Should checkpatch report this issue? if it does, then my (double-down) bad for missing that correction when I ran it against the patch. -- To unsubscribe from this list: send the line "unsubscribe linux-pci" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
On 01/10/13 14:19, Don Dutile wrote: > On 01/09/2013 08:12 PM, Randy Dunlap wrote: >> From: Randy Dunlap<rdunlap@infradead.org> >> >> Fix kernel-doc warning in iov.c: >> >> Warning(drivers/pci/iov.c:752): No description found for parameter 'numvfs' >> >> Signed-off-by: Randy Dunlap<rdunlap@infradead.org> >> --- >> drivers/pci/iov.c | 2 +- >> 1 file changed, 1 insertion(+), 1 deletion(-) >> >> --- lnx-38-rc2.orig/drivers/pci/iov.c >> +++ lnx-38-rc2/drivers/pci/iov.c >> @@ -739,7 +739,7 @@ EXPORT_SYMBOL_GPL(pci_num_vf); >> /** >> * pci_sriov_set_totalvfs -- reduce the TotalVFs available >> * @dev: the PCI PF device >> - * numvfs: number that should be used for TotalVFs supported >> + * @numvfs: number that should be used for TotalVFs supported >> * >> * Should be called from PF driver's probe routine with >> * device's mutex held. >> -- >> To unsubscribe from this list: send the line "unsubscribe linux-pci" in >> the body of a message to majordomo@vger.kernel.org >> More majordomo info at http://vger.kernel.org/majordomo-info.html > > Thanks for cleanup; /my bad. > Should checkpatch report this issue? if it does, then > my (double-down) bad for missing that correction when I ran it against the patch. checkpatch doesn't check for missing kernel-doc notation. I run 'make htmldocs' on each kernel to look for kernel-doc errors and warnings.
On Wed, Jan 9, 2013 at 6:12 PM, Randy Dunlap <rdunlap@infradead.org> wrote: > From: Randy Dunlap <rdunlap@infradead.org> > > Fix kernel-doc warning in iov.c: > > Warning(drivers/pci/iov.c:752): No description found for parameter 'numvfs' > > Signed-off-by: Randy Dunlap <rdunlap@infradead.org> Thanks, Randy. I applied this to my for-linus branch and it will appear in v3.8 along with the code it applies to. Bjorn > --- > drivers/pci/iov.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > --- lnx-38-rc2.orig/drivers/pci/iov.c > +++ lnx-38-rc2/drivers/pci/iov.c > @@ -739,7 +739,7 @@ EXPORT_SYMBOL_GPL(pci_num_vf); > /** > * pci_sriov_set_totalvfs -- reduce the TotalVFs available > * @dev: the PCI PF device > - * numvfs: number that should be used for TotalVFs supported > + * @numvfs: number that should be used for TotalVFs supported > * > * Should be called from PF driver's probe routine with > * device's mutex held. -- To unsubscribe from this list: send the line "unsubscribe linux-pci" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
--- lnx-38-rc2.orig/drivers/pci/iov.c +++ lnx-38-rc2/drivers/pci/iov.c @@ -739,7 +739,7 @@ EXPORT_SYMBOL_GPL(pci_num_vf); /** * pci_sriov_set_totalvfs -- reduce the TotalVFs available * @dev: the PCI PF device - * numvfs: number that should be used for TotalVFs supported + * @numvfs: number that should be used for TotalVFs supported * * Should be called from PF driver's probe routine with * device's mutex held.