Message ID | 20231018061714.3553817-1-s.hauer@pengutronix.de (mailing list archive) |
---|---|
Headers | show |
Series | Add perf support to the rockchip-dfi driver | expand |
Hi Sascha and Heiko, I finished the review from 01 ~ 22 patches. - 01-05 patches are merged. - 06-22 patches with acked tags. Some patches modifies the 'include/soc/rockchip/*' files. After getting the ack from rockchip maintainer (Heiko Stuebner), I'll merge patches from 06 ~ 22 patches to devfreq.git. Best Regards, Chanwoo Choi On 23. 10. 18. 15:16, Sascha Hauer wrote: > This series integrates the recent review feedback from Chanwoo Choi to > v7. > > Chanwoo, I am sending the full patchset again for people to try this > series. You said that you applied 1-5 already, so please start picking > from 6/26. > > Sascha > > Sascha Hauer (26): > PM / devfreq: rockchip-dfi: Make pmu regmap mandatory > PM / devfreq: rockchip-dfi: Embed desc into private data struct > PM / devfreq: rockchip-dfi: use consistent name for private data > struct > PM / devfreq: rockchip-dfi: Add SoC specific init function > PM / devfreq: rockchip-dfi: dfi store raw values in counter struct > PM / devfreq: rockchip-dfi: Use free running counter > PM / devfreq: rockchip-dfi: introduce channel mask > PM / devfreq: rk3399_dmc,dfi: generalize DDRTYPE defines > PM / devfreq: rockchip-dfi: Clean up DDR type register defines > PM / devfreq: rockchip-dfi: Add RK3568 support > PM / devfreq: rockchip-dfi: Handle LPDDR2 correctly > PM / devfreq: rockchip-dfi: Handle LPDDR4X > PM / devfreq: rockchip-dfi: Pass private data struct to internal > functions > PM / devfreq: rockchip-dfi: Prepare for multiple users > PM / devfreq: rockchip-dfi: give variable a better name > PM / devfreq: rockchip-dfi: Add perf support > PM / devfreq: rockchip-dfi: make register stride SoC specific > PM / devfreq: rockchip-dfi: account for multiple DDRMON_CTRL registers > PM / devfreq: rockchip-dfi: add support for RK3588 > dt-bindings: devfreq: event: convert Rockchip DFI binding to yaml > dt-bindings: devfreq: event: rockchip,dfi: Add rk3568 support > dt-bindings: devfreq: event: rockchip,dfi: Add rk3588 support > dt-bindings: soc: rockchip: grf: add rockchip,rk3588-pmugrf > arm64: dts: rockchip: rk3399: Enable DFI > arm64: dts: rockchip: rk356x: Add DFI > arm64: dts: rockchip: rk3588s: Add DFI > > .../bindings/devfreq/event/rockchip,dfi.yaml | 74 ++ > .../bindings/devfreq/event/rockchip-dfi.txt | 18 - > .../rockchip,rk3399-dmc.yaml | 2 +- > .../devicetree/bindings/soc/rockchip/grf.yaml | 1 + > arch/arm64/boot/dts/rockchip/rk3399.dtsi | 1 - > arch/arm64/boot/dts/rockchip/rk356x.dtsi | 7 + > arch/arm64/boot/dts/rockchip/rk3588s.dtsi | 16 + > drivers/devfreq/event/rockchip-dfi.c | 814 +++++++++++++++--- > drivers/devfreq/rk3399_dmc.c | 10 +- > include/soc/rockchip/rk3399_grf.h | 9 +- > include/soc/rockchip/rk3568_grf.h | 13 + > include/soc/rockchip/rk3588_grf.h | 18 + > include/soc/rockchip/rockchip_grf.h | 18 + > 13 files changed, 863 insertions(+), 138 deletions(-) > create mode 100644 Documentation/devicetree/bindings/devfreq/event/rockchip,dfi.yaml > delete mode 100644 Documentation/devicetree/bindings/devfreq/event/rockchip-dfi.txt > create mode 100644 include/soc/rockchip/rk3568_grf.h > create mode 100644 include/soc/rockchip/rk3588_grf.h > create mode 100644 include/soc/rockchip/rockchip_grf.h >
Hi, Am Mittwoch, 18. Oktober 2023, 17:21:07 CEST schrieb Chanwoo Choi: > Hi Sascha and Heiko, > > I finished the review from 01 ~ 22 patches. > - 01-05 patches are merged. > - 06-22 patches with acked tags. > > > Some patches modifies the 'include/soc/rockchip/*' files. > After getting the ack from rockchip maintainer (Heiko Stuebner), > I'll merge patches from 06 ~ 22 patches to devfreq.git. I do hope I caught all patches that needed Acks from that range. The changes to the soc includes all looked fine, so if I forgot to Ack a patch from that 1-22 range, here is a blanked Acked-by: Heiko Stuebner <heiko@sntech.de> for those. Thanks for reviewing that big series Heiko
On Wed, 18 Oct 2023 08:16:48 +0200, Sascha Hauer wrote: > This series integrates the recent review feedback from Chanwoo Choi to > v7. > > Chanwoo, I am sending the full patchset again for people to try this > series. You said that you applied 1-5 already, so please start picking > from 6/26. > > [...] Applied, thanks! [23/26] dt-bindings: soc: rockchip: grf: add rockchip,rk3588-pmugrf commit: 3bd1c0c62bad8ea7f9cc6662e754f77ec8baa46e I've grabbed the pmugrf compatible addition for now, so I can send out the pull request for my "drivers" branch. Best regards,
On Wed, 18 Oct 2023 08:16:48 +0200, Sascha Hauer wrote: > This series integrates the recent review feedback from Chanwoo Choi to > v7. > > Chanwoo, I am sending the full patchset again for people to try this > series. You said that you applied 1-5 already, so please start picking > from 6/26. > > [...] Applied, thanks! [24/26] arm64: dts: rockchip: rk3399: Enable DFI commit: f57ef11ec63c17201b27569fbfb58801c227137d [25/26] arm64: dts: rockchip: rk356x: Add DFI commit: 085be8875ca8a087e3cc102893f384894962c87e [26/26] arm64: dts: rockchip: rk3588s: Add DFI commit: 5a6976b1040a2f99ab84eddbfa7cd072ac5d10fc Best regards,