Message ID | 20160610005619.GQ7555@decadent.org.uk (mailing list archive) |
---|---|
State | Deferred |
Headers | show |
Hi Thomas, On Fri, Jun 10, 2016 at 01:56:20AM +0100, Ben Hutchings wrote: > Several functions in the libcpupower API are renamed or removed in > Linux 4.7. This is an backward-incompatible ABI change, so the > library soname should change from libcpupower.so.0 to > libcpupower.so.1. > > Fixes: ac5a181d065d ("cpupower: Add cpuidle parts into library") > Signed-off-by: Ben Hutchings <ben@decadent.org.uk> > --- > I have to say the choice of variable names here is rather confusing. > LIB_MIN is used for the soname version, which would normally be the > *major* part of the version. > > I'll send a second patch that switches to more conventional library > versioning. > > Ben. > > tools/power/cpupower/Makefile | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/tools/power/cpupower/Makefile b/tools/power/cpupower/Makefile > index 8358863259c5..0b85f5915ce8 100644 > --- a/tools/power/cpupower/Makefile > +++ b/tools/power/cpupower/Makefile > @@ -64,7 +64,7 @@ DESTDIR ?= > > VERSION= $(shell ./utils/version-gen.sh) > LIB_MAJ= 0.0.1 > -LIB_MIN= 0 > +LIB_MIN= 1 > > PACKAGE = cpupower > PACKAGE_BUGREPORT = linux-pm@vger.kernel.org Repinging this patch. Thomas, we are shipping it in Debian since, and I'm wondering if the patch did just felt trough the cracks. Regards, Salvatore
On 5/9/23 12:50, Salvatore Bonaccorso wrote: > Hi Thomas, > > On Fri, Jun 10, 2016 at 01:56:20AM +0100, Ben Hutchings wrote: >> Several functions in the libcpupower API are renamed or removed in >> Linux 4.7. This is an backward-incompatible ABI change, so the >> library soname should change from libcpupower.so.0 to >> libcpupower.so.1. >> >> Fixes: ac5a181d065d ("cpupower: Add cpuidle parts into library") >> Signed-off-by: Ben Hutchings <ben@decadent.org.uk> >> --- >> I have to say the choice of variable names here is rather confusing. >> LIB_MIN is used for the soname version, which would normally be the >> *major* part of the version. >> >> I'll send a second patch that switches to more conventional library >> versioning. >> >> Ben. >> >> tools/power/cpupower/Makefile | 2 +- >> 1 file changed, 1 insertion(+), 1 deletion(-) >> >> diff --git a/tools/power/cpupower/Makefile b/tools/power/cpupower/Makefile >> index 8358863259c5..0b85f5915ce8 100644 >> --- a/tools/power/cpupower/Makefile >> +++ b/tools/power/cpupower/Makefile >> @@ -64,7 +64,7 @@ DESTDIR ?= >> >> VERSION= $(shell ./utils/version-gen.sh) >> LIB_MAJ= 0.0.1 >> -LIB_MIN= 0 >> +LIB_MIN= 1 >> >> PACKAGE = cpupower >> PACKAGE_BUGREPORT = linux-pm@vger.kernel.org > > Repinging this patch. Thomas, we are shipping it in Debian since, and > I'm wondering if the patch did just felt trough the cracks. > Please resend the patch for review. thanks, -- Shuah
Hi Shuah, Apologies for the delay! On Tue, May 09, 2023 at 04:10:05PM -0600, Shuah Khan wrote: > On 5/9/23 12:50, Salvatore Bonaccorso wrote: > > Hi Thomas, > > > > On Fri, Jun 10, 2016 at 01:56:20AM +0100, Ben Hutchings wrote: > > > Several functions in the libcpupower API are renamed or removed in > > > Linux 4.7. This is an backward-incompatible ABI change, so the > > > library soname should change from libcpupower.so.0 to > > > libcpupower.so.1. > > > > > > Fixes: ac5a181d065d ("cpupower: Add cpuidle parts into library") > > > Signed-off-by: Ben Hutchings <ben@decadent.org.uk> > > > --- > > > I have to say the choice of variable names here is rather confusing. > > > LIB_MIN is used for the soname version, which would normally be the > > > *major* part of the version. > > > > > > I'll send a second patch that switches to more conventional library > > > versioning. > > > > > > Ben. > > > > > > tools/power/cpupower/Makefile | 2 +- > > > 1 file changed, 1 insertion(+), 1 deletion(-) > > > > > > diff --git a/tools/power/cpupower/Makefile b/tools/power/cpupower/Makefile > > > index 8358863259c5..0b85f5915ce8 100644 > > > --- a/tools/power/cpupower/Makefile > > > +++ b/tools/power/cpupower/Makefile > > > @@ -64,7 +64,7 @@ DESTDIR ?= > > > VERSION= $(shell ./utils/version-gen.sh) > > > LIB_MAJ= 0.0.1 > > > -LIB_MIN= 0 > > > +LIB_MIN= 1 > > > PACKAGE = cpupower > > > PACKAGE_BUGREPORT = linux-pm@vger.kernel.org > > > > Repinging this patch. Thomas, we are shipping it in Debian since, and > > I'm wondering if the patch did just felt trough the cracks. > > > > Please resend the patch for review. Here is the patch again for a fresh review on it. If you want me to send it standalone with '[RESEND PATCH]' I can do that as well. Regards, Salvatore From 9091eb3294bad8f7d79eaff8f52ebeb02cc7d210 Mon Sep 17 00:00:00 2001 From: Ben Hutchings <ben@decadent.org.uk> Date: Thu, 9 Jun 2016 23:35:08 +0100 Subject: [PATCH] cpupower: Bump soname version Several functions in the libcpupower API are renamed or removed in Linux 4.7. This is an backward-incompatible ABI change, so the library soname should change from libcpupower.so.0 to libcpupower.so.1. Fixes: ac5a181d065d ("cpupower: Add cpuidle parts into library") Signed-off-by: Ben Hutchings <ben@decadent.org.uk> Signed-off-by: Salvatore Bonaccorso <carnil@debian.org> --- tools/power/cpupower/Makefile | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/tools/power/cpupower/Makefile b/tools/power/cpupower/Makefile index 59bfa05dec5d..dc531805a570 100644 --- a/tools/power/cpupower/Makefile +++ b/tools/power/cpupower/Makefile @@ -53,7 +53,7 @@ DESTDIR ?= VERSION:= $(shell ./utils/version-gen.sh) LIB_MAJ= 0.0.1 -LIB_MIN= 0 +LIB_MIN= 1 PACKAGE = cpupower PACKAGE_BUGREPORT = linux-pm@vger.kernel.org
On 5/12/23 13:57, Salvatore Bonaccorso wrote: > Hi Shuah, > > Apologies for the delay! > > On Tue, May 09, 2023 at 04:10:05PM -0600, Shuah Khan wrote: >> On 5/9/23 12:50, Salvatore Bonaccorso wrote: >>> Hi Thomas, >>> >>> On Fri, Jun 10, 2016 at 01:56:20AM +0100, Ben Hutchings wrote: >>>> Several functions in the libcpupower API are renamed or removed in >>>> Linux 4.7. This is an backward-incompatible ABI change, so the >>>> library soname should change from libcpupower.so.0 to >>>> libcpupower.so.1. >>>> >>>> Fixes: ac5a181d065d ("cpupower: Add cpuidle parts into library") >>>> Signed-off-by: Ben Hutchings <ben@decadent.org.uk> >>>> --- >>>> I have to say the choice of variable names here is rather confusing. >>>> LIB_MIN is used for the soname version, which would normally be the >>>> *major* part of the version. >>>> >>>> I'll send a second patch that switches to more conventional library >>>> versioning. >>>> >>>> Ben. >>>> >>>> tools/power/cpupower/Makefile | 2 +- >>>> 1 file changed, 1 insertion(+), 1 deletion(-) >>>> >>>> diff --git a/tools/power/cpupower/Makefile b/tools/power/cpupower/Makefile >>>> index 8358863259c5..0b85f5915ce8 100644 >>>> --- a/tools/power/cpupower/Makefile >>>> +++ b/tools/power/cpupower/Makefile >>>> @@ -64,7 +64,7 @@ DESTDIR ?= >>>> VERSION= $(shell ./utils/version-gen.sh) >>>> LIB_MAJ= 0.0.1 >>>> -LIB_MIN= 0 >>>> +LIB_MIN= 1 >>>> PACKAGE = cpupower >>>> PACKAGE_BUGREPORT = linux-pm@vger.kernel.org >>> >>> Repinging this patch. Thomas, we are shipping it in Debian since, and >>> I'm wondering if the patch did just felt trough the cracks. >>> >> >> Please resend the patch for review. > > Here is the patch again for a fresh review on it. If you want me to > send it standalone with '[RESEND PATCH]' I can do that as well. > Yes please resend with RESEND tag. I won't be able to apply the patch when it is included in the reply. thanks, -- Shuah
Hi, On Wed, May 17, 2023 at 11:53:59AM -0600, Shuah Khan wrote: > On 5/12/23 13:57, Salvatore Bonaccorso wrote: > > Hi Shuah, > > > > Apologies for the delay! > > > > On Tue, May 09, 2023 at 04:10:05PM -0600, Shuah Khan wrote: > > > On 5/9/23 12:50, Salvatore Bonaccorso wrote: > > > > Hi Thomas, > > > > > > > > On Fri, Jun 10, 2016 at 01:56:20AM +0100, Ben Hutchings wrote: > > > > > Several functions in the libcpupower API are renamed or removed in > > > > > Linux 4.7. This is an backward-incompatible ABI change, so the > > > > > library soname should change from libcpupower.so.0 to > > > > > libcpupower.so.1. > > > > > > > > > > Fixes: ac5a181d065d ("cpupower: Add cpuidle parts into library") > > > > > Signed-off-by: Ben Hutchings <ben@decadent.org.uk> > > > > > --- > > > > > I have to say the choice of variable names here is rather confusing. > > > > > LIB_MIN is used for the soname version, which would normally be the > > > > > *major* part of the version. > > > > > > > > > > I'll send a second patch that switches to more conventional library > > > > > versioning. > > > > > > > > > > Ben. > > > > > > > > > > tools/power/cpupower/Makefile | 2 +- > > > > > 1 file changed, 1 insertion(+), 1 deletion(-) > > > > > > > > > > diff --git a/tools/power/cpupower/Makefile b/tools/power/cpupower/Makefile > > > > > index 8358863259c5..0b85f5915ce8 100644 > > > > > --- a/tools/power/cpupower/Makefile > > > > > +++ b/tools/power/cpupower/Makefile > > > > > @@ -64,7 +64,7 @@ DESTDIR ?= > > > > > VERSION= $(shell ./utils/version-gen.sh) > > > > > LIB_MAJ= 0.0.1 > > > > > -LIB_MIN= 0 > > > > > +LIB_MIN= 1 > > > > > PACKAGE = cpupower > > > > > PACKAGE_BUGREPORT = linux-pm@vger.kernel.org > > > > > > > > Repinging this patch. Thomas, we are shipping it in Debian since, and > > > > I'm wondering if the patch did just felt trough the cracks. > > > > > > > > > > Please resend the patch for review. > > > > Here is the patch again for a fresh review on it. If you want me to > > send it standalone with '[RESEND PATCH]' I can do that as well. > > > > Yes please resend with RESEND tag. I won't be able to apply the patch > when it is included in the reply. Thanks for your patience! Just resent the patch as requested: https://lore.kernel.org/linux-pm/20230517191019.643031-1-carnil@debian.org/ Regards, Salvatore
diff --git a/tools/power/cpupower/Makefile b/tools/power/cpupower/Makefile index 8358863259c5..0b85f5915ce8 100644 --- a/tools/power/cpupower/Makefile +++ b/tools/power/cpupower/Makefile @@ -64,7 +64,7 @@ DESTDIR ?= VERSION= $(shell ./utils/version-gen.sh) LIB_MAJ= 0.0.1 -LIB_MIN= 0 +LIB_MIN= 1 PACKAGE = cpupower PACKAGE_BUGREPORT = linux-pm@vger.kernel.org
Several functions in the libcpupower API are renamed or removed in Linux 4.7. This is an backward-incompatible ABI change, so the library soname should change from libcpupower.so.0 to libcpupower.so.1. Fixes: ac5a181d065d ("cpupower: Add cpuidle parts into library") Signed-off-by: Ben Hutchings <ben@decadent.org.uk> --- I have to say the choice of variable names here is rather confusing. LIB_MIN is used for the soname version, which would normally be the *major* part of the version. I'll send a second patch that switches to more conventional library versioning. Ben. tools/power/cpupower/Makefile | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)