Message ID | 20191119002121.4107-12-sean.j.christopherson@intel.com (mailing list archive) |
---|---|
State | Not Applicable, archived |
Headers | show |
Series | treewide: break dependencies on x86's RM header | expand |
On Tuesday, November 19, 2019 1:21:20 AM CET Sean Christopherson wrote: > Convert acpi_wakeup_address from a raw variable into a function so that > x86 can wrap its dereference of the real mode boot header in a function > instead of broadcasting it to the world via a #define. This sets the > stage for a future patch to move the definition of acpi_wakeup_address() > out of asm/acpi.h and thus break acpi.h's dependency on asm/realmode.h. > > No functional change intended. > > Signed-off-by: Sean Christopherson <sean.j.christopherson@intel.com> Acked-by: Rafael J. Wysocki <rafael.j.wysocki@intel.com> > --- > arch/ia64/include/asm/acpi.h | 5 ++++- > arch/ia64/kernel/acpi.c | 2 -- > arch/x86/include/asm/acpi.h | 5 ++++- > drivers/acpi/sleep.c | 4 ++-- > 4 files changed, 10 insertions(+), 6 deletions(-) > > diff --git a/arch/ia64/include/asm/acpi.h b/arch/ia64/include/asm/acpi.h > index f886d4dc9d55..36d7003eee71 100644 > --- a/arch/ia64/include/asm/acpi.h > +++ b/arch/ia64/include/asm/acpi.h > @@ -38,7 +38,10 @@ int acpi_gsi_to_irq (u32 gsi, unsigned int *irq); > /* Low-level suspend routine. */ > extern int acpi_suspend_lowlevel(void); > > -extern unsigned long acpi_wakeup_address; > +static inline unsigned long acpi_wakeup_address(void) > +{ > + return 0; > +} > > /* > * Record the cpei override flag and current logical cpu. This is > diff --git a/arch/ia64/kernel/acpi.c b/arch/ia64/kernel/acpi.c > index 70d1587ddcd4..a5636524af76 100644 > --- a/arch/ia64/kernel/acpi.c > +++ b/arch/ia64/kernel/acpi.c > @@ -42,8 +42,6 @@ int acpi_lapic; > unsigned int acpi_cpei_override; > unsigned int acpi_cpei_phys_cpuid; > > -unsigned long acpi_wakeup_address = 0; > - > #define ACPI_MAX_PLATFORM_INTERRUPTS 256 > > /* Array to record platform interrupt vectors for generic interrupt routing. */ > diff --git a/arch/x86/include/asm/acpi.h b/arch/x86/include/asm/acpi.h > index bc9693c9107e..57788ec6fa82 100644 > --- a/arch/x86/include/asm/acpi.h > +++ b/arch/x86/include/asm/acpi.h > @@ -62,7 +62,10 @@ static inline void acpi_disable_pci(void) > extern int (*acpi_suspend_lowlevel)(void); > > /* Physical address to resume after wakeup */ > -#define acpi_wakeup_address ((unsigned long)(real_mode_header->wakeup_start)) > +static inline unsigned long acpi_wakeup_address(void) > +{ > + return ((unsigned long)(real_mode_header->wakeup_start)); > +} > > /* > * Check if the CPU can handle C2 and deeper > diff --git a/drivers/acpi/sleep.c b/drivers/acpi/sleep.c > index 2af937a8b1c5..9e66c4109556 100644 > --- a/drivers/acpi/sleep.c > +++ b/drivers/acpi/sleep.c > @@ -63,9 +63,9 @@ static int acpi_sleep_prepare(u32 acpi_state) > #ifdef CONFIG_ACPI_SLEEP > /* do we have a wakeup address for S2 and S3? */ > if (acpi_state == ACPI_STATE_S3) { > - if (!acpi_wakeup_address) > + if (!acpi_wakeup_address()) > return -EFAULT; > - acpi_set_waking_vector(acpi_wakeup_address); > + acpi_set_waking_vector(acpi_wakeup_address()); > > } > ACPI_FLUSH_CPU_CACHE(); >
> On Tuesday, November 19, 2019 1:21:20 AM CET Sean Christopherson wrote: > > Convert acpi_wakeup_address from a raw variable into a function so that > > x86 can wrap its dereference of the real mode boot header in a function > > instead of broadcasting it to the world via a #define. This sets the > > stage for a future patch to move the definition of acpi_wakeup_address() > > out of asm/acpi.h and thus break acpi.h's dependency on asm/realmode.h. > > > > No functional change intended. > > > > Signed-off-by: Sean Christopherson <sean.j.christopherson@intel.com> > > Acked-by: Rafael J. Wysocki <rafael.j.wysocki@intel.com> > > > --- a/drivers/acpi/sleep.c > > +++ b/drivers/acpi/sleep.c > > @@ -63,9 +63,9 @@ static int acpi_sleep_prepare(u32 acpi_state) > > #ifdef CONFIG_ACPI_SLEEP > > /* do we have a wakeup address for S2 and S3? */ > > if (acpi_state == ACPI_STATE_S3) { > > - if (!acpi_wakeup_address) > > + if (!acpi_wakeup_address()) > > return -EFAULT; > > - acpi_set_waking_vector(acpi_wakeup_address); > > + acpi_set_waking_vector(acpi_wakeup_address()); > > You might want to store result in a variable... especially since you are turning inline function into real one in a next patch. And maybe function should be called get_acip_wakeup_address or something? This way it is easy to mistake actual wakeup address from function that gets it... Best regards, Pavel > >
On Mon, Nov 25, 2019 at 11:48:03AM +0100, Pavel Machek wrote: > > On Tuesday, November 19, 2019 1:21:20 AM CET Sean Christopherson wrote: > > > Convert acpi_wakeup_address from a raw variable into a function so that > > > x86 can wrap its dereference of the real mode boot header in a function > > > instead of broadcasting it to the world via a #define. This sets the > > > stage for a future patch to move the definition of acpi_wakeup_address() > > > out of asm/acpi.h and thus break acpi.h's dependency on asm/realmode.h. > > > > > > No functional change intended. > > > > > > Signed-off-by: Sean Christopherson <sean.j.christopherson@intel.com> > > > > Acked-by: Rafael J. Wysocki <rafael.j.wysocki@intel.com> > > > > > --- a/drivers/acpi/sleep.c > > > +++ b/drivers/acpi/sleep.c > > > @@ -63,9 +63,9 @@ static int acpi_sleep_prepare(u32 acpi_state) > > > #ifdef CONFIG_ACPI_SLEEP > > > /* do we have a wakeup address for S2 and S3? */ > > > if (acpi_state == ACPI_STATE_S3) { > > > - if (!acpi_wakeup_address) > > > + if (!acpi_wakeup_address()) > > > return -EFAULT; > > > - acpi_set_waking_vector(acpi_wakeup_address); > > > + acpi_set_waking_vector(acpi_wakeup_address()); > > > > > You might want to store result in a variable... especially since you are > turning inline function into real one in a next patch. > > And maybe function should be called get_acip_wakeup_address or > something? This way it is easy to mistake actual wakeup address from > function that gets it... Agreed on both counts. Ingo, Would you prefer a v2 of the entire series (with Acks and removal of Fixes), or a v2 that includes only the last two patches?
* Sean Christopherson <sean.j.christopherson@intel.com> wrote: > On Mon, Nov 25, 2019 at 11:48:03AM +0100, Pavel Machek wrote: > > > On Tuesday, November 19, 2019 1:21:20 AM CET Sean Christopherson wrote: > > > > Convert acpi_wakeup_address from a raw variable into a function so that > > > > x86 can wrap its dereference of the real mode boot header in a function > > > > instead of broadcasting it to the world via a #define. This sets the > > > > stage for a future patch to move the definition of acpi_wakeup_address() > > > > out of asm/acpi.h and thus break acpi.h's dependency on asm/realmode.h. > > > > > > > > No functional change intended. > > > > > > > > Signed-off-by: Sean Christopherson <sean.j.christopherson@intel.com> > > > > > > Acked-by: Rafael J. Wysocki <rafael.j.wysocki@intel.com> > > > > > > > --- a/drivers/acpi/sleep.c > > > > +++ b/drivers/acpi/sleep.c > > > > @@ -63,9 +63,9 @@ static int acpi_sleep_prepare(u32 acpi_state) > > > > #ifdef CONFIG_ACPI_SLEEP > > > > /* do we have a wakeup address for S2 and S3? */ > > > > if (acpi_state == ACPI_STATE_S3) { > > > > - if (!acpi_wakeup_address) > > > > + if (!acpi_wakeup_address()) > > > > return -EFAULT; > > > > - acpi_set_waking_vector(acpi_wakeup_address); > > > > + acpi_set_waking_vector(acpi_wakeup_address()); > > > > > > > > You might want to store result in a variable... especially since you are > > turning inline function into real one in a next patch. > > > > And maybe function should be called get_acip_wakeup_address or > > something? This way it is easy to mistake actual wakeup address from > > function that gets it... > > Agreed on both counts. > > > Ingo, > > Would you prefer a v2 of the entire series (with Acks and removal of Fixes), > or a v2 that includes only the last two patches? Yep, that would be handy. I have them committed to tip:core/headers, but haven't sent it to Linus yet, and can redo that all with these improvements. Thanks, Ingo
* Ingo Molnar <mingo@kernel.org> wrote: > > Would you prefer a v2 of the entire series (with Acks and removal of > > Fixes), or a v2 that includes only the last two patches? > > Yep, that would be handy. I have them committed to tip:core/headers, > but haven't sent it to Linus yet, and can redo that all with these > improvements. Now these bits are back in tip:WIP.core/headers, waiting for the v2 submission. Thanks, Ingo
diff --git a/arch/ia64/include/asm/acpi.h b/arch/ia64/include/asm/acpi.h index f886d4dc9d55..36d7003eee71 100644 --- a/arch/ia64/include/asm/acpi.h +++ b/arch/ia64/include/asm/acpi.h @@ -38,7 +38,10 @@ int acpi_gsi_to_irq (u32 gsi, unsigned int *irq); /* Low-level suspend routine. */ extern int acpi_suspend_lowlevel(void); -extern unsigned long acpi_wakeup_address; +static inline unsigned long acpi_wakeup_address(void) +{ + return 0; +} /* * Record the cpei override flag and current logical cpu. This is diff --git a/arch/ia64/kernel/acpi.c b/arch/ia64/kernel/acpi.c index 70d1587ddcd4..a5636524af76 100644 --- a/arch/ia64/kernel/acpi.c +++ b/arch/ia64/kernel/acpi.c @@ -42,8 +42,6 @@ int acpi_lapic; unsigned int acpi_cpei_override; unsigned int acpi_cpei_phys_cpuid; -unsigned long acpi_wakeup_address = 0; - #define ACPI_MAX_PLATFORM_INTERRUPTS 256 /* Array to record platform interrupt vectors for generic interrupt routing. */ diff --git a/arch/x86/include/asm/acpi.h b/arch/x86/include/asm/acpi.h index bc9693c9107e..57788ec6fa82 100644 --- a/arch/x86/include/asm/acpi.h +++ b/arch/x86/include/asm/acpi.h @@ -62,7 +62,10 @@ static inline void acpi_disable_pci(void) extern int (*acpi_suspend_lowlevel)(void); /* Physical address to resume after wakeup */ -#define acpi_wakeup_address ((unsigned long)(real_mode_header->wakeup_start)) +static inline unsigned long acpi_wakeup_address(void) +{ + return ((unsigned long)(real_mode_header->wakeup_start)); +} /* * Check if the CPU can handle C2 and deeper diff --git a/drivers/acpi/sleep.c b/drivers/acpi/sleep.c index 2af937a8b1c5..9e66c4109556 100644 --- a/drivers/acpi/sleep.c +++ b/drivers/acpi/sleep.c @@ -63,9 +63,9 @@ static int acpi_sleep_prepare(u32 acpi_state) #ifdef CONFIG_ACPI_SLEEP /* do we have a wakeup address for S2 and S3? */ if (acpi_state == ACPI_STATE_S3) { - if (!acpi_wakeup_address) + if (!acpi_wakeup_address()) return -EFAULT; - acpi_set_waking_vector(acpi_wakeup_address); + acpi_set_waking_vector(acpi_wakeup_address()); } ACPI_FLUSH_CPU_CACHE();
Convert acpi_wakeup_address from a raw variable into a function so that x86 can wrap its dereference of the real mode boot header in a function instead of broadcasting it to the world via a #define. This sets the stage for a future patch to move the definition of acpi_wakeup_address() out of asm/acpi.h and thus break acpi.h's dependency on asm/realmode.h. No functional change intended. Signed-off-by: Sean Christopherson <sean.j.christopherson@intel.com> --- arch/ia64/include/asm/acpi.h | 5 ++++- arch/ia64/kernel/acpi.c | 2 -- arch/x86/include/asm/acpi.h | 5 ++++- drivers/acpi/sleep.c | 4 ++-- 4 files changed, 10 insertions(+), 6 deletions(-)