Message ID | 20200413123207.74552-3-paul@crapouillou.net (mailing list archive) |
---|---|
State | RFC |
Headers | show |
Series | [v2,1/3] PM: introduce pm_ptr() macro | expand |
On Mon, 13 Apr 2020 at 14:32, Paul Cercueil <paul@crapouillou.net> wrote: > > Use the newly introduced pm_ptr() macro to simplify the code. > > Signed-off-by: Paul Cercueil <paul@crapouillou.net> To me, the series is a step in the right direction. Perhaps there is a better name than "pm_ptr", but that's just a nitpick. That said, feel free to add (for all three patches in the series): Reviewed-by: Ulf Hansson <ulf.hansson@linaro.org> Let's see what Rafael thinks about this. Kind regards Uffe > --- > > Notes: > v2: Use pm_ptr() macro instead of pm_sleep_ptr() > > drivers/mmc/host/jz4740_mmc.c | 12 +++--------- > 1 file changed, 3 insertions(+), 9 deletions(-) > > diff --git a/drivers/mmc/host/jz4740_mmc.c b/drivers/mmc/host/jz4740_mmc.c > index fbae87d1f017..2d41e7e5ec43 100644 > --- a/drivers/mmc/host/jz4740_mmc.c > +++ b/drivers/mmc/host/jz4740_mmc.c > @@ -1099,24 +1099,18 @@ static int jz4740_mmc_remove(struct platform_device *pdev) > return 0; > } > > -#ifdef CONFIG_PM_SLEEP > - > -static int jz4740_mmc_suspend(struct device *dev) > +static int __maybe_unused jz4740_mmc_suspend(struct device *dev) > { > return pinctrl_pm_select_sleep_state(dev); > } > > -static int jz4740_mmc_resume(struct device *dev) > +static int __maybe_unused jz4740_mmc_resume(struct device *dev) > { > return pinctrl_select_default_state(dev); > } > > static SIMPLE_DEV_PM_OPS(jz4740_mmc_pm_ops, jz4740_mmc_suspend, > jz4740_mmc_resume); > -#define JZ4740_MMC_PM_OPS (&jz4740_mmc_pm_ops) > -#else > -#define JZ4740_MMC_PM_OPS NULL > -#endif > > static struct platform_driver jz4740_mmc_driver = { > .probe = jz4740_mmc_probe, > @@ -1124,7 +1118,7 @@ static struct platform_driver jz4740_mmc_driver = { > .driver = { > .name = "jz4740-mmc", > .of_match_table = of_match_ptr(jz4740_mmc_of_match), > - .pm = JZ4740_MMC_PM_OPS, > + .pm = pm_ptr(&jz4740_mmc_pm_ops), > }, > }; > > -- > 2.25.1 >
diff --git a/drivers/mmc/host/jz4740_mmc.c b/drivers/mmc/host/jz4740_mmc.c index fbae87d1f017..2d41e7e5ec43 100644 --- a/drivers/mmc/host/jz4740_mmc.c +++ b/drivers/mmc/host/jz4740_mmc.c @@ -1099,24 +1099,18 @@ static int jz4740_mmc_remove(struct platform_device *pdev) return 0; } -#ifdef CONFIG_PM_SLEEP - -static int jz4740_mmc_suspend(struct device *dev) +static int __maybe_unused jz4740_mmc_suspend(struct device *dev) { return pinctrl_pm_select_sleep_state(dev); } -static int jz4740_mmc_resume(struct device *dev) +static int __maybe_unused jz4740_mmc_resume(struct device *dev) { return pinctrl_select_default_state(dev); } static SIMPLE_DEV_PM_OPS(jz4740_mmc_pm_ops, jz4740_mmc_suspend, jz4740_mmc_resume); -#define JZ4740_MMC_PM_OPS (&jz4740_mmc_pm_ops) -#else -#define JZ4740_MMC_PM_OPS NULL -#endif static struct platform_driver jz4740_mmc_driver = { .probe = jz4740_mmc_probe, @@ -1124,7 +1118,7 @@ static struct platform_driver jz4740_mmc_driver = { .driver = { .name = "jz4740-mmc", .of_match_table = of_match_ptr(jz4740_mmc_of_match), - .pm = JZ4740_MMC_PM_OPS, + .pm = pm_ptr(&jz4740_mmc_pm_ops), }, };
Use the newly introduced pm_ptr() macro to simplify the code. Signed-off-by: Paul Cercueil <paul@crapouillou.net> --- Notes: v2: Use pm_ptr() macro instead of pm_sleep_ptr() drivers/mmc/host/jz4740_mmc.c | 12 +++--------- 1 file changed, 3 insertions(+), 9 deletions(-)