Message ID | 20200515135626.2554873-1-niklas.soderlund+renesas@ragnatech.se (mailing list archive) |
---|---|
State | New, archived |
Delegated to: | Daniel Lezcano |
Headers | show |
Series | thermal: rcar_gen3_thermal: Do not shadow thcode variable | expand |
Hi Niklas, Thanks for your patch! On Fri, May 15, 2020 at 3:56 PM Niklas Söderlund <niklas.soderlund+renesas@ragnatech.se> wrote: > The function rcar_gen3_thermal_calc_coefs() takes an argument called > 'thcode' which shadows the static global 'thcode' variable. This is not > harmful but bad for readability and is harmful for planed changes to the planned > driver. The THCODE values should be read from hardware fuses if they are > available and only fallback to the global 'thcode' variable if they are > not fused. > > Rename the global 'thcode' variable to 'thcodes' to avoid shadowing the > symbol in functions that takes it as an argument. take > > Signed-off-by: Niklas Söderlund <niklas.soderlund+renesas@ragnatech.se> Reviewed-by: Geert Uytterhoeven <geert+renesas@glider.be> Gr{oetje,eeting}s, Geert
diff --git a/drivers/thermal/rcar_gen3_thermal.c b/drivers/thermal/rcar_gen3_thermal.c index 58fe7c1ef00b1270..bb4f5b42beb943e3 100644 --- a/drivers/thermal/rcar_gen3_thermal.c +++ b/drivers/thermal/rcar_gen3_thermal.c @@ -63,7 +63,7 @@ #define TSC_MAX_NUM 3 /* default THCODE values if FUSEs are missing */ -static const int thcode[TSC_MAX_NUM][3] = { +static const int thcodes[TSC_MAX_NUM][3] = { { 3397, 2800, 2221 }, { 3393, 2795, 2216 }, { 3389, 2805, 2237 }, @@ -172,7 +172,7 @@ static int rcar_gen3_thermal_get_temp(void *devdata, int *temp) /* Read register and convert to mili Celsius */ reg = rcar_gen3_thermal_read(tsc, REG_GEN3_TEMP) & CTEMP_MASK; - if (reg <= thcode[tsc->id][1]) + if (reg <= thcodes[tsc->id][1]) val = FIXPT_DIV(FIXPT_INT(reg) - tsc->coef.b1, tsc->coef.a1); else @@ -430,7 +430,7 @@ static int rcar_gen3_thermal_probe(struct platform_device *pdev) priv->tscs[i] = tsc; priv->thermal_init(tsc); - rcar_gen3_thermal_calc_coefs(tsc, ptat, thcode[i], + rcar_gen3_thermal_calc_coefs(tsc, ptat, thcodes[i], *rcar_gen3_ths_tj_1); zone = devm_thermal_zone_of_sensor_register(dev, i, tsc,
The function rcar_gen3_thermal_calc_coefs() takes an argument called 'thcode' which shadows the static global 'thcode' variable. This is not harmful but bad for readability and is harmful for planed changes to the driver. The THCODE values should be read from hardware fuses if they are available and only fallback to the global 'thcode' variable if they are not fused. Rename the global 'thcode' variable to 'thcodes' to avoid shadowing the symbol in functions that takes it as an argument. Signed-off-by: Niklas Söderlund <niklas.soderlund+renesas@ragnatech.se> --- drivers/thermal/rcar_gen3_thermal.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-)