mbox series

[for-next,00/13] Updates hns for v4.19

Message ID 1532503781-45205-1-git-send-email-oulijun@huawei.com (mailing list archive)
Headers show
Series Updates hns for v4.19 | expand

Message

Lijun Ou July 25, 2018, 7:29 a.m. UTC
This patch series mainly optimizes some lines for hns, included
return correct errono and some bugfixes as well as expose modify
cq verbs for user.

Lijun Ou (13):
  RDMA/hns: Only assgin the fields of av if IB_QP_AV bit is set
  RDMA/hns: Optimized the verb of creating ah
  RDMA/hns: Fix the bug for init cmq
  RDMA/hns: Assign the value for vlan field of qp context
  RDMA/hns: Add 50GE type of hnae3 device match
  RDMA/hns: Modify qp will return errno When qp type is illegal
  RDMA/hns: Use macro instead of magic number
  RDMA/hns: Return correct result with hns_roce_v1_rsv_lp_qp function
  RDMA/hns: Add illegal hop_num judgement
  RDMA/hns: Use delay instead of usleep
  RDMA/hns: Some updates for the fields of address handle
  RDMA/hns: Update the data type of immediate data
  RDMA/hns: Only enable modify cq if uverbs_ex_cmd_mask set

 drivers/infiniband/hw/hns/hns_roce_ah.c     |  74 +++++++-----
 drivers/infiniband/hw/hns/hns_roce_device.h |   2 +-
 drivers/infiniband/hw/hns/hns_roce_hem.c    |   7 +-
 drivers/infiniband/hw/hns/hns_roce_hw_v1.c  |  11 +-
 drivers/infiniband/hw/hns/hns_roce_hw_v2.c  | 176 ++++++++++++++++++++--------
 drivers/infiniband/hw/hns/hns_roce_hw_v2.h  |  13 +-
 drivers/infiniband/hw/hns/hns_roce_main.c   |   6 +-
 7 files changed, 202 insertions(+), 87 deletions(-)

Comments

Jason Gunthorpe July 27, 2018, 2:36 a.m. UTC | #1
On Wed, Jul 25, 2018 at 03:29:28PM +0800, Lijun Ou wrote:
> This patch series mainly optimizes some lines for hns, included
> return correct errono and some bugfixes as well as expose modify
> cq verbs for user.
> 
> Lijun Ou (13):
>   RDMA/hns: Fix the bug for init cmq
>   RDMA/hns: Add 50GE type of hnae3 device match
>   RDMA/hns: Return correct result with hns_roce_v1_rsv_lp_qp function
>   RDMA/hns: Add illegal hop_num judgement
>   RDMA/hns: Use delay instead of usleep
>   RDMA/hns: Update the data type of immediate data
>   RDMA/hns: Only enable modify cq if uverbs_ex_cmd_mask set

I took these patches, but rewrote almost all the commit messages

>   RDMA/hns: Only assgin the fields of av if IB_QP_AV bit is set
>   RDMA/hns: Optimized the verb of creating ah
>   RDMA/hns: Assign the value for vlan field of qp context
>   RDMA/hns: Modify qp will return errno When qp type is illegal
>   RDMA/hns: Use macro instead of magic number
>   RDMA/hns: Some updates for the fields of address handle

Some of these had comments, all need reworked commit messages. Please
revise and resend.

Thanks,
Jason
--
To unsubscribe from this list: send the line "unsubscribe linux-rdma" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html