mbox series

[for-next,0/9] Codes optimization for hip08

Message ID 1562593285-8037-1-git-send-email-oulijun@huawei.com (mailing list archive)
Headers show
Series Codes optimization for hip08 | expand

Message

Lijun Ou July 8, 2019, 1:41 p.m. UTC
Here are codes optimization in order to reduce complexity and
add readability.

Lijun Ou (6):
  RDMA/hns: Package the flow of creating cq
  RDMA/hns: Refactor the code of creating srq
  RDMA/hns: Refactor for hns_roce_v2_modify_qp function
  RDMA/hns: Use a separated function for setting extend sge paramters
  RDMA/hns: Package for hns_roce_rereg_user_mr function
  RDMA/hns: Refactor hem table mhop check and calculation

Xi Wang (1):
  RDMA/hns: optimize the duplicated code for qpc setting flow

Yixian Liu (1):
  RDMA/hns: Refactor eq table init for hip08

chenglang (1):
  RDMA/hns: Optimize hns_roce_mhop_alloc function.

 drivers/infiniband/hw/hns/hns_roce_cq.c     | 186 +++++---
 drivers/infiniband/hw/hns/hns_roce_device.h |   2 -
 drivers/infiniband/hw/hns/hns_roce_hem.c    | 180 ++++----
 drivers/infiniband/hw/hns/hns_roce_hw_v2.c  | 628 ++++++++++++++++------------
 drivers/infiniband/hw/hns/hns_roce_mr.c     | 428 +++++++++++--------
 drivers/infiniband/hw/hns/hns_roce_qp.c     |  61 ++-
 drivers/infiniband/hw/hns/hns_roce_srq.c    | 310 ++++++++------
 7 files changed, 1015 insertions(+), 780 deletions(-)

Comments

Jason Gunthorpe July 25, 2019, 3:42 p.m. UTC | #1
On Mon, Jul 08, 2019 at 09:41:16PM +0800, Lijun Ou wrote:
> Here are codes optimization in order to reduce complexity and
> add readability.
> 
> Lijun Ou (6):
>   RDMA/hns: Package the flow of creating cq
>   RDMA/hns: Refactor the code of creating srq
>   RDMA/hns: Refactor for hns_roce_v2_modify_qp function
>   RDMA/hns: Use a separated function for setting extend sge paramters
>   RDMA/hns: Package for hns_roce_rereg_user_mr function
>   RDMA/hns: Refactor hem table mhop check and calculation
> 
> Xi Wang (1):
>   RDMA/hns: optimize the duplicated code for qpc setting flow
> 
> Yixian Liu (1):
>   RDMA/hns: Refactor eq table init for hip08
> 
> chenglang (1):
>   RDMA/hns: Optimize hns_roce_mhop_alloc function.

Applied to for-next

Thanks,
Jason