Message ID | 20220420121240.67781-1-u.kleine-koenig@pengutronix.de (mailing list archive) |
---|---|
Headers | show |
Series | pwm: renesas-tpu: Various improvements | expand |
Hi Uwe, On Wed, Apr 20, 2022 at 2:12 PM Uwe Kleine-König <u.kleine-koenig@pengutronix.de> wrote: > I reworked the series to improve the renesas-tpu PWM driver after > feedback I got from Geert. The changes are: > > - Add Geert's tags for the first two patches > (I didn't add them for the other patches as I changed these enough to > not carry the tags forward.) > - Use tpu_pwm_disable instead chip->ops->disable (which is NULL now) > fixing a crash in v1. > - The calculation now uses a switch instead of ilog2. > Looking at the compiled code for ARM this is more effective and I > assume the same holds true for other platforms. Display backlight on the R-Mobile A1-based Atmark Techno Armadillo-800EVA still works fine, so Tested-by: Geert Uytterhoeven <geert+renesas@glider.be> Gr{oetje,eeting}s, Geert -- Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org In personal conversations with technical people, I call myself a hacker. But when I'm talking to journalists I just say "programmer" or something like that. -- Linus Torvalds
On Wed, Apr 20, 2022 at 02:12:34PM +0200, Uwe Kleine-König wrote: > Hello, > > I reworked the series to improve the renesas-tpu PWM driver after > feedback I got from Geert. The changes are: > > - Add Geert's tags for the first two patches > (I didn't add them for the other patches as I changed these enough to > not carry the tags forward.) > - Use tpu_pwm_disable instead chip->ops->disable (which is NULL now) > fixing a crash in v1. > - The calculation now uses a switch instead of ilog2. > Looking at the compiled code for ARM this is more effective and I > assume the same holds true for other platforms. > > Thanks again to Geert for his valuable feedback and testing. > > Best regards > Uwe > > Uwe Kleine-König (6): > pwm: renesas-tpu: Make use of dev_err_probe() > pwm: renesas-tpu: Make use of devm functions > pwm: renesas-tpu: Implement .apply() callback > pwm: renesas-tpu: Rename variables to match the usual naming > pwm: renesas-tpu: Improve maths to compute register settings > pwm: renesas-tpu: Improve precision of period and duty_cycle > calculation > > drivers/pwm/pwm-renesas-tpu.c | 317 +++++++++++++++++++--------------- > 1 file changed, 180 insertions(+), 137 deletions(-) Applied, with the checkpatch warning in patch 5/6 addressed (I opted to replace the tabs by spaces). Thanks, Thierry