Message ID | 20230104074146.578485-1-uwu@icenowy.me (mailing list archive) |
---|---|
Headers | show |
Series | Support using physical addresses for RISC-V CMO | expand |
在 2023-01-04星期三的 13:16 +0100,Heiko Stübner写道: > Hi, > > Am Mittwoch, 4. Januar 2023, 10:27:53 CET schrieb Icenowy Zheng: > > 在 2023-01-04星期三的 17:24 +0800,Guo Ren写道: > > > On Wed, Jan 4, 2023 at 4:59 PM Icenowy Zheng <uwu@icenowy.me> > > > wrote: > > > > > > > > 在 2023-01-04星期三的 16:50 +0800,Guo Ren写道: > > > > > On Wed, Jan 4, 2023 at 3:43 PM Icenowy Zheng <uwu@icenowy.me> > > > > > wrote: > > > > > > > > > > > > DMA synchorization is done on PA and the VA is calculated > > > > > > from > > > > > > the > > > > > > PA. > > > > > > > > > > > > Use the alternative macro variant that takes both VA and PA > > > > > > as > > > > > > parameters, thus in case the ISA extension used support PA > > > > > > directly, the > > > > > > overhead for re-converting VA to PA can be omitted. > > > > > > > > > > > > Suggested-by: Guo Ren <guoren@kernel.org> > > > > > > Signed-off-by: Icenowy Zheng <uwu@icenowy.me> > > > > > > --- > > > > > > arch/riscv/mm/dma-noncoherent.c | 8 ++++---- > > > > > > 1 file changed, 4 insertions(+), 4 deletions(-) > > > > > > > > > > > > diff --git a/arch/riscv/mm/dma-noncoherent.c > > > > > > b/arch/riscv/mm/dma- > > > > > > noncoherent.c > > > > > > index d919efab6eba..a751f4aece62 100644 > > > > > > --- a/arch/riscv/mm/dma-noncoherent.c > > > > > > +++ b/arch/riscv/mm/dma-noncoherent.c > > > > > > @@ -19,13 +19,13 @@ void > > > > > > arch_sync_dma_for_device(phys_addr_t > > > > > > paddr, size_t size, > > > > > > > > > > > > switch (dir) { > > > > > > case DMA_TO_DEVICE: > > > > > > - ALT_CMO_OP(clean, vaddr, size, > > > > > > riscv_cbom_block_size); > > > > > > + ALT_CMO_OP_VPA(clean, vaddr, paddr, size, > > > > > > riscv_cbom_block_size); > > > > > ALT_CMO_OP -> ALT_CMO_OP_VPA, is the renaming necessary? > > > > > > > > I didn't rename the original ALT_CMO_OP, ALT_CMO_OP_VPA is > > > > something > > > > new. > > > The ##_VPA is really strange. > > > > > > How about: > > > ALT_CMO_OP -> ALT_CMO_OP_VA > > > ALT_CMO_OP_VPA -> ALT_CMO_OP > > > > It's thus a much bigger change. > > > > If you are not fond of _VPA, I can rename it to _VA_PA. > > before you spend too much time on this, there is currently a parallel > discussion running about including all the other different vendor- > specific cache management. > > See [0] and the thread before that for reference. The code shown here seems to be only a draft, and not even testable. > > The consensus seems to be that cache-handling itself is not fast > anyway, > and therefore to reduce complexity for the cache handling and move > non-zicbom cache-handling into a indirect function call that the can > be > overridden at runtime. Well yes I tested this patchset on my LiteX with OpenC906, and it does not help at all on LiteETH throughtput. So maybe this is only some theortical gain. > > > Heiko > > [0] > https://lore.kernel.org/all/43aee000-5b89-4d94-98d2-b37b1a18a83e@app.fastmail.com/ > >