Series |
ACPI/arm64: add support for virtual cpuhotplug
|
expand
-
[RFC,v2,00/35] ACPI/arm64: add support for virtual cpuhotplug
-
[RFC,v2,01/35] ACPI: Move ACPI_HOTPLUG_CPU to be disabled on arm64 and riscv
-
[RFC,v2,02/35] drivers: base: Use present CPUs in GENERIC_CPU_DEVICES
-
[RFC,v2,03/35] drivers: base: Allow parts of GENERIC_CPU_DEVICES to be overridden
-
[RFC,v2,04/35] drivers: base: Move cpu_dev_init() after node_dev_init()
-
[RFC,v2,05/35] drivers: base: Print a warning instead of panic() when register_cpu() fails
-
[RFC,v2,06/35] arm64: setup: Switch over to GENERIC_CPU_DEVICES using arch_register_cpu()
-
[RFC,v2,07/35] x86: intel_epb: Don't rely on link order
-
[RFC,v2,08/35] x86/topology: Switch over to GENERIC_CPU_DEVICES
-
[RFC,v2,09/35] LoongArch: Switch over to GENERIC_CPU_DEVICES
-
[RFC,v2,10/35] riscv: Switch over to GENERIC_CPU_DEVICES
-
[RFC,v2,11/35] arch_topology: Make register_cpu_capacity_sysctl() tolerant to late CPUs
-
[RFC,v2,12/35] ACPI: Use the acpi_device_is_present() helper in more places
-
[RFC,v2,13/35] ACPI: Rename acpi_scan_device_not_present() to be about enumeration
-
[RFC,v2,14/35] ACPI: Only enumerate enabled (or functional) devices
-
[RFC,v2,15/35] ACPI: processor: Add support for processors described as container packages
-
[RFC,v2,16/35] ACPI: processor: Register CPUs that are online, but not described in the DSDT
-
[RFC,v2,17/35] ACPI: processor: Register all CPUs from acpi_processor_get_info()
-
[RFC,v2,18/35] ACPI: Rename ACPI_HOTPLUG_CPU to include 'present'
-
[RFC,v2,19/35] ACPI: Move acpi_bus_trim_one() before acpi_scan_hot_remove()
-
[RFC,v2,20/35] ACPI: Rename acpi_processor_hotadd_init and remove pre-processor guards
-
[RFC,v2,21/35] ACPI: Add post_eject to struct acpi_scan_handler for cpu hotplug
-
[RFC,v2,22/35] ACPI: Check _STA present bit before making CPUs not present
-
[RFC,v2,23/35] ACPI: Warn when the present bit changes but the feature is not enabled
-
[RFC,v2,24/35] drivers: base: Implement weak arch_unregister_cpu()
-
[RFC,v2,25/35] LoongArch: Use the __weak version of arch_unregister_cpu()
-
[RFC,v2,26/35] arm64: acpi: Move get_cpu_for_acpi_id() to a header
-
[RFC,v2,27/35] ACPICA: Add new MADT GICC flags fields [code first?]
-
[RFC,v2,28/35] arm64, irqchip/gic-v3, ACPI: Move MADT GICC enabled check into a helper
-
[RFC,v2,29/35] irqchip/gic-v3: Don't return errors from gic_acpi_match_gicc()
-
[RFC,v2,30/35] irqchip/gic-v3: Add support for ACPI's disabled but 'online capable' CPUs
-
[RFC,v2,31/35] arm64: psci: Ignore DENIED CPUs
-
[RFC,v2,32/35] ACPI: add support to register CPUs based on the _STA enabled bit
-
[RFC,v2,33/35] arm64: document virtual CPU hotplug's expectations
-
[RFC,v2,34/35] ACPI: Add _OSC bits to advertise OS support for toggling CPU present/enabled
-
[RFC,v2,35/35] cpumask: Add enabled cpumask for present CPUs that can be brought online
|