Message ID | d651269a681150f9bdca8103434fb3f4b509f784.1704800524.git.christophe.leroy@csgroup.eu (mailing list archive) |
---|---|
State | Handled Elsewhere |
Headers | show |
Series | Refactor CONFIG_DEBUG_WX and check_wx_pages debugfs attribute | expand |
On 1/9/24 04:14, Christophe Leroy wrote: > CONFIG_DEBUG_WX is a core option defined in mm/Kconfig.debug > > To avoid any future conflict, rename ARM version > into CONFIG_ARM_DEBUG_WX. > > Signed-off-by: Christophe Leroy <christophe.leroy@csgroup.eu> Looks fine, you might also want to s/CONFIG_DEBUG_WX/CONFIG_ARM_DEBUG_WX/ in arch/arm/configs/aspeed_g{4,5}_defconfig so there are no surprises when people pull in those changes.
diff --git a/arch/arm/Kconfig.debug b/arch/arm/Kconfig.debug index fc2b41d41447..141151d632f6 100644 --- a/arch/arm/Kconfig.debug +++ b/arch/arm/Kconfig.debug @@ -17,7 +17,7 @@ config ARM_PTDUMP_DEBUGFS kernel. If in doubt, say "N" -config DEBUG_WX +config ARM_DEBUG_WX bool "Warn on W+X mappings at boot" depends on MMU select ARM_PTDUMP_CORE diff --git a/arch/arm/include/asm/ptdump.h b/arch/arm/include/asm/ptdump.h index aad1d034136c..46a4575146ee 100644 --- a/arch/arm/include/asm/ptdump.h +++ b/arch/arm/include/asm/ptdump.h @@ -32,10 +32,10 @@ void ptdump_check_wx(void); #endif /* CONFIG_ARM_PTDUMP_CORE */ -#ifdef CONFIG_DEBUG_WX -#define debug_checkwx() ptdump_check_wx() +#ifdef CONFIG_ARM_DEBUG_WX +#define arm_debug_checkwx() ptdump_check_wx() #else -#define debug_checkwx() do { } while (0) +#define arm_debug_checkwx() do { } while (0) #endif #endif /* __ASM_PTDUMP_H */
CONFIG_DEBUG_WX is a core option defined in mm/Kconfig.debug To avoid any future conflict, rename ARM version into CONFIG_ARM_DEBUG_WX. Signed-off-by: Christophe Leroy <christophe.leroy@csgroup.eu> --- arch/arm/Kconfig.debug | 2 +- arch/arm/include/asm/ptdump.h | 6 +++--- 2 files changed, 4 insertions(+), 4 deletions(-)