Message ID | 20220303203958.4904-4-macroalpha82@gmail.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | rk808: Convert bindings to yaml | expand |
On 2022-03-03 20:39, Chris Morgan wrote: > From: Chris Morgan <macromorgan@hotmail.com> > > The regulator name of SWITCH_REG1 does not match any other board > with a rk818 PMIC, nor does it correspond to a regulator in the > rk808-regulator driver. Changing name to SWITCH_REG which is > consistent with other boards and is in the driver. The datasheet I found also names the channel "SWITCH" rather than "SWITCH1", so this seems correct to me. Reviewed-by: Robin Murphy <robin.murphy@arm.com> > Signed-off-by: Chris Morgan <macromorgan@hotmail.com> > --- > arch/arm/boot/dts/rk3188-px3-evb.dts | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/arch/arm/boot/dts/rk3188-px3-evb.dts b/arch/arm/boot/dts/rk3188-px3-evb.dts > index 39c60426c9c9..fc478ac4e781 100644 > --- a/arch/arm/boot/dts/rk3188-px3-evb.dts > +++ b/arch/arm/boot/dts/rk3188-px3-evb.dts > @@ -212,7 +212,7 @@ wl_18: LDO_REG8 { > regulator-name = "wl_18"; > }; > > - lcd_33: SWITCH_REG1 { > + lcd_33: SWITCH_REG { > regulator-name = "lcd_33"; > }; > };
diff --git a/arch/arm/boot/dts/rk3188-px3-evb.dts b/arch/arm/boot/dts/rk3188-px3-evb.dts index 39c60426c9c9..fc478ac4e781 100644 --- a/arch/arm/boot/dts/rk3188-px3-evb.dts +++ b/arch/arm/boot/dts/rk3188-px3-evb.dts @@ -212,7 +212,7 @@ wl_18: LDO_REG8 { regulator-name = "wl_18"; }; - lcd_33: SWITCH_REG1 { + lcd_33: SWITCH_REG { regulator-name = "lcd_33"; }; };