Message ID | 20230319174105.43978-1-robh@kernel.org (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | arm64/arm: dts: rockchip: Fix DSI node names | expand |
On 3/19/23 18:41, Rob Herring wrote: > DSI bus/controller nodes should be named 'dsi' rather than 'mipi'. There's already a serie that does that. Lack of communication becomes common. More thing must be fixed to comply then this patch alone. [PATCH v6 09/17] ARM: dts: rockchip: rk3288: fix dsi node https://lore.kernel.org/linux-rockchip/f3edcbff-4aef-1d24-8d65-e519c9451cda@gmail.com/ [PATCH v6 15/17] arm64: dts: rockchip: rk3399: fix dp node https://lore.kernel.org/linux-rockchip/f6008819-db9b-0944-3f5b-5522b7cd8a8d@gmail.com/ > > Signed-off-by: Rob Herring <robh@kernel.org> > --- > arch/arm/boot/dts/rk3288.dtsi | 2 +- > arch/arm64/boot/dts/rockchip/rk3399.dtsi | 4 ++-- > 2 files changed, 3 insertions(+), 3 deletions(-) > > diff --git a/arch/arm/boot/dts/rk3288.dtsi b/arch/arm/boot/dts/rk3288.dtsi > index 2ca76b69add7..d401b850583c 100644 > --- a/arch/arm/boot/dts/rk3288.dtsi > +++ b/arch/arm/boot/dts/rk3288.dtsi > @@ -1114,7 +1114,7 @@ vopl_mmu: iommu@ff940300 { > status = "disabled"; > }; > > - mipi_dsi: mipi@ff960000 { > + mipi_dsi: dsi@ff960000 { > compatible = "rockchip,rk3288-mipi-dsi", "snps,dw-mipi-dsi"; > reg = <0x0 0xff960000 0x0 0x4000>; > interrupts = <GIC_SPI 19 IRQ_TYPE_LEVEL_HIGH>; > diff --git a/arch/arm64/boot/dts/rockchip/rk3399.dtsi b/arch/arm64/boot/dts/rockchip/rk3399.dtsi > index 1881b4b71f91..e44e1c40c0ba 100644 > --- a/arch/arm64/boot/dts/rockchip/rk3399.dtsi > +++ b/arch/arm64/boot/dts/rockchip/rk3399.dtsi > @@ -1954,7 +1954,7 @@ hdmi_in_vopl: endpoint@1 { > }; > }; > > - mipi_dsi: mipi@ff960000 { > + mipi_dsi: dsi@ff960000 { > compatible = "rockchip,rk3399-mipi-dsi", "snps,dw-mipi-dsi"; > reg = <0x0 0xff960000 0x0 0x8000>; > interrupts = <GIC_SPI 45 IRQ_TYPE_LEVEL_HIGH 0>; > @@ -1990,7 +1990,7 @@ mipi_in_vopl: endpoint@1 { > }; > }; > > - mipi_dsi1: mipi@ff968000 { > + mipi_dsi1: dsi@ff968000 { > compatible = "rockchip,rk3399-mipi-dsi", "snps,dw-mipi-dsi"; > reg = <0x0 0xff968000 0x0 0x8000>; > interrupts = <GIC_SPI 46 IRQ_TYPE_LEVEL_HIGH 0>;
Am Sonntag, 19. März 2023, 20:36:20 CET schrieb Johan Jonker: > > On 3/19/23 18:41, Rob Herring wrote: > > DSI bus/controller nodes should be named 'dsi' rather than 'mipi'. > > There's already a serie that does that. I've now applied Johan's patches that fixed a lot of these naming issues and also the other things uncovered after the yaml conversion. Heiko
diff --git a/arch/arm/boot/dts/rk3288.dtsi b/arch/arm/boot/dts/rk3288.dtsi index 2ca76b69add7..d401b850583c 100644 --- a/arch/arm/boot/dts/rk3288.dtsi +++ b/arch/arm/boot/dts/rk3288.dtsi @@ -1114,7 +1114,7 @@ vopl_mmu: iommu@ff940300 { status = "disabled"; }; - mipi_dsi: mipi@ff960000 { + mipi_dsi: dsi@ff960000 { compatible = "rockchip,rk3288-mipi-dsi", "snps,dw-mipi-dsi"; reg = <0x0 0xff960000 0x0 0x4000>; interrupts = <GIC_SPI 19 IRQ_TYPE_LEVEL_HIGH>; diff --git a/arch/arm64/boot/dts/rockchip/rk3399.dtsi b/arch/arm64/boot/dts/rockchip/rk3399.dtsi index 1881b4b71f91..e44e1c40c0ba 100644 --- a/arch/arm64/boot/dts/rockchip/rk3399.dtsi +++ b/arch/arm64/boot/dts/rockchip/rk3399.dtsi @@ -1954,7 +1954,7 @@ hdmi_in_vopl: endpoint@1 { }; }; - mipi_dsi: mipi@ff960000 { + mipi_dsi: dsi@ff960000 { compatible = "rockchip,rk3399-mipi-dsi", "snps,dw-mipi-dsi"; reg = <0x0 0xff960000 0x0 0x8000>; interrupts = <GIC_SPI 45 IRQ_TYPE_LEVEL_HIGH 0>; @@ -1990,7 +1990,7 @@ mipi_in_vopl: endpoint@1 { }; }; - mipi_dsi1: mipi@ff968000 { + mipi_dsi1: dsi@ff968000 { compatible = "rockchip,rk3399-mipi-dsi", "snps,dw-mipi-dsi"; reg = <0x0 0xff968000 0x0 0x8000>; interrupts = <GIC_SPI 46 IRQ_TYPE_LEVEL_HIGH 0>;
DSI bus/controller nodes should be named 'dsi' rather than 'mipi'. Signed-off-by: Rob Herring <robh@kernel.org> --- arch/arm/boot/dts/rk3288.dtsi | 2 +- arch/arm64/boot/dts/rockchip/rk3399.dtsi | 4 ++-- 2 files changed, 3 insertions(+), 3 deletions(-)