mbox series

[PATCHv6,0/3] Deprecate DAC960 driver

Message ID 20181017152513.136526-1-hare@suse.de (mailing list archive)
Headers show
Series Deprecate DAC960 driver | expand

Message

Hannes Reinecke Oct. 17, 2018, 3:25 p.m. UTC
Hi all,

as we're trying to get rid of the remaining request_fn drivers here's
a patchset to move the DAC960 driver to the SCSI stack.
As per request from hch I've split up the driver into two new SCSI
drivers called 'myrb' and 'myrs'.

The 'myrb' driver only supports the earlier (V1) firmware interface, which
doesn't have a SCSI interface for the logical drives; for those I've added
a (pretty rudimentary, admittedly) SCSI translation for them.

The 'myrs' driver supports the newer (V2) firmware interface, which is
SCSI based and doesn't need the translation layer.

And the weird proc interface from DAC960 has been converted to sysfs attributes.

Tested with eXtremeRAID 1100 (for V1 Firmware) and Mylex AcceleRAID 170
(for V2 Firmware).

Changes to v5:
- Include review from Christoph

Changes to v4:
- checkpatch fixes
- Remove remaining camel case naming
- Include reviews from Christoph
- More codingstyle fixes

Changes to v3:
- Rename structures to match the general codingstyle
- Replace typedefs

Changes to v2:
- Move to dma_pool API
- Fixup 0-day build issues
- Add myrb_biosparam
- Dropped patch merged with upstream

Changes to v1:
- Split into two drivers
- Improve scanning for V1 firmware interface

Hannes Reinecke (3):
  myrb: Add Mylex RAID controller (block interface)
  myrs: Add Mylex RAID controller (SCSI interface)
  drivers/block: Remove DAC960 driver

 Documentation/blockdev/README.DAC960 |  756 ----
 MAINTAINERS                          |    7 +
 drivers/block/DAC960.c               | 7229 ----------------------------------
 drivers/block/DAC960.h               | 4414 ---------------------
 drivers/block/Kconfig                |   12 -
 drivers/block/Makefile               |    1 -
 drivers/scsi/Kconfig                 |   30 +
 drivers/scsi/Makefile                |    2 +
 drivers/scsi/myrb.c                  | 3656 +++++++++++++++++
 drivers/scsi/myrb.h                  |  958 +++++
 drivers/scsi/myrs.c                  | 3267 +++++++++++++++
 drivers/scsi/myrs.h                  | 1134 ++++++
 12 files changed, 9054 insertions(+), 12412 deletions(-)
 delete mode 100644 Documentation/blockdev/README.DAC960
 delete mode 100644 drivers/block/DAC960.c
 delete mode 100644 drivers/block/DAC960.h
 create mode 100644 drivers/scsi/myrb.c
 create mode 100644 drivers/scsi/myrb.h
 create mode 100644 drivers/scsi/myrs.c
 create mode 100644 drivers/scsi/myrs.h

Comments

Jens Axboe Oct. 17, 2018, 3:43 p.m. UTC | #1
On 10/17/18 9:25 AM, Hannes Reinecke wrote:
> Hi all,
> 
> as we're trying to get rid of the remaining request_fn drivers here's
> a patchset to move the DAC960 driver to the SCSI stack.
> As per request from hch I've split up the driver into two new SCSI
> drivers called 'myrb' and 'myrs'.
> 
> The 'myrb' driver only supports the earlier (V1) firmware interface, which
> doesn't have a SCSI interface for the logical drives; for those I've added
> a (pretty rudimentary, admittedly) SCSI translation for them.
> 
> The 'myrs' driver supports the newer (V2) firmware interface, which is
> SCSI based and doesn't need the translation layer.
> 
> And the weird proc interface from DAC960 has been converted to sysfs attributes.
> 
> Tested with eXtremeRAID 1100 (for V1 Firmware) and Mylex AcceleRAID 170
> (for V2 Firmware).

Applied 3/3 in for-4.20/block
Martin K. Petersen Oct. 18, 2018, 1:14 a.m. UTC | #2
Hannes,

> as we're trying to get rid of the remaining request_fn drivers here's
> a patchset to move the DAC960 driver to the SCSI stack.  As per
> request from hch I've split up the driver into two new SCSI drivers
> called 'myrb' and 'myrs'.

Applied to 4.20/scsi-queue since Jens already dropped the block driver.

Have you considered a dummy CONFIG_BLK_DEV_DAC960 config option like we
did when we merged mpt2sas and mpt3sas?

Also, does MODULE_ALIAS do the right thing when a driver is split into
two distinct modules?
Hannes Reinecke Oct. 18, 2018, 5:54 a.m. UTC | #3
On 10/18/18 3:14 AM, Martin K. Petersen wrote:
> 
> Hannes,
> 
>> as we're trying to get rid of the remaining request_fn drivers here's
>> a patchset to move the DAC960 driver to the SCSI stack.  As per
>> request from hch I've split up the driver into two new SCSI drivers
>> called 'myrb' and 'myrs'.
> 
> Applied to 4.20/scsi-queue since Jens already dropped the block driver.
> 
> Have you considered a dummy CONFIG_BLK_DEV_DAC960 config option like we
> did when we merged mpt2sas and mpt3sas?
> 
No, I haven't, but I should probably do it. Should I fix up the patch
or send an additional one?

> Also, does MODULE_ALIAS do the right thing when a driver is split into
> two distinct modules?
> 
Well, it does; half of the time :-)

Personally, I don't think there'll be many users around so I've just 
added if for completions sake.

But I can remove it if you think that'll be more suitable.

Cheers,

Hannes
Martin K. Petersen Oct. 19, 2018, 10:26 p.m. UTC | #4
Hannes,

> No, I haven't, but I should probably do it. Should I fix up the patch
> or send an additional one?

Additional, please.

>> Also, does MODULE_ALIAS do the right thing when a driver is split
>> into two distinct modules?
>>
> Well, it does; half of the time :-)

Is this a qualified guess or have you actually tried?

> Personally, I don't think there'll be many users around so I've just
> added if for completions sake.

Yeah, I agree it's less critical than mpt[23]sas. However, I'm sure
we'll break something for someone somewhere.