Message ID | 20171001193101.8898-8-jeremy.lefaure@lse.epita.fr (mailing list archive) |
---|---|
State | Deferred |
Headers | show |
diff --git a/drivers/scsi/bfa/bfa_core.c b/drivers/scsi/bfa/bfa_core.c index 3e1caec82554..4a03cd9fa63f 100644 --- a/drivers/scsi/bfa/bfa_core.c +++ b/drivers/scsi/bfa/bfa_core.c @@ -16,6 +16,7 @@ * General Public License for more details. */ +#include <linux/kernel.h> #include "bfad_drv.h" #include "bfa_modules.h" #include "bfi_reg.h" @@ -1957,7 +1958,7 @@ bfa_get_pciids(struct bfa_pciid_s **pciids, int *npciids) {BFA_PCI_VENDOR_ID_BROCADE, BFA_PCI_DEVICE_ID_CT_FC}, }; - *npciids = sizeof(__pciids) / sizeof(__pciids[0]); + *npciids = ARRAY_SIZE(__pciids); *pciids = __pciids; }
Using the ARRAY_SIZE macro improves the readability of the code. Found with Coccinelle with the following semantic patch: @r depends on (org || report)@ type T; T[] E; position p; @@ ( (sizeof(E)@p /sizeof(*E)) | (sizeof(E)@p /sizeof(E[...])) | (sizeof(E)@p /sizeof(T)) ) Signed-off-by: Jérémy Lefaure <jeremy.lefaure@lse.epita.fr> --- drivers/scsi/bfa/bfa_core.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-)