Message ID | 52e4453499a65ad276df5af9a0f057e960704f93.1595325064.git.hy50.seo@samsung.com (mailing list archive) |
---|---|
State | Superseded |
Headers | show |
Series | Support vendor specific operations for WB | expand |
This patch is not really needed - just squash it to the previous one. > > > Signed-off-by: SEO HOYOUNG <hy50.seo@samsung.com> > --- > drivers/scsi/ufs/ufshcd.c | 2 +- > drivers/scsi/ufs/ufshcd.h | 2 +- > 2 files changed, 2 insertions(+), 2 deletions(-) > > diff --git a/drivers/scsi/ufs/ufshcd.c b/drivers/scsi/ufs/ufshcd.c > index 9261519e7e9a..3eb139406a7c 100644 > --- a/drivers/scsi/ufs/ufshcd.c > +++ b/drivers/scsi/ufs/ufshcd.c > @@ -6615,7 +6615,7 @@ static int ufshcd_reset_and_restore(struct ufs_hba > *hba) > int err = 0; > int retries = MAX_HOST_RESET_RETRIES; > > - ufshcd_reset_vendor(hba); > + ufshcd_wb_reset_vendor(hba); > > do { > /* Reset the attached device */ > diff --git a/drivers/scsi/ufs/ufshcd.h b/drivers/scsi/ufs/ufshcd.h > index deb9577e0eaa..61ae5259c62a 100644 > --- a/drivers/scsi/ufs/ufshcd.h > +++ b/drivers/scsi/ufs/ufshcd.h > @@ -1217,7 +1217,7 @@ static int ufshcd_wb_ctrl_vendor(struct ufs_hba > *hba, bool enable) > return hba->wb_ops->wb_ctrl_vendor(hba, enable); > } > > -static int ufshcd_reset_vendor(struct ufs_hba *hba) > +static int ufshcd_wb_reset_vendor(struct ufs_hba *hba) > { > if (!hba->wb_ops || !hba->wb_ops->wb_reset_vendor) > return -1; > -- > 2.26.0
> This patch is not really needed - just squash it to the previous one. Why you said this patch is not really needed? I don't understand Our WB device need to disable WB when called ufshcd_reset_and_restore() func. Please explain reason. > > > > > > > Signed-off-by: SEO HOYOUNG <hy50.seo@samsung.com> > > --- > > drivers/scsi/ufs/ufshcd.c | 2 +- > > drivers/scsi/ufs/ufshcd.h | 2 +- > > 2 files changed, 2 insertions(+), 2 deletions(-) > > > > diff --git a/drivers/scsi/ufs/ufshcd.c b/drivers/scsi/ufs/ufshcd.c > > index 9261519e7e9a..3eb139406a7c 100644 > > --- a/drivers/scsi/ufs/ufshcd.c > > +++ b/drivers/scsi/ufs/ufshcd.c > > @@ -6615,7 +6615,7 @@ static int ufshcd_reset_and_restore(struct > > ufs_hba > > *hba) > > int err = 0; > > int retries = MAX_HOST_RESET_RETRIES; > > > > - ufshcd_reset_vendor(hba); > > + ufshcd_wb_reset_vendor(hba); > > > > do { > > /* Reset the attached device */ diff --git > > a/drivers/scsi/ufs/ufshcd.h b/drivers/scsi/ufs/ufshcd.h index > > deb9577e0eaa..61ae5259c62a 100644 > > --- a/drivers/scsi/ufs/ufshcd.h > > +++ b/drivers/scsi/ufs/ufshcd.h > > @@ -1217,7 +1217,7 @@ static int ufshcd_wb_ctrl_vendor(struct ufs_hba > > *hba, bool enable) > > return hba->wb_ops->wb_ctrl_vendor(hba, enable); } > > > > -static int ufshcd_reset_vendor(struct ufs_hba *hba) > > +static int ufshcd_wb_reset_vendor(struct ufs_hba *hba) > > { > > if (!hba->wb_ops || !hba->wb_ops->wb_reset_vendor) > > return -1; > > -- > > 2.26.0
> > > This patch is not really needed - just squash it to the previous one. > Why you said this patch is not really needed? > I don't understand > Our WB device need to disable WB when called ufshcd_reset_and_restore() > func. > Please explain reason. This patch only change the names of some functions defined in the first patch. Squash it to the first one.
> > > > > > This patch is not really needed - just squash it to the previous one. > > Why you said this patch is not really needed? > > I don't understand > > Our WB device need to disable WB when called > > ufshcd_reset_and_restore() func. > > Please explain reason. > This patch only change the names of some functions defined in the first > patch. > Squash it to the first one. "Asutosh Das (asd) <asutoshd@codeaurora.org>" said this function not clearly. So I modify this function name. I think this name is clear than the previous name.
> > > > This patch is not really needed - just squash it to the previous one. > > > Why you said this patch is not really needed? > > > I don't understand > > > Our WB device need to disable WB when called > > > ufshcd_reset_and_restore() func. > > > Please explain reason. > > This patch only change the names of some functions defined in the first > > patch. > > Squash it to the first one. > > "Asutosh Das (asd) <asutoshd@codeaurora.org>" said this function not > clearly. > So I modify this function name. > I think this name is clear than the previous name. I am not arguing about that. Are you familiar with the concept of squash?
> > > > > This patch is not really needed - just squash it to the previous > one. > > > > Why you said this patch is not really needed? > > > > I don't understand > > > > Our WB device need to disable WB when called > > > > ufshcd_reset_and_restore() func. > > > > Please explain reason. > > > This patch only change the names of some functions defined in the > > > first patch. > > > Squash it to the first one. > > > > "Asutosh Das (asd) <asutoshd@codeaurora.org>" said this function not > > clearly. > > So I modify this function name. > > I think this name is clear than the previous name. > I am not arguing about that. > Are you familiar with the concept of squash? Sorry, I misunderstand. I do not know very well. Please can you explain concept of squash to me?
diff --git a/drivers/scsi/ufs/ufshcd.c b/drivers/scsi/ufs/ufshcd.c index 9261519e7e9a..3eb139406a7c 100644 --- a/drivers/scsi/ufs/ufshcd.c +++ b/drivers/scsi/ufs/ufshcd.c @@ -6615,7 +6615,7 @@ static int ufshcd_reset_and_restore(struct ufs_hba *hba) int err = 0; int retries = MAX_HOST_RESET_RETRIES; - ufshcd_reset_vendor(hba); + ufshcd_wb_reset_vendor(hba); do { /* Reset the attached device */ diff --git a/drivers/scsi/ufs/ufshcd.h b/drivers/scsi/ufs/ufshcd.h index deb9577e0eaa..61ae5259c62a 100644 --- a/drivers/scsi/ufs/ufshcd.h +++ b/drivers/scsi/ufs/ufshcd.h @@ -1217,7 +1217,7 @@ static int ufshcd_wb_ctrl_vendor(struct ufs_hba *hba, bool enable) return hba->wb_ops->wb_ctrl_vendor(hba, enable); } -static int ufshcd_reset_vendor(struct ufs_hba *hba) +static int ufshcd_wb_reset_vendor(struct ufs_hba *hba) { if (!hba->wb_ops || !hba->wb_ops->wb_reset_vendor) return -1;
Signed-off-by: SEO HOYOUNG <hy50.seo@samsung.com> --- drivers/scsi/ufs/ufshcd.c | 2 +- drivers/scsi/ufs/ufshcd.h | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-)