Message ID | 20210323091905.317885-1-unclexiaole@gmail.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | ima: Fix function name error in comment. | expand |
Hi Jiele, On Tue, 2021-03-23 at 09:19 +0000, Jiele Zhao wrote: > Function "ima_file_check" is written as "ima_path_check" in > the comment. Fix this error to prevent misunderstanding. > > Signed-off-by: Jiele Zhao <unclexiaole@gmail.com> The original function name was ima_path_check(). The policy parsing still supports PATH_CHECK. Commit 9bbb6cad0173 ("ima: rename ima_path_check to ima_file_check") renamed the function to ima_file_check(), but missed modifying the function name in the comment. Please update this patch description accordingly and add the "Fixes" tag. thanks, Mimi
Ping. On 2021/3/23 17:19, Jiele Zhao wrote: > Function "ima_file_check" is written as "ima_path_check" in > the comment. Fix this error to prevent misunderstanding. > > Signed-off-by: Jiele Zhao <unclexiaole@gmail.com> > --- > security/integrity/ima/ima_main.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/security/integrity/ima/ima_main.c b/security/integrity/ima/ima_main.c > index 9ef748ea829f..03bef720ab44 100644 > --- a/security/integrity/ima/ima_main.c > +++ b/security/integrity/ima/ima_main.c > @@ -482,7 +482,7 @@ int ima_bprm_check(struct linux_binprm *bprm) > } > > /** > - * ima_path_check - based on policy, collect/store measurement. > + * ima_file_check - based on policy, collect/store measurement. > * @file: pointer to the file to be measured > * @mask: contains MAY_READ, MAY_WRITE, MAY_EXEC or MAY_APPEND > *
diff --git a/security/integrity/ima/ima_main.c b/security/integrity/ima/ima_main.c index 9ef748ea829f..03bef720ab44 100644 --- a/security/integrity/ima/ima_main.c +++ b/security/integrity/ima/ima_main.c @@ -482,7 +482,7 @@ int ima_bprm_check(struct linux_binprm *bprm) } /** - * ima_path_check - based on policy, collect/store measurement. + * ima_file_check - based on policy, collect/store measurement. * @file: pointer to the file to be measured * @mask: contains MAY_READ, MAY_WRITE, MAY_EXEC or MAY_APPEND *
Function "ima_file_check" is written as "ima_path_check" in the comment. Fix this error to prevent misunderstanding. Signed-off-by: Jiele Zhao <unclexiaole@gmail.com> --- security/integrity/ima/ima_main.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)