mbox series

[GIT,PULL] RISC-V SpacemiT Devicetrees for v6.14

Message ID 20250108142122-GYA3300457@gentoo (mailing list archive)
State Superseded
Headers show
Series [GIT,PULL] RISC-V SpacemiT Devicetrees for v6.14 | expand

Pull-request

https://github.com/spacemit-com/linux/ tags/spacemit-dt-for-6.14

Message

Yixun Lan Jan. 8, 2025, 2:21 p.m. UTC
Hi Arnd,

Here is SpacemiT's device tree changes for 6.14 cycle.
All patches have been merged in linux-next tree for testing.

Please pull, thanks

Yixun Lan (dlan)

The following changes since commit 78d4f34e2115b517bcbfe7ec0d018bbbb6f9b0b8:

  Linux 6.13-rc3 (2024-12-15 15:58:23 -0800)

are available in the Git repository at:

  https://github.com/spacemit-com/linux/ tags/spacemit-dt-for-6.14

for you to fetch changes up to e7cd95ad8013bc232316bba0a52ea11ecd5c81bd:

  riscv: dts: spacemit: add pinctrl property to uart0 in BPI-F3 (2025-01-04 10:28:18 +0800)

----------------------------------------------------------------
RISC-V SpacemiT DT changes for 6.14
- basic device tree support
- pinctrl dt node info
- update MAINTAINERS info

----------------------------------------------------------------
Yangyu Chen (8):
      dt-bindings: riscv: Add SpacemiT X60 compatibles
      dt-bindings: riscv: add SpacemiT K1 bindings
      dt-bindings: timer: Add SpacemiT K1 CLINT
      dt-bindings: interrupt-controller: Add SpacemiT K1 PLIC
      riscv: add SpacemiT SoC family Kconfig support
      riscv: dts: add initial SpacemiT K1 SoC device tree
      riscv: dts: spacemit: add Banana Pi BPI-F3 board device tree
      riscv: defconfig: enable SpacemiT SoC

Yixun Lan (3):
      MAINTAINERS: setup support for SpacemiT SoC tree
      dt-bindings: serial: 8250: Add SpacemiT K1 uart compatible
      riscv: dts: spacemit: add pinctrl property to uart0 in BPI-F3

 .../interrupt-controller/sifive,plic-1.0.0.yaml    |   1 +
 Documentation/devicetree/bindings/riscv/cpus.yaml  |   1 +
 .../devicetree/bindings/riscv/spacemit.yaml        |  28 ++
 Documentation/devicetree/bindings/serial/8250.yaml |   4 +-
 .../devicetree/bindings/timer/sifive,clint.yaml    |   1 +
 MAINTAINERS                                        |   9 +
 arch/riscv/Kconfig.socs                            |   5 +
 arch/riscv/boot/dts/Makefile                       |   1 +
 arch/riscv/boot/dts/spacemit/Makefile              |   2 +
 arch/riscv/boot/dts/spacemit/k1-bananapi-f3.dts    |  22 +
 arch/riscv/boot/dts/spacemit/k1-pinctrl.dtsi       |  20 +
 arch/riscv/boot/dts/spacemit/k1.dtsi               | 464 +++++++++++++++++++++
 arch/riscv/configs/defconfig                       |   1 +
 13 files changed, 558 insertions(+), 1 deletion(-)
 create mode 100644 Documentation/devicetree/bindings/riscv/spacemit.yaml
 create mode 100644 arch/riscv/boot/dts/spacemit/Makefile
 create mode 100644 arch/riscv/boot/dts/spacemit/k1-bananapi-f3.dts
 create mode 100644 arch/riscv/boot/dts/spacemit/k1-pinctrl.dtsi
 create mode 100644 arch/riscv/boot/dts/spacemit/k1.dtsi

Comments

Arnd Bergmann Jan. 16, 2025, 4:49 p.m. UTC | #1
On Wed, Jan 8, 2025, at 15:21, Yixun Lan wrote:
> Hi Arnd,
>
> Here is SpacemiT's device tree changes for 6.14 cycle.
> All patches have been merged in linux-next tree for testing.
>
>
> ----------------------------------------------------------------
> RISC-V SpacemiT DT changes for 6.14
> - basic device tree support
> - pinctrl dt node info
> - update MAINTAINERS info
>

Sorry for the delay in pulling this. I just had a look and found
that your branch is based on -rc3 while the soc tree is currently
using 6.13-rc2. I try hard to avoid unnecessary backmerges of
upstream contents into my tree, so it would be nice if you could
rebase it onto 6.13-rc1 or 6.13-rc2 and resend.

While looking through the contents, I also found a mistake
in the contents:

+++ b/arch/riscv/boot/dts/spacemit/k1.dtsi
@@ -0,0 +1,459 @@
...
+       aliases {
+               serial0 = &uart0;
+               serial1 = &uart2;
+               serial2 = &uart3;
+               serial3 = &uart4;
+               serial4 = &uart5;
+               serial5 = &uart6;
+               serial6 = &uart7;
+               serial7 = &uart8;
+               serial8 = &uart9;
+       };

The aliases here should be in the k1-bananapi-f3.dts file,
not in the k1.dtsi file, since the mapping between exposed
UART devices and those available in the chip is board
specific. You normally want to list only those devices
that are marked status="okay" on that board.

I would suggest you fix this in a patch on top of your
existing commits, but make it part of the pull request.

      Arnd
Yixun Lan Jan. 16, 2025, 11:47 p.m. UTC | #2
Hi Arnd:

> On Wed, Jan 8, 2025, at 15:21, Yixun Lan wrote:
> > Hi Arnd,
> >
> > Here is SpacemiT's device tree changes for 6.14 cycle.
> > All patches have been merged in linux-next tree for testing.
> >
> >
> > ----------------------------------------------------------------
> > RISC-V SpacemiT DT changes for 6.14
> > - basic device tree support
> > - pinctrl dt node info
> > - update MAINTAINERS info
> >
> 
> Sorry for the delay in pulling this. I just had a look and found
> that your branch is based on -rc3 while the soc tree is currently
> using 6.13-rc2. I try hard to avoid unnecessary backmerges of
> upstream contents into my tree, so it would be nice if you could
> rebase it onto 6.13-rc1 or 6.13-rc2 and resend.
> 
sorry, I will keep this in mind, and will rebase to 6.13-rc2

> While looking through the contents, I also found a mistake
> in the contents:
> 
> +++ b/arch/riscv/boot/dts/spacemit/k1.dtsi
> @@ -0,0 +1,459 @@
> ...
> +       aliases {
> +               serial0 = &uart0;
> +               serial1 = &uart2;
> +               serial2 = &uart3;
> +               serial3 = &uart4;
> +               serial4 = &uart5;
> +               serial5 = &uart6;
> +               serial6 = &uart7;
> +               serial7 = &uart8;
> +               serial8 = &uart9;
> +       };
> 
> The aliases here should be in the k1-bananapi-f3.dts file,
> not in the k1.dtsi file, since the mapping between exposed
> UART devices and those available in the chip is board
> specific. You normally want to list only those devices
> that are marked status="okay" on that board.
> 
> I would suggest you fix this in a patch on top of your
> existing commits, but make it part of the pull request.
> 
Ok

>       Arnd