mbox series

[0/6] small changes to ptrlist API

Message ID 20210306100552.33784-1-luc.vanoostenryck@gmail.com (mailing list archive)
Headers show
Series small changes to ptrlist API | expand

Message

Luc Van Oostenryck March 6, 2021, 10:05 a.m. UTC
This series contains a few changes to the ptrlst API:
* let TYPEOF() return the entry's type instead of the type of its address
* rename TYPEOF() to PTRLIST_TYPE()
* add pop_ptr_list(), a generic macro
* make linearize_ptr_list() generic and rename it to ptr_list_to_array() 
* change the return value of linearize_ptr_list()/ptr_list_to_array() to
  simplify its use.

Luc Van Oostenryck (6):
  ptrlist: ~fix TYPEOF()
  ptrlist: change TYPEOF() into PTRLIST_TYPE()
  ptrlist: add pop_ptr_list()
  ptrlist: use ptr_list_nth() instead of linearize_ptr_list()
  ptrlist: make linearize_ptr_list() generic
  ptrlist: change return value of linearize_ptr_list()/ptr_list_to_array()

 ptrlist.c  | 10 +++++-----
 ptrlist.h  | 22 +++++++++++++++++-----
 simplify.c |  6 +++---
 sparse.c   | 13 +------------
 4 files changed, 26 insertions(+), 25 deletions(-)