diff mbox series

[1/4] trace-cmd: Allow overriding of python installation directory

Message ID 20190720030344.1991393-2-chutzpah@gentoo.org (mailing list archive)
State Accepted
Headers show
Series trace-cmd: Fixes for packaging | expand

Commit Message

Patrick McLean July 20, 2019, 3:03 a.m. UTC
From: Patrick McLean <patrick.mclean@sony.com>

The current Makefile hardcodes the python module install directory, so
packages can't put them in their distro's perferred location. This
allows the directory to be overriden on the command line.

Signed-off-by: Patrick McLean <patrick.mclean@sony.com>
---
 Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/Makefile b/Makefile
index ad74a96..3579f27 100644
--- a/Makefile
+++ b/Makefile
@@ -64,7 +64,7 @@  python_dir = $(HOME)/.trace-cmd/python
 var_dir = $(HOME)/.trace-cmd/
 else
 plugin_dir = $(libdir)/trace-cmd/plugins
-python_dir = $(libdir)/trace-cmd/python
+python_dir ?= $(libdir)/trace-cmd/python
 PLUGIN_DIR = -DPLUGIN_DIR="$(plugin_dir)"
 PYTHON_DIR = -DPYTHON_DIR="$(python_dir)"
 PLUGIN_DIR_SQ = '$(subst ','\'',$(PLUGIN_DIR))'