From patchwork Tue Aug 13 11:27:03 2019 Content-Type: text/plain; charset="utf-8" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit X-Patchwork-Submitter: =?utf-8?b?Q2h1bmZlbmcgWXVuICjkupHmmKXls7Ap?= X-Patchwork-Id: 11091795 Return-Path: Received: from mail.wl.linuxfoundation.org (pdx-wl-mail.web.codeaurora.org [172.30.200.125]) by pdx-korg-patchwork-2.web.codeaurora.org (Postfix) with ESMTP id 57F5D14DB for ; Tue, 13 Aug 2019 11:27:34 +0000 (UTC) Received: from mail.wl.linuxfoundation.org (localhost [127.0.0.1]) by mail.wl.linuxfoundation.org (Postfix) with ESMTP id 46E68285E5 for ; Tue, 13 Aug 2019 11:27:34 +0000 (UTC) Received: by mail.wl.linuxfoundation.org (Postfix, from userid 486) id 39F44285F0; Tue, 13 Aug 2019 11:27:34 +0000 (UTC) X-Spam-Checker-Version: SpamAssassin 3.3.1 (2010-03-16) on pdx-wl-mail.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-7.9 required=2.0 tests=BAYES_00,MAILING_LIST_MULTI, RCVD_IN_DNSWL_HI,UNPARSEABLE_RELAY autolearn=ham version=3.3.1 Received: from vger.kernel.org (vger.kernel.org [209.132.180.67]) by mail.wl.linuxfoundation.org (Postfix) with ESMTP id 51AEF285E5 for ; Tue, 13 Aug 2019 11:27:33 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1726974AbfHML12 (ORCPT ); Tue, 13 Aug 2019 07:27:28 -0400 Received: from mailgw02.mediatek.com ([1.203.163.81]:59572 "EHLO mailgw02.mediatek.com" rhost-flags-OK-FAIL-OK-FAIL) by vger.kernel.org with ESMTP id S1726086AbfHML12 (ORCPT ); Tue, 13 Aug 2019 07:27:28 -0400 X-UUID: d5466bd576b049c9a1375d6769e8e4b9-20190813 X-UUID: d5466bd576b049c9a1375d6769e8e4b9-20190813 Received: from mtkcas34.mediatek.inc [(172.27.4.253)] by mailgw02.mediatek.com (envelope-from ) (mailgw01.mediatek.com ESMTP with TLS) with ESMTP id 1944081045; Tue, 13 Aug 2019 19:27:20 +0800 Received: from MTKCAS06.mediatek.inc (172.21.101.30) by MTKMBS31N1.mediatek.inc (172.27.4.69) with Microsoft SMTP Server (TLS) id 15.0.1395.4; Tue, 13 Aug 2019 19:27:14 +0800 Received: from localhost.localdomain (10.17.3.153) by MTKCAS06.mediatek.inc (172.21.101.73) with Microsoft SMTP Server id 15.0.1395.4 via Frontend Transport; Tue, 13 Aug 2019 19:27:17 +0800 From: Chunfeng Yun To: Rob Herring , Greg Kroah-Hartman , Biju Das CC: Mark Rutland , Chunfeng Yun , Matthias Brugger , Adam Thomson , Li Jun , Badhri Jagan Sridharan , Heikki Krogerus , Hans de Goede , Andy Shevchenko , Min Guo , , , , , , Linus Walleij , Nagarjuna Kristam Subject: [PATCH next v9 00/11] add USB GPIO based connection detection driver Date: Tue, 13 Aug 2019 19:27:03 +0800 Message-ID: <1565695634-9711-1-git-send-email-chunfeng.yun@mediatek.com> X-Mailer: git-send-email 1.8.1.1.dirty MIME-Version: 1.0 X-TM-SNTS-SMTP: 60EE3475727C8F8EA180652F2BC9E94AE75F43462F5133011D73E92E678602342000:8 X-MTK: N Sender: linux-usb-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: linux-usb@vger.kernel.org X-Virus-Scanned: ClamAV using ClamSMTP Because the USB Connector is introduced and the requirement of usb-connector.txt binding, the old way using extcon to support USB Dual-Role switch is now deprecated, meanwhile there is no available common driver when use Type-B connector, typically using an input GPIO to detect USB ID pin. This patch series introduce a USB GPIO based connection detection driver and try to replace the function provided by extcon-usb-gpio driver. v9 changes: 1. replace signed-off-by by suggested-by Heikki 2. add reviewed-by Linus 3. use class_find_device_by_fwnode() introduced by series [1] [1]: https://lore.kernel.org/patchwork/patch/1103630/ [v3,1/7] drivers: Introduce device lookup variants by name they are already in: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/driver-core.git/log/drivers/base/core.c?h=driver-core-next v8 changes: 1. rename the driver's name suggested by Heikki 2. move the driver from usb/roles/ into usb/common/ suggested by Heikki 3. introduce Kconfig for usb common core to add the new driver 4. modify binding of the driver 5. rename the subject title v7 changes: 1. [5/10]: add signed-off-by Chunfeng 2. [6/10]: add signed-off-by Chunfeng 3. [6/10]: depends on linux-next of Rafael's tree [1] 4. [7/10]: add signed-off-by Chunfeng and tested-by Biju 5. [9/10]: add tested-by Nagarjuna, and remove DEV_PMS_OPS suggested by Andy [1] https://git.kernel.org/pub/scm/linux/kernel/git/rafael/linux-pm.git/log/?h=linux-next v6 changes: 1. merge [1] and [2] into this series 2. don't use graph anymore to find usb-role-switch 3. abandon [3] and introduce three patches (6, 7, 8 in this series) to rebuild APIs getting usb-role-switch [1]: [v3] dt-binding: usb: add usb-role-switch property https://patchwork.kernel.org/patch/10934835/ [2]: [v6,08/13] usb: roles: Introduce stubs for the exiting functions in role.h https://patchwork.kernel.org/patch/10909971/ [3]: [PATCH v5 4/6] usb: roles: add API to get usb_role_switch by node v5 changes: 1. remove linux/of.h and put usb_role_switch when error happens, suggested by Biju 2. treat Type-B connector as USB controller's child, but not as a virtual device, suggested by Rob 3. provide and use generic property "usb-role-switch", see [1], suggested by Rob Note: this series still depends on [2] [1]: [v3] dt-binding: usb: add usb-role-switch property https://patchwork.kernel.org/patch/10934835/ [2]: [v6,08/13] usb: roles: Introduce stubs for the exiting functions in role.h https://patchwork.kernel.org/patch/10909971/ v4 changes: 1. use switch_fwnode_match() to find fwnode suggested by Heikki 2. assign fwnode member of usb_role_switch struct suggested by Heikki 3. make [4/6] depend on [2] 3. remove linux/gpio.h suggested by Linus 4. put node when error happens [4/6] usb: roles: add API to get usb_role_switch by node [2] [v6,08/13] usb: roles: Introduce stubs for the exiting functions in role.h https://patchwork.kernel.org/patch/10909971/ v3 changes: 1. add GPIO direction, and use fixed-regulator for GPIO controlled VBUS regulator suggested by Rob; 2. rebuild fwnode_usb_role_switch_get() suggested by Andy and Heikki 3. treat the type-B connector as a virtual device; 4. change file name of driver again 5. select USB_ROLE_SWITCH in mtu3/Kconfig suggested by Heikki 6. rename ssusb_mode_manual_switch() to ssusb_mode_switch() v2 changes: 1. make binding clear, and add a extra compatible suggested by Hans Chunfeng Yun (8): dt-binding: usb: add usb-role-switch property dt-bindings: connector: add optional properties for Type-B dt-bindings: usb: add binding for USB GPIO based connection detection driver dt-bindings: usb: mtu3: add properties about USB Role Switch usb: roles: get usb-role-switch from parent usb: common: create Kconfig file usb: common: add USB GPIO based connection detection driver usb: mtu3: register a USB Role Switch for dual role mode Heikki Krogerus (2): device connection: Add fwnode_connection_find_match() usb: roles: Add fwnode_usb_role_switch_get() function Yu Chen (1): usb: roles: Introduce stubs for the exiting functions in role.h .../bindings/connector/usb-connector.txt | 14 + .../devicetree/bindings/usb/generic.txt | 4 + .../devicetree/bindings/usb/mediatek,mtu3.txt | 10 + .../devicetree/bindings/usb/usb-conn-gpio.txt | 31 ++ drivers/base/devcon.c | 43 ++- drivers/usb/Kconfig | 35 +-- drivers/usb/common/Kconfig | 51 ++++ drivers/usb/common/Makefile | 1 + drivers/usb/common/usb-conn-gpio.c | 284 ++++++++++++++++++ drivers/usb/mtu3/Kconfig | 1 + drivers/usb/mtu3/mtu3.h | 5 + drivers/usb/mtu3/mtu3_debugfs.c | 4 +- drivers/usb/mtu3/mtu3_dr.c | 48 ++- drivers/usb/mtu3/mtu3_dr.h | 6 +- drivers/usb/mtu3/mtu3_plat.c | 3 +- drivers/usb/roles/class.c | 41 ++- include/linux/device.h | 10 +- include/linux/usb/role.h | 37 +++ 18 files changed, 570 insertions(+), 58 deletions(-) create mode 100644 Documentation/devicetree/bindings/usb/usb-conn-gpio.txt create mode 100644 drivers/usb/common/Kconfig create mode 100644 drivers/usb/common/usb-conn-gpio.c