Message ID | 20210503154647.142551-4-hdegoede@redhat.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | drm + usb-type-c: Add support for out-of-band hotplug notification (v2) | expand |
Hi, On 5/4/21 10:00 AM, Andy Shevchenko wrote: > > > On Monday, May 3, 2021, Hans de Goede <hdegoede@redhat.com <mailto:hdegoede@redhat.com>> wrote: > > Add a function to find a connector based on a fwnode. > > This will be used by the new drm_connector_oob_hotplug_event() > function which is added by the next patch in this patch-set. > > Changes in v2: > - Complete rewrite to use a global connector list in drm_connector.c > rather then using a class-dev-iter in drm_sysfs.c > > Signed-off-by: Hans de Goede <hdegoede@redhat.com <mailto:hdegoede@redhat.com>> > --- > drivers/gpu/drm/drm_connector.c | 50 +++++++++++++++++++++++++++++ > drivers/gpu/drm/drm_crtc_internal.h | 1 + > include/drm/drm_connector.h | 8 +++++ > 3 files changed, 59 insertions(+) > > diff --git a/drivers/gpu/drm/drm_connector.c b/drivers/gpu/drm/drm_connector.c > index 87c68563e6c3..ef759d6add81 100644 > --- a/drivers/gpu/drm/drm_connector.c > +++ b/drivers/gpu/drm/drm_connector.c > @@ -66,6 +66,14 @@ > * support can instead use e.g. drm_helper_hpd_irq_event(). > */ > > +/* > + * Global connector list for drm_connector_find_by_fwnode(). > + * Note drm_connector_[un]register() first take connector->lock and then > + * take the connector_list_lock. > + */ > +static DEFINE_MUTEX(connector_list_lock); > +static LIST_HEAD(connector_list); > + > struct drm_conn_prop_enum_list { > int type; > const char *name; > @@ -267,6 +275,7 @@ int drm_connector_init(struct drm_device *dev, > goto out_put_type_id; > } > > + INIT_LIST_HEAD(&connector->global_connector_list_entry); > INIT_LIST_HEAD(&connector->probed_modes); > INIT_LIST_HEAD(&connector->modes); > mutex_init(&connector->mutex); > @@ -540,6 +549,9 @@ int drm_connector_register(struct drm_connector *connector) > drm_privacy_screen_register_notifier(connector->privacy_screen, > &connector->privacy_screen_notifier); > > + mutex_lock(&connector_list_lock); > + list_add_tail(&connector->global_connector_list_entry, &connector_list); > + mutex_unlock(&connector_list_lock); > goto unlock; > > err_debugfs: > @@ -568,6 +580,10 @@ void drm_connector_unregister(struct drm_connector *connector) > return; > } > > + mutex_lock(&connector_list_lock); > + list_del_init(&connector->global_connector_list_entry); > + mutex_unlock(&connector_list_lock); > + > if (connector->privacy_screen) > drm_privacy_screen_unregister_notifier( > connector->privacy_screen, > @@ -2676,6 +2692,40 @@ int drm_mode_getconnector(struct drm_device *dev, void *data, > return ret; > } > > +/** > + * drm_connector_find_by_fwnode - Find a connector based on the associated fwnode > + * @fwnode: fwnode for which to find the matching drm_connector > + * > + * This functions looks up a drm_connector based on its associated fwnode. When > + * a connector is found a reference to the connector is returned. The caller must > + * call drm_connector_put() to release this reference when it is done with the > + * connector. > + * > + * Returns: A reference to the found connector or an ERR_PTR(). > + */ > +struct drm_connector *drm_connector_find_by_fwnode(struct fwnode_handle *fwnode) > +{ > + struct drm_connector *connector, *found = ERR_PTR(-ENODEV); > + > + if (!fwnode) > + return ERR_PTR(-ENODEV); > + > + mutex_lock(&connector_list_lock); > + > + list_for_each_entry(connector, &connector_list, global_connector_list_entry) { > + if (connector->fwnode == fwnode || > + (connector->fwnode && connector->fwnode->secondary == fwnode)) { > + drm_connector_get(connector); > + found = connector; > + break; > + } > + } > + > + mutex_unlock(&connector_list_lock); > + > + return found; > > > > If I am not mistaken you can replace this with > > return list_entry_is_head(); > > call and remove additional Boolean variable. Found is not a boolean, it is a pointer to the found connector (or ERR_PTR(-ENODEV)). Regards, Hans > > > +} > + > > /** > * DOC: Tile group > diff --git a/drivers/gpu/drm/drm_crtc_internal.h b/drivers/gpu/drm/drm_crtc_internal.h > index 54d4cf1233e9..6e28fc00a740 100644 > --- a/drivers/gpu/drm/drm_crtc_internal.h > +++ b/drivers/gpu/drm/drm_crtc_internal.h > @@ -185,6 +185,7 @@ int drm_connector_set_obj_prop(struct drm_mode_object *obj, > int drm_connector_create_standard_properties(struct drm_device *dev); > const char *drm_get_connector_force_name(enum drm_connector_force force); > void drm_connector_free_work_fn(struct work_struct *work); > +struct drm_connector *drm_connector_find_by_fwnode(struct fwnode_handle *fwnode); > > /* IOCTL */ > int drm_connector_property_set_ioctl(struct drm_device *dev, > diff --git a/include/drm/drm_connector.h b/include/drm/drm_connector.h > index d20bfd7576ed..ae377354e48e 100644 > --- a/include/drm/drm_connector.h > +++ b/include/drm/drm_connector.h > @@ -1267,6 +1267,14 @@ struct drm_connector { > */ > struct list_head head; > > + /** > + * @global_connector_list_entry: > + * > + * Connector entry in the global connector-list, used by > + * drm_connector_find_by_fwnode(). > + */ > + struct list_head global_connector_list_entry; > + > /** @base: base KMS object */ > struct drm_mode_object base; > > -- > 2.31.1 > > > > -- > With Best Regards, > Andy Shevchenko > >
On Tue, May 4, 2021 at 2:53 PM Hans de Goede <hdegoede@redhat.com> wrote: > On 5/4/21 10:00 AM, Andy Shevchenko wrote: > > On Monday, May 3, 2021, Hans de Goede <hdegoede@redhat.com <mailto:hdegoede@redhat.com>> wrote: ... > > +struct drm_connector *drm_connector_find_by_fwnode(struct fwnode_handle *fwnode) > > +{ > > + struct drm_connector *connector, *found = ERR_PTR(-ENODEV); > > + > > + if (!fwnode) > > + return ERR_PTR(-ENODEV); > > + > > + mutex_lock(&connector_list_lock); > > + > > + list_for_each_entry(connector, &connector_list, global_connector_list_entry) { > > + if (connector->fwnode == fwnode || > > + (connector->fwnode && connector->fwnode->secondary == fwnode)) { > > + drm_connector_get(connector); > > + found = connector; > > + break; > > + } > > + } > > + > > + mutex_unlock(&connector_list_lock); > > + > > + return found; > > > > If I am not mistaken you can replace this with > > > > return list_entry_is_head(); > > > > call and remove additional Boolean variable. > > Found is not a boolean, it is a pointer to the found connector (or ERR_PTR(-ENODEV)). Ah, perhaps giving a better name? `match` ? And to the initial topic, it's either an additional variable or additional branch in this case. I think additional branch (taking into account the length of the line or amount of lines) doesn't buy us anything. > > +}
diff --git a/drivers/gpu/drm/drm_connector.c b/drivers/gpu/drm/drm_connector.c index 87c68563e6c3..ef759d6add81 100644 --- a/drivers/gpu/drm/drm_connector.c +++ b/drivers/gpu/drm/drm_connector.c @@ -66,6 +66,14 @@ * support can instead use e.g. drm_helper_hpd_irq_event(). */ +/* + * Global connector list for drm_connector_find_by_fwnode(). + * Note drm_connector_[un]register() first take connector->lock and then + * take the connector_list_lock. + */ +static DEFINE_MUTEX(connector_list_lock); +static LIST_HEAD(connector_list); + struct drm_conn_prop_enum_list { int type; const char *name; @@ -267,6 +275,7 @@ int drm_connector_init(struct drm_device *dev, goto out_put_type_id; } + INIT_LIST_HEAD(&connector->global_connector_list_entry); INIT_LIST_HEAD(&connector->probed_modes); INIT_LIST_HEAD(&connector->modes); mutex_init(&connector->mutex); @@ -540,6 +549,9 @@ int drm_connector_register(struct drm_connector *connector) drm_privacy_screen_register_notifier(connector->privacy_screen, &connector->privacy_screen_notifier); + mutex_lock(&connector_list_lock); + list_add_tail(&connector->global_connector_list_entry, &connector_list); + mutex_unlock(&connector_list_lock); goto unlock; err_debugfs: @@ -568,6 +580,10 @@ void drm_connector_unregister(struct drm_connector *connector) return; } + mutex_lock(&connector_list_lock); + list_del_init(&connector->global_connector_list_entry); + mutex_unlock(&connector_list_lock); + if (connector->privacy_screen) drm_privacy_screen_unregister_notifier( connector->privacy_screen, @@ -2676,6 +2692,40 @@ int drm_mode_getconnector(struct drm_device *dev, void *data, return ret; } +/** + * drm_connector_find_by_fwnode - Find a connector based on the associated fwnode + * @fwnode: fwnode for which to find the matching drm_connector + * + * This functions looks up a drm_connector based on its associated fwnode. When + * a connector is found a reference to the connector is returned. The caller must + * call drm_connector_put() to release this reference when it is done with the + * connector. + * + * Returns: A reference to the found connector or an ERR_PTR(). + */ +struct drm_connector *drm_connector_find_by_fwnode(struct fwnode_handle *fwnode) +{ + struct drm_connector *connector, *found = ERR_PTR(-ENODEV); + + if (!fwnode) + return ERR_PTR(-ENODEV); + + mutex_lock(&connector_list_lock); + + list_for_each_entry(connector, &connector_list, global_connector_list_entry) { + if (connector->fwnode == fwnode || + (connector->fwnode && connector->fwnode->secondary == fwnode)) { + drm_connector_get(connector); + found = connector; + break; + } + } + + mutex_unlock(&connector_list_lock); + + return found; +} + /** * DOC: Tile group diff --git a/drivers/gpu/drm/drm_crtc_internal.h b/drivers/gpu/drm/drm_crtc_internal.h index 54d4cf1233e9..6e28fc00a740 100644 --- a/drivers/gpu/drm/drm_crtc_internal.h +++ b/drivers/gpu/drm/drm_crtc_internal.h @@ -185,6 +185,7 @@ int drm_connector_set_obj_prop(struct drm_mode_object *obj, int drm_connector_create_standard_properties(struct drm_device *dev); const char *drm_get_connector_force_name(enum drm_connector_force force); void drm_connector_free_work_fn(struct work_struct *work); +struct drm_connector *drm_connector_find_by_fwnode(struct fwnode_handle *fwnode); /* IOCTL */ int drm_connector_property_set_ioctl(struct drm_device *dev, diff --git a/include/drm/drm_connector.h b/include/drm/drm_connector.h index d20bfd7576ed..ae377354e48e 100644 --- a/include/drm/drm_connector.h +++ b/include/drm/drm_connector.h @@ -1267,6 +1267,14 @@ struct drm_connector { */ struct list_head head; + /** + * @global_connector_list_entry: + * + * Connector entry in the global connector-list, used by + * drm_connector_find_by_fwnode(). + */ + struct list_head global_connector_list_entry; + /** @base: base KMS object */ struct drm_mode_object base;
Add a function to find a connector based on a fwnode. This will be used by the new drm_connector_oob_hotplug_event() function which is added by the next patch in this patch-set. Changes in v2: - Complete rewrite to use a global connector list in drm_connector.c rather then using a class-dev-iter in drm_sysfs.c Signed-off-by: Hans de Goede <hdegoede@redhat.com> --- drivers/gpu/drm/drm_connector.c | 50 +++++++++++++++++++++++++++++ drivers/gpu/drm/drm_crtc_internal.h | 1 + include/drm/drm_connector.h | 8 +++++ 3 files changed, 59 insertions(+)