Message ID | 20200306132823.D5C5B803087C@mail.baikalelectronics.ru (mailing list archive) |
---|---|
State | Rejected |
Headers | show |
Series | watchdog: dw_wdt: Take Baikal-T1 DW WDT peculiarities into account | expand |
On 3/6/20 5:27 AM, Sergey.Semin@baikalelectronics.ru wrote: > From: Serge Semin <Sergey.Semin@baikalelectronics.ru> > > For better readability replace the numeric literals with globally > available xSEC_PER_SEC macro. > This is really completely unrelated to the rest of the series, and I don't really see the point. I am fine with such changes if there are some context changes around it, but otherwise they add no value other than being a potential source of backport conflicts. Guenter > Signed-off-by: Serge Semin <Sergey.Semin@baikalelectronics.ru> > Signed-off-by: Alexey Malahov <Alexey.Malahov@baikalelectronics.ru> > Cc: Thomas Bogendoerfer <tsbogend@alpha.franken.de> > Cc: Paul Burton <paulburton@kernel.org> > Cc: Ralf Baechle <ralf@linux-mips.org> > --- > drivers/watchdog/watchdog_dev.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git a/drivers/watchdog/watchdog_dev.c b/drivers/watchdog/watchdog_dev.c > index 8b5c742f24e8..a1a3bbe21653 100644 > --- a/drivers/watchdog/watchdog_dev.c > +++ b/drivers/watchdog/watchdog_dev.c > @@ -99,7 +99,7 @@ static inline bool watchdog_need_worker(struct watchdog_device *wdd) > { > /* All variables in milli-seconds */ > unsigned int hm = wdd->max_hw_heartbeat_ms; > - unsigned int t = wdd->timeout * 1000; > + unsigned int t = wdd->timeout * MSEC_PER_SEC; > > /* > * A worker to generate heartbeat requests is needed if all of the > @@ -121,7 +121,7 @@ static inline bool watchdog_need_worker(struct watchdog_device *wdd) > static ktime_t watchdog_next_keepalive(struct watchdog_device *wdd) > { > struct watchdog_core_data *wd_data = wdd->wd_data; > - unsigned int timeout_ms = wdd->timeout * 1000; > + unsigned int timeout_ms = wdd->timeout * MSEC_PER_SEC; > ktime_t keepalive_interval; > ktime_t last_heartbeat, latest_heartbeat; > ktime_t virt_timeout; >
On Fri, Mar 06, 2020 at 07:20:29AM -0800, Guenter Roeck wrote: > On 3/6/20 5:27 AM, Sergey.Semin@baikalelectronics.ru wrote: > > From: Serge Semin <Sergey.Semin@baikalelectronics.ru> > > > > For better readability replace the numeric literals with globally > > available xSEC_PER_SEC macro. > > > > This is really completely unrelated to the rest of the series, > and I don't really see the point. I am fine with such changes if there > are some context changes around it, but otherwise they add no value > other than being a potential source of backport conflicts. It's up to you, since you are the subsystem maintainer. I'll drop the patch in v2. -Sergey > > Guenter > > > Signed-off-by: Serge Semin <Sergey.Semin@baikalelectronics.ru> > > Signed-off-by: Alexey Malahov <Alexey.Malahov@baikalelectronics.ru> > > Cc: Thomas Bogendoerfer <tsbogend@alpha.franken.de> > > Cc: Paul Burton <paulburton@kernel.org> > > Cc: Ralf Baechle <ralf@linux-mips.org> > > --- > > drivers/watchdog/watchdog_dev.c | 4 ++-- > > 1 file changed, 2 insertions(+), 2 deletions(-) > > > > diff --git a/drivers/watchdog/watchdog_dev.c b/drivers/watchdog/watchdog_dev.c > > index 8b5c742f24e8..a1a3bbe21653 100644 > > --- a/drivers/watchdog/watchdog_dev.c > > +++ b/drivers/watchdog/watchdog_dev.c > > @@ -99,7 +99,7 @@ static inline bool watchdog_need_worker(struct watchdog_device *wdd) > > { > > /* All variables in milli-seconds */ > > unsigned int hm = wdd->max_hw_heartbeat_ms; > > - unsigned int t = wdd->timeout * 1000; > > + unsigned int t = wdd->timeout * MSEC_PER_SEC; > > > > /* > > * A worker to generate heartbeat requests is needed if all of the > > @@ -121,7 +121,7 @@ static inline bool watchdog_need_worker(struct watchdog_device *wdd) > > static ktime_t watchdog_next_keepalive(struct watchdog_device *wdd) > > { > > struct watchdog_core_data *wd_data = wdd->wd_data; > > - unsigned int timeout_ms = wdd->timeout * 1000; > > + unsigned int timeout_ms = wdd->timeout * MSEC_PER_SEC; > > ktime_t keepalive_interval; > > ktime_t last_heartbeat, latest_heartbeat; > > ktime_t virt_timeout; > > >
diff --git a/drivers/watchdog/watchdog_dev.c b/drivers/watchdog/watchdog_dev.c index 8b5c742f24e8..a1a3bbe21653 100644 --- a/drivers/watchdog/watchdog_dev.c +++ b/drivers/watchdog/watchdog_dev.c @@ -99,7 +99,7 @@ static inline bool watchdog_need_worker(struct watchdog_device *wdd) { /* All variables in milli-seconds */ unsigned int hm = wdd->max_hw_heartbeat_ms; - unsigned int t = wdd->timeout * 1000; + unsigned int t = wdd->timeout * MSEC_PER_SEC; /* * A worker to generate heartbeat requests is needed if all of the @@ -121,7 +121,7 @@ static inline bool watchdog_need_worker(struct watchdog_device *wdd) static ktime_t watchdog_next_keepalive(struct watchdog_device *wdd) { struct watchdog_core_data *wd_data = wdd->wd_data; - unsigned int timeout_ms = wdd->timeout * 1000; + unsigned int timeout_ms = wdd->timeout * MSEC_PER_SEC; ktime_t keepalive_interval; ktime_t last_heartbeat, latest_heartbeat; ktime_t virt_timeout;