diff mbox

[05/19] rtlwifi: use to_delayed_work()

Message ID 1d07f186a933c2d1f0bf1780ab1dcb50d3a808aa.1458262312.git.julian.calaby@gmail.com (mailing list archive)
State Accepted
Delegated to: Kalle Valo
Headers show

Commit Message

Julian Calaby March 18, 2016, 2:22 a.m. UTC
From: Geliang Tang <geliangtang@163.com>

Use to_delayed_work() instead of open-coding it.

Signed-off-by: Geliang Tang <geliangtang@163.com>
[Update commit message]
Signed-off-by: Julian Calaby <julian.calaby@gmail.com>
---
 drivers/net/wireless/realtek/rtlwifi/wifi.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Larry Finger March 18, 2016, 2:44 a.m. UTC | #1
On 03/17/2016 09:22 PM, Julian Calaby wrote:
> From: Geliang Tang <geliangtang@163.com>
>
> Use to_delayed_work() instead of open-coding it.
>
> Signed-off-by: Geliang Tang <geliangtang@163.com>
> [Update commit message]
> Signed-off-by: Julian Calaby <julian.calaby@gmail.com>

Acked-by: Larry Finger <Larry.Finger@lwfinger.net>

Larry

> ---
>   drivers/net/wireless/realtek/rtlwifi/wifi.h | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/net/wireless/realtek/rtlwifi/wifi.h b/drivers/net/wireless/realtek/rtlwifi/wifi.h
> index 554d814..edece53 100644
> --- a/drivers/net/wireless/realtek/rtlwifi/wifi.h
> +++ b/drivers/net/wireless/realtek/rtlwifi/wifi.h
> @@ -2867,7 +2867,7 @@ value to host byte ordering.*/
>   	(ppsc->cur_ps_level |= _ps_flg)
>
>   #define container_of_dwork_rtl(x, y, z) \
> -	container_of(container_of(x, struct delayed_work, work), y, z)
> +	container_of(to_delayed_work(x), y, z)
>
>   #define FILL_OCTET_STRING(_os, _octet, _len)	\
>   		(_os).octet = (u8 *)(_octet);		\
>

--
To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/drivers/net/wireless/realtek/rtlwifi/wifi.h b/drivers/net/wireless/realtek/rtlwifi/wifi.h
index 554d814..edece53 100644
--- a/drivers/net/wireless/realtek/rtlwifi/wifi.h
+++ b/drivers/net/wireless/realtek/rtlwifi/wifi.h
@@ -2867,7 +2867,7 @@  value to host byte ordering.*/
 	(ppsc->cur_ps_level |= _ps_flg)
 
 #define container_of_dwork_rtl(x, y, z) \
-	container_of(container_of(x, struct delayed_work, work), y, z)
+	container_of(to_delayed_work(x), y, z)
 
 #define FILL_OCTET_STRING(_os, _octet, _len)	\
 		(_os).octet = (u8 *)(_octet);		\