diff mbox

atmel: use memdup_user to simplify the code

Message ID 20180604103210.23984-1-yuehaibing@huawei.com (mailing list archive)
State Accepted
Commit 8668f9a57c8c551f3e6a45d2733e64686c7b7904
Delegated to: Kalle Valo
Headers show

Commit Message

Yue Haibing June 4, 2018, 10:32 a.m. UTC
use existing memdup_user() helper function instead of open-coding

Signed-off-by: YueHaibing <yuehaibing@huawei.com>
---
 drivers/net/wireless/atmel/atmel.c | 11 +++--------
 1 file changed, 3 insertions(+), 8 deletions(-)

Comments

Kalle Valo June 27, 2018, 4:06 p.m. UTC | #1
YueHaibing <yuehaibing@huawei.com> wrote:

> use existing memdup_user() helper function instead of open-coding
> 
> Signed-off-by: YueHaibing <yuehaibing@huawei.com>

Patch applied to wireless-drivers-next.git, thanks.

8668f9a57c8c atmel: use memdup_user to simplify the code
diff mbox

Patch

diff --git a/drivers/net/wireless/atmel/atmel.c b/drivers/net/wireless/atmel/atmel.c
index d122386..30b479a 100644
--- a/drivers/net/wireless/atmel/atmel.c
+++ b/drivers/net/wireless/atmel/atmel.c
@@ -2657,14 +2657,9 @@  static int atmel_ioctl(struct net_device *dev, struct ifreq *rq, int cmd)
 			break;
 		}
 
-		if (!(new_firmware = kmalloc(com.len, GFP_KERNEL))) {
-			rc = -ENOMEM;
-			break;
-		}
-
-		if (copy_from_user(new_firmware, com.data, com.len)) {
-			kfree(new_firmware);
-			rc = -EFAULT;
+		new_firmware = memdup_user(com.data, com.len);
+		if (IS_ERR(new_firmware)) {
+			rc = PTR_ERR(new_firmware);
 			break;
 		}