mbox series

[bpf-next,0/6] libbpf: rename btf__get_from_id() and btf__load() APIs, support split BTF

Message ID 20210714141532.28526-1-quentin@isovalent.com (mailing list archive)
Headers show
Series libbpf: rename btf__get_from_id() and btf__load() APIs, support split BTF | expand

Message

Quentin Monnet July 14, 2021, 2:15 p.m. UTC
As part of the effort to move towards a v1.0 for libbpf [0], this set
improves some confusing function names related to BTF loading from and to
the kernel:

- btf__load() becomes btf__load_into_kernel().
- btf__get_from_id becomes btf__load_from_kernel_by_id().
- A new version btf__load_from_kernel_by_id_split() extends the former to
  add support for split BTF.

The old functions are not removed yet, but marked as deprecated.

The last patch is a trivial change to bpftool to add support for dumping
split BTF objects by referencing them by their id (and not only by their
BTF path).

[0] https://github.com/libbpf/libbpf/wiki/Libbpf:-the-road-to-v1.0#btfh-apis

Quentin Monnet (6):
  libbpf: rename btf__load() as btf__load_into_kernel()
  libbpf: rename btf__get_from_id() as btf__load_from_kernel_by_id()
  tools: replace btf__get_from_id() with btf__load_from_kernel_by_id()
  libbpf: explicitly mark btf__load() and btf__get_from_id() as
    deprecated
  libbpf: add split BTF support for btf__load_from_kernel_by_id()
  tools: bpftool: support dumping split BTF by id

 tools/bpf/bpftool/btf.c                      |  2 +-
 tools/bpf/bpftool/btf_dumper.c               |  2 +-
 tools/bpf/bpftool/map.c                      |  4 ++--
 tools/bpf/bpftool/prog.c                     |  6 +++---
 tools/lib/bpf/btf.c                          | 15 ++++++++++++---
 tools/lib/bpf/btf.h                          | 10 ++++++++--
 tools/lib/bpf/libbpf.c                       |  4 ++--
 tools/lib/bpf/libbpf.map                     |  7 +++++++
 tools/perf/util/bpf-event.c                  |  4 ++--
 tools/perf/util/bpf_counter.c                |  2 +-
 tools/testing/selftests/bpf/prog_tests/btf.c |  2 +-
 11 files changed, 40 insertions(+), 18 deletions(-)

Comments

John Fastabend July 16, 2021, 3:28 a.m. UTC | #1
Quentin Monnet wrote:
> As part of the effort to move towards a v1.0 for libbpf [0], this set
> improves some confusing function names related to BTF loading from and to
> the kernel:
> 
> - btf__load() becomes btf__load_into_kernel().
> - btf__get_from_id becomes btf__load_from_kernel_by_id().
> - A new version btf__load_from_kernel_by_id_split() extends the former to
>   add support for split BTF.
> 
> The old functions are not removed yet, but marked as deprecated.
> 
> The last patch is a trivial change to bpftool to add support for dumping
> split BTF objects by referencing them by their id (and not only by their
> BTF path).
> 
> [0] https://github.com/libbpf/libbpf/wiki/Libbpf:-the-road-to-v1.0#btfh-apis
> 
> Quentin Monnet (6):
>   libbpf: rename btf__load() as btf__load_into_kernel()
>   libbpf: rename btf__get_from_id() as btf__load_from_kernel_by_id()
>   tools: replace btf__get_from_id() with btf__load_from_kernel_by_id()
>   libbpf: explicitly mark btf__load() and btf__get_from_id() as
>     deprecated
>   libbpf: add split BTF support for btf__load_from_kernel_by_id()
>   tools: bpftool: support dumping split BTF by id
> 
>  tools/bpf/bpftool/btf.c                      |  2 +-
>  tools/bpf/bpftool/btf_dumper.c               |  2 +-
>  tools/bpf/bpftool/map.c                      |  4 ++--
>  tools/bpf/bpftool/prog.c                     |  6 +++---
>  tools/lib/bpf/btf.c                          | 15 ++++++++++++---
>  tools/lib/bpf/btf.h                          | 10 ++++++++--
>  tools/lib/bpf/libbpf.c                       |  4 ++--
>  tools/lib/bpf/libbpf.map                     |  7 +++++++
>  tools/perf/util/bpf-event.c                  |  4 ++--
>  tools/perf/util/bpf_counter.c                |  2 +-
>  tools/testing/selftests/bpf/prog_tests/btf.c |  2 +-
>  11 files changed, 40 insertions(+), 18 deletions(-)
> 
> -- 
> 2.30.2
> 

For the series.

Acked-by: John Fastabend <john.fastabend@gmail.com>