mbox series

[RESEND,net-next,0/2] Remove duplicate code around MTU

Message ID 20210720200628.16805-1-vfedorenko@novek.ru (mailing list archive)
Headers show
Series Remove duplicate code around MTU | expand

Message

Vadim Fedorenko July 20, 2021, 8:06 p.m. UTC
This patchset is intended to remove duplicated code around MTU calculation
and consolidate in one function. Also it alignes IPv4 and IPv6 code in
functions naming and usage

Vadim Fedorenko (2):
  net: ipv6: introduce ip6_dst_mtu_maybe_forward
  net: ipv4: Consolidate ipv4_mtu and ip_dst_mtu_maybe_forward

 include/net/ip.h                   | 22 ++++++++++++++++++----
 include/net/ip6_route.h            |  5 +++--
 net/ipv4/route.c                   | 21 +--------------------
 net/ipv6/ip6_output.c              |  2 +-
 net/ipv6/route.c                   | 20 +-------------------
 net/netfilter/nf_flow_table_core.c |  2 +-
 6 files changed, 25 insertions(+), 47 deletions(-)

Comments

patchwork-bot+netdevbpf@kernel.org July 21, 2021, 4 p.m. UTC | #1
Hello:

This series was applied to netdev/net-next.git (refs/heads/master):

On Tue, 20 Jul 2021 23:06:26 +0300 you wrote:
> This patchset is intended to remove duplicated code around MTU calculation
> and consolidate in one function. Also it alignes IPv4 and IPv6 code in
> functions naming and usage
> 
> Vadim Fedorenko (2):
>   net: ipv6: introduce ip6_dst_mtu_maybe_forward
>   net: ipv4: Consolidate ipv4_mtu and ip_dst_mtu_maybe_forward
> 
> [...]

Here is the summary with links:
  - [RESEND,net-next,1/2] net: ipv6: introduce ip6_dst_mtu_maybe_forward
    https://git.kernel.org/netdev/net-next/c/427faee167bc
  - [RESEND,net-next,2/2] net: ipv4: Consolidate ipv4_mtu and ip_dst_mtu_maybe_forward
    https://git.kernel.org/netdev/net-next/c/ac6627a28dbf

You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html