mbox series

[net-next,v2,0/2] Couple of minor improvements to build_skb variants

Message ID 20230308131720.2103611-1-gal@nvidia.com (mailing list archive)
Headers show
Series Couple of minor improvements to build_skb variants | expand

Message

Gal Pressman March 8, 2023, 1:17 p.m. UTC
First patch replaces open-coded occurrences of
skb_propagate_pfmemalloc() in build_skb() and build_skb_around().
The secnod patch adds a likely() to the skb allocation in build_skb().

Changelog -
v1->v2: https://lore.kernel.org/netdev/20230215121707.1936762-1-gal@nvidia.com/
* Add 'frag_size' into the likely call

Thanks

Gal Pressman (2):
  skbuff: Replace open-coded skb_propagate_pfmemalloc()s
  skbuff: Add likely to skb pointer in build_skb()

 net/core/skbuff.c | 8 +++-----
 1 file changed, 3 insertions(+), 5 deletions(-)

Comments

patchwork-bot+netdevbpf@kernel.org March 11, 2023, 1 a.m. UTC | #1
Hello:

This series was applied to netdev/net-next.git (main)
by Jakub Kicinski <kuba@kernel.org>:

On Wed, 8 Mar 2023 15:17:18 +0200 you wrote:
> First patch replaces open-coded occurrences of
> skb_propagate_pfmemalloc() in build_skb() and build_skb_around().
> The secnod patch adds a likely() to the skb allocation in build_skb().
> 
> Changelog -
> v1->v2: https://lore.kernel.org/netdev/20230215121707.1936762-1-gal@nvidia.com/
> * Add 'frag_size' into the likely call
> 
> [...]

Here is the summary with links:
  - [net-next,v2,1/2] skbuff: Replace open-coded skb_propagate_pfmemalloc()s
    https://git.kernel.org/netdev/net-next/c/566b6701d5df
  - [net-next,v2,2/2] skbuff: Add likely to skb pointer in build_skb()
    https://git.kernel.org/netdev/net-next/c/3c6401266f91

You are awesome, thank you!