mbox series

[net-next,v5,0/6] Support symmetric RSS (Toeplitz) hash

Message ID 20231018170635.65409-1-ahmed.zaki@intel.com (mailing list archive)
Headers show
Series Support symmetric RSS (Toeplitz) hash | expand

Message

Ahmed Zaki Oct. 18, 2023, 5:06 p.m. UTC
Patch 1 adds the support at the Kernel level, allowing the user to set a
symmetric RSS hash for any flow type via:

    # ethtool -N|-U eth0 rx-flow-hash <flow_type> s|d|f|n symmetric-xor

Support for the new "symmetric-xor" flag will be later sent to the
"ethtool" user-space tool.

Patch 2 fixes a long standing bug with the register values. The bug has
been benign for now since only (asymmetric) Toeplitz hash (Zero) has been
used.

Patches 3 and 4 lay some groundwork refactoring. While the first is
mainly cosmetic, the second is needed since there is no more room in the
previous 64-bit RSS profile ID for the symmetric attribute introduced in 
the next patch.

Finally, patches 5 and 6 add the symmetric Toeplitz support for the ice 
(E800 PFs) and the iAVF drivers.

---
v5: move sanity checks from ethtool/ioctl.c to ice's and iavf's rxfnc
    drivers entries (patches 5 and 6).
v4: add a comment to "#define RXH_SYMMETRIC_XOR" (in uapi/linux/ethtool.h)
v3: rename "symmetric" to "symmetric-xor" and drop "Fixes" tag in patch 2.
v2: fixed a "Reviewed by" to "Reviewed-by", also need to cc maintainers.

Ahmed Zaki (4):
  net: ethtool: allow symmetric-xor RSS hash for any flow type
  ice: fix ICE_AQ_VSI_Q_OPT_RSS_* register values
  ice: refactor the FD and RSS flow ID generation
  iavf: enable symmetric RSS Toeplitz hash

Jeff Guo (1):
  ice: enable symmetric RSS Toeplitz hash for any flow type

Qi Zhang (1):
  ice: refactor RSS configuration

 Documentation/networking/scaling.rst          |   6 +
 .../net/ethernet/intel/iavf/iavf_adv_rss.c    |   8 +-
 .../net/ethernet/intel/iavf/iavf_adv_rss.h    |   3 +-
 .../net/ethernet/intel/iavf/iavf_ethtool.c    |  33 +-
 drivers/net/ethernet/intel/ice/ice.h          |   2 +
 .../net/ethernet/intel/ice/ice_adminq_cmd.h   |   8 +-
 drivers/net/ethernet/intel/ice/ice_common.h   |   1 +
 drivers/net/ethernet/intel/ice/ice_ethtool.c  |  25 +-
 .../net/ethernet/intel/ice/ice_ethtool_fdir.c |  35 +-
 .../net/ethernet/intel/ice/ice_flex_pipe.c    |  43 +-
 .../net/ethernet/intel/ice/ice_flex_pipe.h    |   4 +-
 .../net/ethernet/intel/ice/ice_flex_type.h    |   7 +
 drivers/net/ethernet/intel/ice/ice_flow.c     | 439 +++++++++++++-----
 drivers/net/ethernet/intel/ice/ice_flow.h     |  46 +-
 .../net/ethernet/intel/ice/ice_hw_autogen.h   |   4 +
 drivers/net/ethernet/intel/ice/ice_lib.c      | 117 ++---
 drivers/net/ethernet/intel/ice/ice_main.c     |  49 +-
 drivers/net/ethernet/intel/ice/ice_type.h     |   1 +
 drivers/net/ethernet/intel/ice/ice_virtchnl.c |  55 ++-
 .../ethernet/intel/ice/ice_virtchnl_fdir.c    |  35 +-
 include/linux/avf/virtchnl.h                  |  16 +-
 include/uapi/linux/ethtool.h                  |  21 +-
 22 files changed, 652 insertions(+), 306 deletions(-)

Comments

Jakub Kicinski Oct. 18, 2023, 5:57 p.m. UTC | #1
On Wed, 18 Oct 2023 11:06:29 -0600 Ahmed Zaki wrote:
> v5: move sanity checks from ethtool/ioctl.c to ice's and iavf's rxfnc
>     drivers entries (patches 5 and 6).

What about the discussion with Alex?
I thought you'd move the flag out of RXH_ into a separate field,
key-preproc, sub-algo, whatever..
Ahmed Zaki Oct. 18, 2023, 6:21 p.m. UTC | #2
On 2023-10-18 11:57, Jakub Kicinski wrote:
> On Wed, 18 Oct 2023 11:06:29 -0600 Ahmed Zaki wrote:
>> v5: move sanity checks from ethtool/ioctl.c to ice's and iavf's rxfnc
>>      drivers entries (patches 5 and 6).
> 
> What about the discussion with Alex?
> I thought you'd move the flag out of RXH_ into a separate field,
> key-preproc, sub-algo, whatever..

I did not mean the discussions are over, these are just the latest 
agreed-upon changes. Please mark it accordingly until we reach an 
agreement on the user interface.