mbox series

[iproute2,v5,0/7] configure: add support for libdir option

Message ID cover.1634199240.git.aclaudi@redhat.com (mailing list archive)
Headers show
Series configure: add support for libdir option | expand

Message

Andrea Claudi Oct. 14, 2021, 8:50 a.m. UTC
This series add support for the libdir parameter in iproute2 configure
script. The idea is to make use of the fact that packaging systems may
assume that 'configure' comes from autotools allowing a syntax similar
to the autotools one, and using it to tell iproute2 where the distro
expects to find its lib files.

Patches 1-2 fix a parsing issue on current configure options, that may
trigger an endless loop when no value is provided with some options;

Patch 3 fixes a parsing issue bailing out when more than one value is
provided for a single option;

Patch 4 simplifies options parsing, moving semantic checks out of the
while loop processing options;

Patch 5 introduces support for the --opt=value style on current options,
for uniformity;

Patch 6 adds the --prefix option, that may be used by some packaging
systems when calling the configure script;

Patch 7 finally adds the --libdir option, and also drops the static
LIBDIR var from the Makefile.

Changelog:
----------
v4 -> v5
  - bail out when multiple values are provided with a single option
  - simplify option parsing and reduce code duplication, as suggested
    by Phil Sutter
  - remove a nasty eval on libdir option processing

v3 -> v4
  - fix parsing issue on '--include_dir' and '--libbpf_dir'
  - split '--opt value' and '--opt=value' use cases, avoid code
    duplication moving semantic checks on value to dedicated functions

v2 -> v3
  - fix parsing error on prefix and libdir options.

v1 -> v2
  - consolidate '--opt value' and '--opt=value' use cases, as suggested
    by David Ahern.
  - added patch 2 to manage the --prefix option, used by the Debian
    packaging system, as reported by Luca Boccassi, and use it when
    setting lib directory.

Andrea Claudi (7):
  configure: fix parsing issue on include_dir option
  configure: fix parsing issue on libbpf_dir option
  configure: fix parsing issue with more than one value per option
  configure: simplify options parsing
  configure: support --param=value style
  configure: add the --prefix option
  configure: add the --libdir option

 Makefile  |  7 ++---
 configure | 78 +++++++++++++++++++++++++++++++++++++++++--------------
 2 files changed, 63 insertions(+), 22 deletions(-)

Comments

David Ahern Oct. 16, 2021, 12:02 a.m. UTC | #1
On 10/14/21 2:50 AM, Andrea Claudi wrote:
> This series add support for the libdir parameter in iproute2 configure
> script. The idea is to make use of the fact that packaging systems may
> assume that 'configure' comes from autotools allowing a syntax similar
> to the autotools one, and using it to tell iproute2 where the distro
> expects to find its lib files.
> 
> Patches 1-2 fix a parsing issue on current configure options, that may
> trigger an endless loop when no value is provided with some options;
> 
> Patch 3 fixes a parsing issue bailing out when more than one value is
> provided for a single option;
> 
> Patch 4 simplifies options parsing, moving semantic checks out of the
> while loop processing options;
> 
> Patch 5 introduces support for the --opt=value style on current options,
> for uniformity;
> 
> Patch 6 adds the --prefix option, that may be used by some packaging
> systems when calling the configure script;
> 
> Patch 7 finally adds the --libdir option, and also drops the static
> LIBDIR var from the Makefile.
> 

applied to net-next. Thanks for working on this.
David Ahern Oct. 16, 2021, 12:02 a.m. UTC | #2
On 10/15/21 6:02 PM, David Ahern wrote:
> applied to net-next. Thanks for working on this.

sigh. iproute2-next