Message ID | 20220309223237.34507-4-jonathan.lemon@gmail.com (mailing list archive) |
---|---|
State | Superseded |
Delegated to: | Netdev Maintainers |
Headers | show |
Series | ptp: ocp: support for new firmware | expand |
Context | Check | Description |
---|---|---|
netdev/tree_selection | success | Clearly marked for net-next |
netdev/fixes_present | success | Fixes tag not required for -next series |
netdev/subject_prefix | success | Link |
netdev/cover_letter | success | Series has a cover letter |
netdev/patch_count | success | Link |
netdev/header_inline | success | No static functions without inline keyword in header files |
netdev/build_32bit | success | Errors and warnings before: 0 this patch: 0 |
netdev/cc_maintainers | success | CCed 3 of 3 maintainers |
netdev/build_clang | success | Errors and warnings before: 0 this patch: 0 |
netdev/module_param | success | Was 0 now: 0 |
netdev/verify_signedoff | success | Signed-off-by tag matches author and committer |
netdev/verify_fixes | success | No Fixes tag |
netdev/build_allmodconfig_warn | success | Errors and warnings before: 0 this patch: 0 |
netdev/checkpatch | success | total: 0 errors, 0 warnings, 0 checks, 32 lines checked |
netdev/kdoc | success | Errors and warnings before: 0 this patch: 0 |
netdev/source_inline | success | Was 0 now: 0 |
diff --git a/drivers/ptp/ptp_ocp.c b/drivers/ptp/ptp_ocp.c index 53b11c7f8fa0..c85ba3812b25 100644 --- a/drivers/ptp/ptp_ocp.c +++ b/drivers/ptp/ptp_ocp.c @@ -339,7 +339,7 @@ static struct ptp_ocp_eeprom_map fb_eeprom_map[] = { * 0: TS3 (and PPS) * 1: TS0 * 2: TS1 - * 3: GNSS + * 3: GNSS1 * 4: GNSS2 * 5: MAC * 6: TS2 @@ -540,7 +540,7 @@ static struct ocp_selector ptp_ocp_sma_out[] = { { .name = "10Mhz", .value = 0x00 }, { .name = "PHC", .value = 0x01 }, { .name = "MAC", .value = 0x02 }, - { .name = "GNSS", .value = 0x04 }, + { .name = "GNSS1", .value = 0x04 }, { .name = "GNSS2", .value = 0x08 }, { .name = "IRIG", .value = 0x10 }, { .name = "DCF", .value = 0x20 }, @@ -2288,7 +2288,7 @@ ptp_ocp_summary_show(struct seq_file *s, void *data) if (bp->ts0) { ts_reg = bp->ts0->mem; on = ioread32(&ts_reg->enable); - src = "GNSS"; + src = "GNSS1"; seq_printf(s, "%7s: %s, src: %s\n", "TS0", on ? " ON" : "OFF", src); } @@ -2371,7 +2371,7 @@ ptp_ocp_summary_show(struct seq_file *s, void *data) else if (val & 0x02) src = "MAC"; else if (val & 0x04) - src = "GNSS"; + src = "GNSS1"; else src = "----"; } else {
As there are may be 2 GNSS outputs, rename the first one for clarity. This also works around a parsing issue when specifying selectors. Signed-off-by: Jonathan Lemon <jonathan.lemon@gmail.com> --- drivers/ptp/ptp_ocp.c | 8 ++++---- 1 file changed, 4 insertions(+), 4 deletions(-)